Why doesn't my rover stop? (log included 4.0 and 4.1) the PRX data seem to have disappeared in the beta 4.1 data flash log

Hi, my rover FC omnibus 4.0 or 4.1 beta (does not change) with TF Luna lidar does not seem to stop at obstacles (in acro mode). I tried both the simple stop and the BendyRuler. The lidar reading is very accurate. Works well in manual and auto and acro mode.



Hi @Alberto_Ds, the first problem (as I see from your logs) is that you haven’t enabled Obstacle avoidance from the OA_TYPE parameter. So naturally, BendyRuler won’t work for you.
Secondly, BendyRuler is a path planning algorithm and only works in autonomous modes like AUTO, and GUIDED. It won’t work in manual, acro etc.

I just tested rover’s ACRO + simple avoidance in a simulator, and it seems to be working alright to me. If it works for you in other modes (like you mentioned) I don’t see any reason it should not work in acro… but I’ll still investigate a little more.


Thanks for the reply! Actually I haven’t tested the bendy ruler well yet (it’s raining outside) but the simple stop in indoor acro mode would be enough, instead my rover seems to have a hesitation, but then if I keep the command all the way forward it resumes the movement and hits the obstacle. my logs are made indoors (obviously without gps) to test the simple stop.

Can I keep the simple stop and the benyruler running together? I think so if the bendyruler only works in GPS mode

Hi, I tried (ardurover 4.1 beta) in outdoor (gps lock) with bendyruler and simple stop but no way, it doesn’t work.

No data in DataFlash log’s PRX messages …

Hi @Alberto_Ds. I am sorry that happened. If it’s a bug, I’ll look into it and with the next beta release, we’ll most likely be able to fix it. Can you send me the logs from your tests today so I can have a look?

Thanks a lot! This is the big log (4.1 beta 40 minutes of outdoor testing!)

Edit: sorry I may be wrong about this, I’ll check and let you know. Seems like Rover does not log RFND messages always… Not sure. In any case please check if your sensor is working in the proximity viewer because the PRX log messages should definitely be there…

Hi @Alberto_Ds,
I reviewed your log. Your parameters appear to be correct.
You are using a rangefinder yet I don’t see any RFND log messages in the logs (correct me if I am wrong).
This most likely means that there is a problem with the sensor/sensor to flight controller connection because any received data from the rangefinder is first logged in RFND message then as PRX message (after some filtering) and both are not present.

Can you once again check in the proximity viewer if everything is working? Maybe a wire came off somewhere? And if you test your rover again, can you check right before arming, if you’re getting a valid reading through MP? BendyRuler or Avoidance won’t work until we get the sensor data…

there is no RNGFND in the log but it works perfectly as you can see from the screenshots. The reading of the TF LUNA decreases when the rover approaches an obstacle, I can also see it in the telemetry, but the simple stop does not work either.




I seem to have the same issue with 4.1 beta and a TFmini plus. The obstacles are shown in the proximity screen. Simple avoidance is set to stop at obstacle, yet the rover drives right into the obstacle in acro mode.

Hi @count74 @Alberto_Ds,
Is this problem only in Rover 4.1 beta? Did you try 4.0 - stable acro? And is it also not working in other modes or is it limited to just Acro?

@count74 can you add your logs here as well?

I am going to try and add some additional logging before the next beta release so that we have an easier time debugging what’s happened. Thank you for your patience, hope we can get to the bottom of this.

Hi, same problem also with 4.0 stable (log 4.0 in this thread first post). Not working in all mode with or without GPS, for me.

Thanks a lot

I also noticed that in acro and steering mode, the rover continues its movement for a few moments even without stick input, this does not happen in manual.

@count74 @rishabsingh3003

do you have any news for this problem?

Hi @Alberto_Ds,
We have recently enabled logging for RangeFinder and Simple Avoidance on Rover.
This will go out with Rover beta 2.0. So when it comes out (which should be very soon), please flash your flight controller again, redo the test, and send us a log.
Everything seems to be working fine on simulators, and reports from other people, so the extra logs will help us in debugging what’s the problem in this particular case.
Sorry for the trouble this is causing you


I was out on a parking lot yesterday and the rover does not stop or avoid obstacles in any way. The distance to the obstacle is displayed, but that is all. I will upload a log later.

1 Like

@rishabsingh3003 @count74 @rmackay9

Hi all, this is log (indoor) with 4.1 beta 3.
now the rangefinder log seems to work, but the simple stop still does not work. I attach log.

Hi @Alberto_Ds. I am sorry I forgot to reply back.
Upon investigating further, I realized you were using an Omnibus F4 (As written above)? This is unfortunately a 1MB board and we have removed the support of Proximity Library because of flash memory limitations.
That is why the PRX data has disappeared.
To have those extra features in Rover 4.1, you would need a board with a bigger flash size. Sorry for the inconvenience.

Thanks for replay.

On 4.1 beta 3 range finder log works (see log above). Simple stop doesn’t even work on 4.0.

Could it work on older versions?

However, the removal of this function for FCs <1MB is not reported on the wiki.


We will update the documentation.
Here is the PR that removed the support. The affected FC’s are listed there if you are interested.

On 4.1 beta 3 range finder log works because we recently added a patch that enabled rangefinder logging on rover. I added that after you reported Range Finder was working, but there were no PRX logs. Just wanted to check if everything was fine with the Range Finder. Unfortunately, I had not realized by then that it was a 1MB board issue.

Simple Stop should still work in 4.0 though. I’ll go through your 4.0 log and see if we find something…

Thanks a lot …We hope that at least the simple stop works, otherwise a rover without obstacle avoidance would not make much sense.
We also hope that you can allow the user which functions to exclude and include in the 1MB firmware