Servers by jDrones

Yuneec ST16 Transmitter Support?

another possibility is that your sr24 module is for tx but not for rx.

you know yuneec use the same sr24 module in both the transmitter and drone
it is difficult to judge if one sr24 is for rx or tx from its appearance, since only the firmware inside is different.

It worked! I tried X-CTU’s serial console which is much simpler. I clearly had no business with the advanced features of Realterm.

I got the fast blinking light, then put the ST16 into bind mode and it turned solid.

…Now…I cant seem to get this pixhawk to recognize the receiver. Is there anything required to activate the DSM port?

sorry, I don’t have any experience with pixhawk.
what I’m trying now is to make an adaptor board using arduino, which can convert sr24 to standard pwm. then I can use it in my rc toys

@tridge - is there anything required to run the st24 RX protocol? FWIR, it should auto-recognize the RX protocol, correct?

Anyone? I need some help here…

Does the st24 protocol even function?

As far as I can tell the protocol should just work. I’ll try binding another receiver with that hex trick next weekend.

Binding worked perfectly using an Arduino to send the hex, but got the same manual control lost error in QGC. It seems that it decodes the first packet correctly and displays it, but fails on the rest. This looks like an error in the Pixhawk firmware, probably in the sr24 decoder. I’m going to try and copy the decoder code from GitHub and run it on an Arduino to debug it, if I can get it to work or if I find a bug I’ll open an issue on GitHub. Also, since Arducopter and Pixhawk are very similar it may very well be the same bug in both.

Binding has been working great. Ive successfully bound it many times now.

I am not sure where to see the “RCInput: …” message, but it is in the AP_HAL_ChibiOS/RCInput.cpp:

I tried watching the ‘messages’ tab in Mission planner, but it never showed up there. Mission planner just shows “No RC Receiver” in the HUD at all times and I get no response at the RC calibration page. I tried calibrating, but still nothing.

I can see the sticks moving around on the ST16 HW monitor page, but I am not sure if this is at the actual TX output point or at some point before that. At this time I can only assume that the stick movements are getting to the SR24.

I will try mavproxy and see If the “RCInput: decoding %s” shows itself.

It looks like other users are having trouble with Spektrum RX as well:

Unfortunately, it looks like the solution is commonly to bind in 11ms mode instead of 22ms mode. I dont think we have that option with the Yuneec SR24.

I noticed this comment:

In addition, beginning with ArduPilot firmware releases 4.0 and later, any UART RX input will auto-detect the RC receiver, if attached.

http://ardupilot.org/copter/docs/common-pixhawk-and-px4-compatible-rc-transmitter-and-receiver-systems.html#connecting-the-receiver

…Does that mean that we can connect the SR24 to ANY UART port? (Assuming the ST24.cpp protocol is functional, obviously)

Can you tell more about how to bind sr24 and st10c after sent the binding command to the sr24? While sr24’s yellow light is blinking my cc2531 could not capture any signal. If there are more commands for binding.

I havent tried using a packet sniffer.

Afik, there are no more commands. The SR24 will be in bind mode when the yellow light is blinking fast. Once you see the fast blinking light, you will have to browse through the menu on the ST10 and find the bind option. After you put the ST10 in bind mode, the light on the SR24 should go solid indicating that it is bound.

Do you have a solid light?

Thanks for your reply. After sending the bind command, the sr24 keep blinking. Maybe my sr24 is a tx module as Sheng Yao said(In fact I have 4 sr24) . And I have a st10c too, Sheng Yao said he could bind st10c and sr24. So I want to know the steps.

Servers by jDrones