Servers by jDrones

Spektrum Receiver

Hi everyone. I’m trying to connect a spektrum ar620 to a Pixhawk 2.4.8 running rover v4.0.0. I’m trying to run the radio calibration, but none of the sticks register. I have the ar620 connected to the SPKT/DSM connector and it powers up. Does anyone have any idea why it wouldn’t be working, did I order a receiver that is incompatible with the pixhawk? We’re trying to use this setup to test a vessel until I can write the needed code to control it over mavlink.

Thanks in advance.

Try binding using 11ms protocol instead of 22ms. I think it’s a F.Rate setting or something like that.

I already have the transmitter bound to the receiver. The light shows up showing they’re bound. The problem seems to be in the connection between the pixhawk and the spektrum ar620 itself. I had assumed it would work out of the box but could there be something I need to configure on the ar620?

Also I tried looking for the F.RATE parameter in the pixhawk parameters and I couldn’t find any.

The frame rate is between the TX and RX, and the pixhawk has trouble interpreting the RX if the frame rate is incorrect. The F.Rate is a Spektrum setting, not an ardupilot setting. Try re-binding after changing the frame rate.

From a recent facebook post to the ardupilot.org group:

Sorry I’ve been busy. Thank you, I will report back when I get time to actually set it up.

Just an update for everyone, the Spektrum transmitter we had only worked at 22ms but the pixhawk seems to only work at 11ms so we ended grabbing a PPM transmitter instead for now since we’re just going to control it from GPS and an offboard computer anyways.

Thanks for the help though. If the pixhawk is supposed to support 22ms please let me know and I’ll create an issue on github.

Already done! https://github.com/ArduPilot/ardupilot/issues/13117

Servers by jDrones