SmartAudio not working correctly any longer

SmartAudio has been working great for me at least since release 4.0. Now I have switched to 4.3.2 and it is no longer possible to get the lowest power level 25mW. Other levels work as earlier. I have same problem on two drones with similar setup which is:

  • FC is Mateksys H743 Slim and Lumeniere H743
  • VTx is the Eachine Tx805 which can transmit 25, 200, 600 and 800 mW
  • Receiver is Mateksys ELRS-R24-D 2.4GHz
  • ELRS tested in hybrid as well as wide mode and turning the FrSky QX7S S2 transmitter knob gives the levels described in the ELRS manual under the switches section. ELRS version is 2.5.1 and not changed.

If I set the VTX_OPTION to 0 and VTX_POWER to 25 and save the parameters the 25mW do activate but as soon as I turn the level up and back down the VTx goes into pitmode automatically and the VTX_OPTION is changed to 1 and the VTX_POWER stored is 200 instead of the 25mW level. Also the MP messages show that the lowest level 25mW is no longer activated turning the S2 switch.

Has anyone else experienced this and found a solution?

Sounds like a bug - quite likely as this area of code had a lot of rework in 4.3. Can you post your config and expain what you are expecting to happen?

Many thanks for your assistance Andy!
If I start with how it used to work when turning the Tx S2 potentiometer clockwise from bottom to full:

  • at bottom (~1000us) pitmode is automatically engaged
  • at ~1235us 25mW turned on
  • at ~1360us 200mW turned on
  • at ~1620us 600mW turned on
  • at ~1755us 800mW turned on

I have not noted where output values were noted from but I assume it is the channel output.

Current values as now seen from EDGE TX output for channel 9:

  • at bottom (~1000us) pitmode is automatically engaged
  • < ~1167us 25mW is never turned on
  • at ~1167us 200mW turns on. MP radio calibration page shows 1274
  • at ~1457us 600mW turns on. MP radio calibration page shows 1424
  • at ~1669us 800mW turns on. MP radio calibration page shows 1724

VTX- params as copied from MP are:
VTX_OPTIONS 1 (set by AC auomatically)
VTX_POWER 200 (set by AC automatically, used to be 25 at output 1000us when working correctly)

RC9 Params are:
RC9_DZ 0
RC9_MAX 2000
RC9_MIN 999
RC9_TRIM 1500

SERIAL4 params are:

I hope this is what you asked for but if complete config file is needed please tell me.

I might need to get you to try a debug build. We are now querying SmartAudio for the power levels and it is possible that the VTX is lying

Of course I will test whatever needed, just tell me the details.

I will do you a debug build - are you using the bdshot or regular version of the firmware?

I use the bdshot version.

Ok here is a debug version. You need to use mavproxy to see the output - if you can send me the output from boot with you twiddling the knob that would be great.

Sorry to say that I have used Mavproxy just once before and do not remember any “howto”. Assume I can find the docs and the installs but it will take me a little time to set it up (presumably). The firmware is installed and works.

Log.txt (6.0 KB)
Will this be OK?

Looks good. Any chance you can do another one where you basically try to set the power to 25mw and leave it there?

I do not think it matters but for the log you received I had changed from hybrid to wide resolution for ELRS which of course means higher resolution. Should I keep wide or go back to hybrid also?

Setting 25mW works fine provided pitmode is shutoff. When pitmode is set automatically power is again set to 200mW (at least for hybrid mode).

I will send a new log per your request.

Here I did set pitmode to off and power to 25mW using MP (because do not know how to do that using Mavproxy). Then I connected Mavproxy and also later turned upp the power etc.
Hopefully you will find what you are looking for here but if not I have to find out how to do the settings from Mavproxy,
Log2.txt (8.7 KB)

Here is another try made the same way. Seems to be a bug when adding attachments but hopefully log3 came even if it says log2.
Log2.txt (8.7 KB)

I found out how to do the settings from Mavproxy so here is a new log. I started by setting VTX_OPTIONS to 0 and VTX_POWER to 25, then turned the power up and down and finally went back to OPTIONS=0 and POWER=25
Log4.txt (9.5 KB)

I have an idea what is going on here - will need you to try a custom build

Great, just post it when ready.

Ok here is a build. Still has debug on so please send me the log when you try. Dropbox - arducopter.apj - Simplify your life

Smartaudio not working because of no radio communication. Rx led shows that radio has connected. After returning to 4.3.3 radio works again and a new try with the custom build gives same result, i e no radio.
Log5.txt (3.7 KB)

Log looks good. Can you try with this version? No way it should prevent RC working: