Prearm error GPS alt error 5850m (see BARO_ALTERR

Screenshot 2022-12-10 161610
i am getting an error while arming my pixhawk. also if i take flight in alt mode the drone crashes i.e it flips on one side please help me with it.

I have same problem
How to solve it plese help

I have same problem
How to solve it sir please help me

I am also getting this with PixHawk 2.4.8 (clone?) since upgrading to 4.3.1. Similar numbers to you guys as well, 5811m.

But when I look at the MavLink telemetry for GLOBAL_POSITIOM.alt and HOME_POSITION.altitude they are both very close to each other, I don’t see a 5km offset anywhere.

Hi, thanks for the report. If someone could post onboard logs that would be very helpful.

Hi friends. same problem. PreArm: Baro: GPS alt error 5850m (see BARO_ALTERR. 2022-12-23 23-55-58.txt (549.9 KB)
version tried 4.3.1 and 4.3.2 gps matek M10

Hi all - version 4.3.0 doesn’t have this issue and downgrading has me back in the air.

1 Like

Thanks . you’re right. version 4.3.0 no such messages.

Is yours also a PixHawk board Vlad?

yes. using PixHawk board no clone. model quadrocopter.

Hi,
Please go into config setting in mission planner and then click on parameter list and find BARO_ALTERR it will be 5000 change that parameter to 6000 and click on write the parameter it will get save into FC. The message will pop up as parameter save successfully.

The right solution is to tell Ardupilot that your board has the ‘other’ type of barometer chip.

BARO_OPTIONS=1

I’ve done this and now I’m flying okay with 4.3.2.

1 Like

I have already set baro_options at 1 still the error, so i have bought a ms5611 and connected it to i2c externally and it works. Manufacturer replaces ms5611 with 5607 for cost cutting, and thats why it happens. Particularly recent batch of pixhawk is faulty.

Sir reply about this problem BARO_GPS_ALT ERROR

I also have a 5607 baro on board. i set BARO_OPTIONS=1 and the error is gone. thank you very much.

2 Likes

Yes sir resolve this problem thanks a lot :pray:

2022-12-30 16-16-56.tlog (444.7 KB)

can someone please check what is wrong?

the quad is yawing while take off and getting stabilized after take off and altitude hole is not working properly.

the above is the bin file

That is only a .tlog. Please post the .bin file.

And please start a new thread for your copters problem, since it doesnt seem to be related to the subject of this thread.

If it is still the baro issue, make sure you are using latest firmware for Pixhawk1 (not FMUv2 or FMUv3)
and you have BARO_OPTIONS,1

1 Like

I removed baro 5607 and set 5611, set BARO_OPTIONS=0. Installed firmware 4.3.2 Now everything works well.