Pixhawk 6c with Elrs


Im experiencing some issues with my Pixhawk 6c and the Betafpv ELRS Nano receiver.
I wired it up to the Telem2 plug on the pixhawk but no stick outputs in Mission Planner are appearing.

The connection between the Transmitter and the receiver shoud be fine since theres a solid blue light and i also got a Telemetry output on the radio

And i changed some Settings in the Parameter Tree:

RSSI_type =3
RC_options = 9

Im still not sure if SERIAL 5 is the right UART but i tried other ones and also no output in mission planner
Does anyone have an idea what i could change?

Serial5 should be [Edit: “not”] correct for Pixhawk 6c.
RC_OPTIONS = 9 seems off.

For ELRS you need bit 13 (value 8192) for the right baud rate and I would recommend bit 5 (value 32) for “Arming check throttle for 0 input”, resulting in RC_OPTIONS = 8224

Pixhawk 6C
6C uart

I only had a quick glance at the Pixhawk 6c ports and assumed uart = serial. Try Serial2 then.

Also a quick follow-up regarding RC_OPTIONS: RC_OPTIONS = 9 is composed of bit 1 and bit 3. Bit 1 means “Ignore RC Receiver” which is probably the opposite what you want.

WOW, thank you so much for the fast help.
I now set the serial2= 23 serial2_baud = 32 and RC_options= 8224 and it worked instandly.

Thank you for solving my problem.

You are very welcome

Hello, I experiencing the same issues as Ixamm.

My Pixhawk is 2.4.8, Arducopter v4.5.0, receiver BetaFPV 14CH P900 @ 868 MHz, radio Horus X12s with BetaFPV micro module 868 MHz.

Radio is set to 400kbit, switch mode 8ch, packet rate 100Hz full.
I use Serial2 (Telem2).
I have set serial2_protocol= 23 serial2_baud = 32 and RC_options= 8224, RSSI_TYPE = 3, but still no stick outputs in Mission Planner are appearing.

Thanks very much in advance for any advice…

Configuration seems alright, how is it physically connected?

Also is the receiver set to CRSF output?

From receiver Tx to FC Rx and vice versa.
Receiver has set serial CRSF at CH 13 &14. The CH14 is set as serial Rx and CH13 as serial Tx.
But Im not sure about UART to be inverted or not (in the TX module setting), could it be the cause?

I have set in the Tx module:
Compatibility option: UART inverted (I think, this is recommended as default)

Is this your receiver? I couldn’t find anything with the “P900” addition.

If yes, then according to the BetaFPV product page receiver CH13 is Rx and CH14 is Tx (unless you can change that manually, which I don’t know about).

If switching Rx and Tx doesn’t help try inverted / not inverted.

1 Like

Thank you for your swift reply.
Yes, this is my receiver, and i have it correctly connected according to the picture. (Maybe I didnt wtite it exactly recently). So, i will try inverted or not inverted.

I flashed FW to the receiver (not to the transmitter!) and suddenly everything works like clockwork.
RC movements are transferred to Mission Planner, telemetry works too.

Thank you very much for your help (I couldn’t have figured out the parameters on my own), have a nice day, I send my regards from the Czech Republic!

1 Like

Great to hear it worked :+1:t2: