SpeedyBee F4 V3 + EP1 TCX0 - can't resoncile together

Hi Guys,

I want to build Rover based on SpeedyBee F4 V3 controler.

Please, advice me next steps or way to solve issue with connectivity between SpeedyBee board and EP1 radio.

I’m new in ardupilot (but with some experience in embedded tech), and want to setup SpeedyBee board as controller for the Rover.


  • SpeedyBee F4 V3 - controler
  • Happymodel EP1 TCX0 radio module
  • Rover V4.4.0 firmware
  • ELRS radio (CRSF protocol)
  • Сonfiguration (in missionPlanner, SpeedyBee board)
    SERIAL2_BAUD 115 (115200 same as on radio module)
    RSSI_TYPE 3 (ReceiverProtocol)
    RC_OPTIONS 512 (Suppress CRSF mode/rate message for ELRS systems )

What I alredy done:

  1. Soldered EP1 radio to SpeedyBee board.
  2. Set up all radio setting and verified that succefully receive data from radis module on R2 pin on SpeedyBee board (I’m using UART2) For verification I used UART->USB converted and succefuly parsed data on R2 pin (used python script)

After this all, in logs I still receiving zero in all channels

RCIN, 4216468, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0

Searching for information on forums, and experiments - so far have not brought success.

Which should be my next step for solving this issue? What I should check again or something new?

Thank You in advance!

Welcome to the community.

For ELRS you also need RC_OPTIONS bit 13 (value 8192, “Use 420kbaud for ELRS protocol”) for the right baud rate and I would recommend bit 5 (value 32, “Arming check throttle for 0 input”), resulting in RC_OPTIONS = 8736

It’s in the wiki: Crossfire and ELRS RC Systems
And in the forum: Pixhawk 6c with Elrs - #2 by Janno

1 Like

Thank You for the answer! I tried RC_OPTIONS = 8736 and still not working.

Do I need “Use 420kbaud for ELRS protocol” as I working on 115200 speed?

That’s at least what it sais in the wiki and it worked for me and two other people I was helping so far…
On the other hand, I never used bit 9 (512) before :man_shrugging:
Without bit 9 it would be RC_OPTIONS = 8224

Did you also connect to the T2 Pin on the FC as written here?

1 Like

Yes, I checked several times. As, in my case EP1 works via UART, RC tx ↔ rx FC. RC rx ↔ tx FC, power and ground.

There also mentions about pull-up resistor, but, as I understand, it is not me case.

Also (just saw a several minutes ago), in messages I repetitively see one message, maybe it is something important, trying to figure out this.

27.01.2024 23:06:45 : CRSFv2: requesting RX device info
27.01.2024 23:06:45 : CRSFv2: requesting RX device info
27.01.2024 23:06:44 : CRSFv2: requesting RX device info
27.01.2024 23:06:44 : CRSFv2: requesting RX device info
27.01.2024 23:06:43 : CRSFv2: requesting RX device info
27.01.2024 23:06:43 : CRSFv2: requesting RX device info

Seems alright to me.
Other than to try if maybe other UART ports work I’m out of ideas unfortunately.

This may be the issue. Reconfigure your receiver to use the default 420kbaud speed and then follow the AP wiki instructions.

1 Like

Thank You for advice.

Checked, 420kbaud didn’t help.

Maybe I should set some debug print info somewhere in code for debugging? now I’m able to build and run on my firmware (currently I’m using Rover 4.4.0)

Share pictures of your wiring and a copy of your parameter file.

Too many of us successfully use ELRS for this to be a bug that warrants custom firmware hooks.

1 Like

Here are wiring and other info. Also for RC_OPTIONS I tried several values (RC_OPTIONS = 8736,
RC_OPTIONS = 8192, RC_OPTIONS = 8224, and more)

Thank You!

message_log.txt (1.6 KB)

More data.
rover_settings.param (16.9 KB)

ah, yes, I do not have BRD_ALT_CONFIG in rover firmware (not yet sure should I have it or not)

Why would you change the receiver baud away from the default 420k?!

1 Like

On FC 460K means 460800 (see picture.)


So I changed on receiver to the same 460800

Was I wrong?

Completely wrong. You checked the bitmask to use 420k. We told you to do that, as it is the default behavior. And I literally told you to set 420k on your receiver yesterday.

1 Like

Sorry for misunderstanding. I will try it. Thank You very much for your patience!!

Many Thanks You for help!

After change this param to right one + some experimental - all works fine for me!!