ELRS + Omnibus F3 pro + Mission planner

Hello Everyone,
Its been a while since I am out Mission planner, after Covid things just stalled and I drifted away. Finally I decided to start again and found out the new long Elrs is in the market.

So I got new radio TX16s + Ranger 2.4 + Rp1 and RP2 package. I had the old setup which was running on FRSkY rx using Sbus, which I removed and replaced with ELRS 2.4ghz.

Let me start sharing the issue, after I installed the ELRS RP1 to one of the 4 pin UART G, +5v, Tx and rx ( wires are crossed from board to rx ( tx goes to rx and rx goes to tx).

The issue is that I am not able to receive any input from radio and mission planner does not show anything, I have try to change the input by switching the serial ports 1, 2,3 and 4 but nothing.

Any help to get it working will be appreciated.

Thanks in Advance

The easiest way to help you would be if you posted a .param file with your parameters.

What are your values for SERIALn_PROTOCOL, RSSI_TYPE, RC_OPTIONS? (n is the serial port number you are currently connected to)

Also have you tried searching for this problem in the wiki and/or in the forum? Maybe you can find a n answer here, here, here, here or here.

Thank you for reverting, i have searched could not find solution

Please have a look at the parameters



None of these ports is configured as RC input, no wonder it doesn’t work.

I did changed all the serial port one by one

speed - 115
Protcol - RCin

Stil it did not work

Then i revert back to default



connect the receiver to serial port n.
try again.

also are you sure it is an Omnibus F3 pro that you are using? Because this board does not have enough flash to run ArduPilot.

Hi Janno,
I have tried the above options, still nothing.

Currently I am using Mission Planner on the same board using FRSKY RX with Sbus, I am just trying to change the RX to ELRS.

Correction, yes you are right its F4 board with OSD and not F3.

have a look now