Nimbus Tricopter VTOL

Yeah, this looks like the crazy flight. You may have taken off before the home position was set. I’m not sure how to determine this from the log. I don’t like this red Event Flag called “AUTO_ARMED”. I also see that you have ARMING_CHECK set to 0 again. I’ve warned you before about this!

You can review the RTL settings in the WiKi here…I didn’t see anything wrong.

Next time, use the Yaapu telemetry or Mission Planner to determine that the home position has been set. Also set your ARMING_CHECK back to 1.

Hi Greg: I guess it didn’t show why the drone didn’t finish the RTH and we still don’t know why it took off as a fly away while in a RTL mode? Well i went out and got another Quad and checked the arming was on 1 yaapu alarms going nuts = can’t arm due to bad AHRS,bad Logging,3D accel cal needed,FS_THR_Value,GPS Glitch I’m dumb struck i go to RC groups and it seems i’m not the only one getting the bad AHRS ,GPS glitch bad logging and no one actually tells you how to fix it and the HUD in MP the only thing RED is BAD AHRS and i just don’t know how to fix this, heck 4 days ago i spent 1 1/2 hrs with the VTOL waiting for it to get rid of Bad AHRS and Arm but it never did so i packed it up cause the wind started gusting and never got to fly,looking back i can’t ever having these Problems with the APM ,2.4.6 so just keep at it something has to start sinking in Thanks B.K

Try to power up the vehicle where you want the home position to be. Also, do not move the vehicle until you get enough satellites to have an HDOP value <1.0. The Bad AHRS messages are often caused by the plane moving or by not having enough satellites for a good flight. A wind rocking the wings can cause the Bad AHRS message when the satellite count is low.

For some reason, on your fly-away flight, you kept gaining satellites (14-19) during the entire flight. This suggests that you didn’t wait long enough before arming and flying or that your take-off area is blocking 5 satellites.

If you don’t want to use Mission Planner on a laptop (or QCG on a tablet), use the power of the Yaapu telemetry. There should be an audible for when it sets the GPS Home position. Also, on the MavLink Messages screen (sample below) wait for the message that says something like “EKFx is using GPS” or something like that.

The newer versions of APM are more sensitive to issues that would have been covered up by older versions. This reveals problems in your build (remember your vibration issue?) and other issues that arise before and after take-off.

Sample of MavLink Messages Screen
screenshot_x9d _18-03-03_20-25-42

Hi Greg:Well this morning it seemed nothing on the J T16 Tx worked i could not get telem to work so i plugged into the computer and all was good by that time the wife had lunch waiting i left everything hooked up to see if it would sink in i don’t know about your horus but yaapu scripts won’t work without GPS after lunch i changed the micro usb in the Tx and started over now i have it working again i got 10 sat and .9 hdop the only fault is Bad Logging ive put 3 brand new usb cards in this Pix Cube black and it keeps says Bad Logging (got any tips for this fault) and Since we got Windy and possible chance of Rain for the next 3-4 days i’ll start checking out my other Models. Thanks B.K cheers


If you do a search on “Bad Logging” from the forum home page, you get quite a few hits!

This thread in particular has several suggestions.
Pixhawk bad logging error

  • Try formatting your SD card
  • Format the SD card with a FAT32
  • Try a different SD card…replacing the vendor supplied SD card
  • Go to mission planner, open full parameter list and make setting to its default; 65535

Yesterday, we woke up to snow on the roof and ground and it was still snowing. By the afternoon, the sun came out and all the snow melted, so it really was a Good Friday! :grinning:



I ran an Auto Analysis on your crash log. It’s easy for you to do by simply pressing the “Auto Analysis” button (as shown below) in the DataFlash Logs tab. The MAG_ENABLE error is explained by Dave below. So that leaves an “Odd” error with the VCC logging data and a “Bad” error with the compass.

It will be interesting to see what happens on your next flight with ARMING_CHECK set to 1 and waiting for the Home position to be announced. I have not used Copter 4.0 yet so maybe others can spot additional problems.


Hi Greg: i’ve tried to use the auto log and it just keep saying error(not available when used as a windows store app)? and i’ve been trying all day to get a GPS sensor on my drones to run the yaapu scripts and now for some reason it won’t thank GOD i shave my head i wouldn’t have hair anyway with Bad logging and NO GPS sensor constantly beeping WTH, I was going to update the yaapu scripts Built From Home has a new video with new& better features but right now i wouldn’t be able to run it i don’t know if the telem cables or the smart port or the wires are the prob however it reads the batt voltages fine IDK . LOL OH my friend sent me a Pic of the snow you guys got I bet you’re hoping for spring or at least good Hobby weather i feel for ya but its Hot and Windy here well i get some lunch and try to think and start over again HEY It’s a Hobby. Thanks B.K

It’s difficult to help you with your Yaapu problem. You should consider posting your issue on the Yaapu Thread and maybe Alex can help.

Where people stumble on the hardware setup is to set the appropriate SERIALx_PROTOCOL to 10 in the Pixhawk. I also see that the Jumper T16 requires JumperTX 2.2.3 or greater and uses the Horus version of Yaapu telemetry. Perhaps it would be easier to first get it working on your Taranis X9D as this would validate the hardware setup on the Pixhawk and the telemetry cable from the Pixhawk serial port to the FrSky receiver. After that, it’s just a setup issue when swapping radios to the Jumper T16.


Hi Greg:Yep i had all ( drones ) running yaapu with the X9D+SE Then i got the J T16 Pro to run the Maps and they were all working THEN a week ago after rebuilding that T-Quad that had the fly away and i couldn’t get it to have a GPS to display the Mapping feature then i tried the other ones and now none of them display yaapu maps but 2 because of NO GPS, i’ve tried switching serial ports on the pix and that didn’t help, i tried deleting all sensors and then discover sensors and now only 4 sensors show up TRSS,TQly RSSI RXBt, OMG i had a quad sitting outside about 4 hrs ,Batt hooked up looked out thought i better bring it in the sun was hitting it and getting Hot so i thought i’d try to see if it was still not getting a gps and too my delight everythings working now i got 3Dlock 12 sats 0.8 hdop the maps showing my position in the RV Park IDK I don’t get it i am getting Bad logging and a gps glitch then it clears i even armed it and held it up and started the motors i thro off everything working fine now on this one . Ok Thanks B.K

Perhaps the “NO GPS” alert from the Yaapu telemetry is real. You need to connect to your quad using Mission Planner and verify that GPS is working…especially the next time you get that message on the Yaapu telemetry. It’s important to also use the 3DR telemetry link on a laptop or tablet so you have a tie-breaker.

I have seen these issues before on one of my older VTOLs. It turned out to be an intermittent Pixhawk, so I replaced it with a new v2.4.8 Pixhawk, loaded the saved .param file and everything worked again. I tossed the old Pixhawk that I had used for many years.

Hi Greg:Thats what was bothering me i start Mp and waited till i had gps lock and hdop 1.0 then fired up the Tx and plugged in the voltage sensor and the battery everything was good on the MP HUD except NO RC until it bind and the ever Bad Logging error i might of agreed with you on a bad pixhawk but not 7 and one Cube tomorrow,So i’m wiping every thing out re flashing the Tx and reinstall all my models and redo the yaapu script if that fails i’ll try the Taranis and forget the maps or i rebind a model using the taranis if that works then try the Jumper Tx without the maps hey lots of possibilities lol and it’s a Hobby mess things up and fix it hopefully learn something Thanks for being patient.B.K

Hi Greg:I started doing the Taranis Plus and i went to up Grade the Firmware and Tried to put it in boot mode and the screen turned white and made a constant funny buzzing noise i unplugged from the computer turned it off and tried several times only with the same result, and i just turned it on all my models,sounds,settings were there everything seem to work i just can’t get it into bootloader mode,Has this ever happened to you/any idea’s. So Then i did the old Taranis and everything worked fine. Then i did the Jumper T16 Pro and it to upgraded to 2.3.7 without any prob also the weird thing while Binding to a drone it would take upwards to 1 to 4/5 hrs to find it’s way to home and then another hr or 2 to get the hdop to 1.0 to get a gps 3dlock to get the mapping feature to work and another weird thing when the wind would blow 20 to 30 mph and the harder it blew the hdop would go up wth. The upgraded Mapping for the Horus sucks or atleast until Built From Home puts another Video out cause that one upgrade wiped out all the widgets except the main screen and the Mapping screen but i can’t add any thing to the screen ie, voltage,l-cell rssi etc i mesg him but no reply so far to see if he’s going to do another Vid soon to be able to add all the stuff yaapu scripts shows,(sorry for the rant) take care and Thanks.B.K

No, never. Go to the Radios forum on RC Groups and post into the Taranis How-To thread.

You are getting GPS interference from your FrSky telemetry. Move the GPS puck away from the FrSky receiver antennas (which is also a transmitter for telemetry) or raise the GPS puck higher.

What is Built From Home?

Hi:Greg; they say it sounds like my bootloader is corrupt it on the Sd card firmware folder file then put it back in and flash it using the transmitter, i’m waiting on the clock battery.
Built from Home is the youtube chan i followed him to learn how to put yaapu script on the Jumper T16 Pro.
Thanks B.K

Ok, I see. Wow, he’s so young but makes a good video. I just wanted to confirm that you weren’t compiling stuff on your own…hence “built” from home. :smiley:

Hi Greg: Thanks for Looking out for me i really appreciate it (I Really Do),Oh yea those hubsan shades you put on your Horus i ordered 2 of them and they came in yesterday and i put one on this jumper Tx and it works really good thanks for that tip. Thanks again.B.K

Hi Greg: I found the GPS problem wrong Baud Rate in MP. B.K

Ok, that’s odd. I’m looking at your Tarot fly-away .param file and all looks well. What Pixhawk are you using?

  • SERIAL0_BAUD,115 (USB)
  • SERIAL1_BAUD,57 (Telem1)
  • SERIAL2_BAUD,57 (Telem2)
  • SERIAL3_BAUD,38 (GPS1)
  • SERIAL4_BAUD,38 (Serial4)
  • SERIAL5_BAUD,57 (Serial5)

Hello Everyone,

I have been following this thread since January and it definitely encouraged me to jump into the VTOL frenzy. I’ve been working with multi-rotors only so far and i hope this would be a wonderful up-grade, and hopefully a smooth one with all the help available from you guys.

I wanted to have some DIY fun with Tilt-Rotor so i placed an order for Nimbus 1800 RC plane from Foxtech
along with the tilting mechanism

I have finally received a grey Nimbus airframe after quite a bit of delay. Looks awesome

Here is the list of components i have arranged for this build:

2x Scorpion 4020-540 (Yeah, i do think its an overkill but it was the only option available locally)
APC 14x8.5E (Front Motors)
1x T-Motor MN 505S 380KV Tail Motor with T-Motor 17x5.8 Carbon Prop
Tattu 12000mAH 15C LiPo
Pixhawk 2.1 Cube Black

I have read about the cheap Tail servos on Foxtech Nimbus failing for many people and i will be replacing them with the recommended part. I want to ask if there are other known problems with the airframe and stock components that i might have missed in the conversations above.

It would be great if we can collectively formulate a tutorial for the beginners starting out with Nimbus, summarising all the findings in this thread and listing them as one post. What i think could be on the list is:

  1. List of components to up-grade from stock frame (Tail servo being the prime example)
  2. Recommended forward drive
  3. List of improvement parts for Nimbus (STL and more)
  4. Parameter file (with only the key parameters that can be used by all while setting up from scratch)
  5. Flight time with different drive/battery combinations

And more can be added as we go along. Just a suggestion and i would love to contribute where i can although will take a month or so to get to position where i can contribute.

Looking forward to great help from you guys :slight_smile:

Hey Greg: I’m using Pix 1 for The VTOL and 6 other drones, I got two Pix Cube black and one using APM, So the weather is crappy i got the VTOL Out to just check too see if everything is still good to go WTH Nothing works some of the sticks and switches aren’t registering or saying what i prog them to say i’m not liking that last yaapu script i installed on this T16 it’s either that or my stupidity so i’ll revert back to the older version and if that don’t work then hopefully the X9D+ Batt will be here and i’ll go back to my Taranis (LOL i should of waited and got the Horus), One Day everything works great a week later nothing does WOW what a Hobby. Thanks for the info on the fly away but i’m still confused why when it was in RTH and started coming down to land why it just took off and flew into the rv park? I now have a kill motor switch just in case even though i’m heading to the open field away from the park and toward the lake to fly now( I still have 3 drones out in the lake that just quit and fell straight down) again Thanks. B.K