Motors are not responding to transmitter's command

I’ve been having this issue for a couple of days. I’ve tried to calibrate the ESC so many times through Mission Planner and manually using the transmitter. The motors won’t respond to the transmitter after arming. They will just start spinning and won’t go up or down if I push the throttle.
Is there some configuration I need to set for the transmitter to work properly with the motors?

The transmitter I’m using is the RadioLink T8FB
Receiver is R8EF
The ESC is a 4 in 1 Tekko32
Flight controller is the Kakute F7 mini v2.

Have you checked your transmitter trim? This happened to me recently.

Not sure what you mean. I’m kind of new to drones.

Your first step is to use Google.

Post your parameter file.

I know that. I already tried to look for a solution and nothing has mentioned trim. You are the first, that’s why I’m asking. Actually, the trims are the small rectangular buttons you can push correct?
They only make a beep sound and don’t do anything.

parafile.param (17.7 KB)

You have it configured as an Octoquad (FRAME_CLASS,4). You would need 2 of those Tekko 4in1’s for that :grinning:

Oh wow!
I changed it to 1.

I changed it but motors still won’t respond to the transmitter. I can only arm them and that’s it.

Did you cycle the power after changing it? You have to when a servo config is changed. In any case post another parameter file.

paramfile2.param (17.7 KB)

I did cycle the power.

OK, the motors are assigned properly now. Before doing anything with the Transmitter you should run Motor Test in Mission Planner. I’m going to guess it won’t work and you have a wiring problem but check it out anyway.
I have one of those FC’s. Just flew it actually.

If you have a .bin flight log, which you should if it arms, post a link to that.

I ran the "Test all in Sequence) at 5% for 2s and they all work. That’s what I don’t understand. They do work, but when I try using the transmitter they don’t do anything except rotating at the same speed all four.

Is the Radio working on Mission Planners Radio calibration screen? Green bars move? Is the radio setup for AETR? I think all Radiolink is junk but it should still function.

Yes, I can test the radio in Mission Planer. I don’t know how to set up for AETR.

So that means the correct function moves with the correct stick?

I assume they do unless I completely misunderstood each stick.
So, the throttle is at the left and it does work when I move it up, down, left, and right.
Same for the pitch, except that when I move the stick up the bar goes down.

Post a link to .bin flight log.

This is correct.

How can I access the log?

I selected one of them and clicked on download, but don’t know where it was saved.

24 12-31-1969 7-00-01 PM.log (318.5 KB)

I did an auto analyze log,

Select the last one. It’s saved in whatever directory you have here (log path).

Post the .bin file. Typically you can’t attach them here directly being too large. If that’s the case put it in a cloud storage location and post a link. This is the normal routine when help is required.

Why are you using the Dev version of firmware?