Servers by jDrones

How to disable (ignoring) the altitude measurements using baro in non GPS environment setting for ArduRover?

There was a problem with a navigation stack.
Short story:
hardware:
Pixhawk cube + jetson dev kit tx2 + HOKUYO UTM 30LX on aion r1 rover
Software part
AMCL - for localization.
hector_mapping - for mapping.
move_base - package for navigate.

The goal is to make rover able to move around the 2d space and avoiding obstacles by sending the destination point (2d nav goal in Rviz).

The thing is that when you start all you nodes the local costmapp is literally above the global costmap in rviz, which I suppose affected by the transformation from pose topic which come from EKF3 estimator, which in other hands has the parameters such as coordinates x, y and altitude z - which should not be used at all in my case due the 2d configuration space. So any thoughts how to disable baro in software manner ?

EK3_SRC1_POSZ = 0
EK3_SRC2_POSZ = 0
EK3_SRC3_POSZ = 0
changing this parameters doesn’t affect at all.
Tested on Rover 4.1dev, 4.0 Stable, 3.5.2

Servers by jDrones