Servers by jDrones

Copter-3.6.4 released!

stable-release

(rmackay9) #1

After about a week of beta testing, Copter-3.6.4 has been released as the official default firmware for multicopters and helicopters and should appear in the ground stations within the next hour or two. The changes are in the ReleaseNotes and also copied below:

  1. Bug fixes and minor enhancements
    a) Detect and clear stuck I2C bus when using ChibiOS. May help some Radiolink TS100 GPS/compass module users
    b) Pixhawk4 fix for battery monitor voltage scaling
    c) TradHeli Dual (aka Chinook) fix for scaling of second swashplate movement
    d) Omnibus F7 IMU orientation fix
    e) Gimbal fix to avoid extreme movement if pilot’s transmitter is off at startup
    f) Follow mode fix to obey FOLL_SYSID parameter (controls which vehicle to follow)
  2. Cheerson CX-OF optical flow sensor support (wiki)

We still have some known issues that we are working through including the persistent “Bad Logging” message that some users are seeing.

Thanks as always to our beta testers for helping us test it!


(rmackay9) #2

(Giorgio Rinolfi) #3

I have to point out that the BlHeli_S passthrough still doesn’t works (just tried) in this release and I cannot see any mention in the above known issues.
Please report back if you can’t make evidence of this “still ignored known issues”
Thanks


(Vitaliy) #4

Hello. I can not solve the problem with the display of current in a mission glider. I have a variety of power modules, the original 3dr, chinese, holybro. Voltage all shows well. The current or the same value shows, or significantly less than required. Shows in the range of 0.2-0.5 for example. I do everything I calibrate and do according to the instructions. I do not know what to do.:sob:


(rmackay9) #5

Giorgio,

Thanks for the report, I wasn’t aware of this but I’ll check it.


(Lee) #6

What was the last release that you used that did work? I’m trying to do this as well and can load an old version if needed to get the CFG done etc.


(Nik ) #7

What is the setup process for switching over to ChibiOS from NuttX if I decide to? I just upgraded to the 3.6.4 firmware on my Cube, but I like the new fix for the stuck i2c bus in chibiOS that you mentioned (as I also had what I believed to be an i2c issue with my lidar last week where it stopped holding altitude)

Do I need to retune my copter or do anything special if I re-upload the 3.6.4 firmware and switch to Chibi OS?


(rmackay9) #8

@Iron_Donkey, I slightly enhanced the “Loading Firmware to Pixhawk boards” wiki page a few weeks ago to add the part about loading ChibiOS vs NuttX but in any case, if using the MP, switching between the NuttX and ChibiOS version should simply be a matter of answering the question when MP pops it up during the loading process. Most users will not notice any difference in behaviour and no special actions or re-tuning are required. No parameters are wiped… it should all be pretty seamless.


(ppoirier) #9

Yep confirmed with 2 PixRacer update today, easy and smooth migration to chibios


(Giorgio Rinolfi) #10

Hi Lee,
I’ve just check with MP and I’ve found 2 versions that works for the BlHeli_S passthrough, the string plotted by MP after connection is the only firmware version I’m able to give you:
ArduCopter V3.6-dev (6185d288) some minor issues
ArduCopter V3.6-dev (a0d874ba) this one seems to works even better

I hope it could help you!


(Nik ) #11

Ok that sounds good, I already upgraded to 3.6.4 with nuttX so maybe I’ll wait until 3.6.5 comes out to switch over. Either way it’ll happen. Thanks!


(brandon macdougall) #12

Hello, I recently got a PixracerR-15 from mRo for a y-6 copter build and noticed my Spektrum AR7700 and the DX8 will not communicate to Mission Planner in ChibiOS, Radio is binded but no green bars in Ground control software … as a test I flashed current firmware Nuttx and the Spectrum equipment connected fine. Can we add this to the issues for review?


(mlebret) #13

Hello,

It could be a bug with Oneshot125 activation.

https://discuss.ardupilot.org/t/copter-3-6-4-oneshot125-not-enabled/37067

With Arducopter 3.5.7, when MOT_PWM_TYPE is set to 2, RCout status display a value between 125 and 250, same result when looking RCOU in log.

Oneshot125RCOU

With Arducopter 3.6.2, 3.6.4 or 3.7.0dev, RCout is in the range 1000-2000

My card is a Navio2,

Thanks,

Marc


(Lee) #14

I am encountering problems with radio calibration. When I calibrate the TRIM values on many of the RC channels are set too low i.e. between ~800 and ~950 resulting in warning about trim being lower than min. I had to go in and manually set the trim values to 1500, which may not be optimal.

I am using Taranis X9D plus running open tx version 2.2.2


Hexcopter Flips on First Flight, and second
(Peter Hall) #15

its a Mission planner bug, update the the latest beta


(Mallikarjun SE) #16

Same here! I input the trim values manually!


(rmackay9) #17

@quadsours,

I was wondering if you could try Copter-3.6.5-rc2 to see if the Spektrum/DX8 works OK? This will be out tomorrow I think.


(brandon macdougall) #18

Will do! I moving to SRXL as well.


(brandon macdougall) #19

Frame: OCTA_QUAD
fmuv3 002D002F 3335510F 38343436
ChibiOS: 35ad8a79
ArduCopter V3.7.0-dev (99120cdd)
u-blox 1 HW: 00080000 SW: ROM CORE 3.01 (107888)

Tested: Spektrum AR77700 with DX8 Pixhawk classic. Radio connected ok flight modes working ok.


(brandon macdougall) #20

I was told that I should get the testing firmware by using " CTRL Q" and not through MP Beta Firmware button is this right? I seem to be using ArduCopter V3.7.0-dev (99120cdd).