Servers by jDrones

Sik radios failing in Mission Planner new version - Known Issues

@tridge
There seems to be some problem with the sik radios under the new version of Mission planner 1.3.70 Build 1.3.7227.34800

someone pointed out this issue at this link Telemetry radio on quad not connecting to ground station radio

I am experiencing the same problem.

Test Setup:

  1. Windows 10
  2. Only SIK radio connected to laptop.
  3. Inside MP, when you click load Config after selecting the correct com port and baud rate, keep saying failed to enter command mode.
  4. The config will not load.

interestingly, if you connect to the remote SIK radio, using the same com port it connects fine.

Any idea what causing this issue?

Update: 5-5-2020

Does the green light flashing on your radio or it is solid ?
If flashing then the two radios are not connected.
Did you removed CTS/DTR wires on the remote side of the radio ? (nota bene: they have to be removed)

Andras please reread my post. The radios talk fine when use the connect feature. The problem is Config not loading.

You can unchecking RTS/CT box. I can get them to work on remote radio without removing any wires. Don’t understand why are suggesting that?

Hi Asim,
Then it is nothing like the issue you linked.
Please clarify :

a. You have your radio connected to GCS via USB. But remote radio did not powered up.
Can you get the local config of your radio ?
b. You have your radio connected to GCS via USB and remote radio is powered up AND connected (solid green lights on both radios)
You can get the local config of your radio but not config of the remote ?
In case b if you can get the local config but not the remote,you see in the RSSI box ?

ps. I suggest removing RTS/CTS WIRES on the FC side, because those are used to go to firmware update mode on power on, and if a flight controller pull them up for any reason during power-on you cannot connect. But his goes with the issue you linked, not the one you described.

I will reply tonight as I am off to attend some meetings. Thanks

Eosbandi
@tridge
khancyr

Here are the sequence of events:

  1. Run mission planner and the SIK radio is connected to the same laptop.
  2. The green light on the SIK radio is flashing.
  3. Go to Initial Settings, select SIK radio and click load config using connected com port and baud rate.
  4. The result is as follows: “failed to enter Command Mode”

  1. Powered up Ardupilot and the SIK radio is connected to telemetry port 2.
  2. The TX and RX SIK radios light go solid green.
  3. You select Correct Com port and baud rate and click “connect” you get this error message.

  1. Now if I disconnect TX SIK radio, and re connect it to the same laptop. Same error message connection failed.
  2. If I shut down Mission planner, disconnect TX SIK radio, and re run Mission Planner, and re connect the TX SIK radio, where the remote ARDU Pilot and remote SIK radio never went through the power cycle. The TX SIK radio will establish the connection with remote SIK radio.

  1. Now click on Disconnect. to disconnect connection with remote SIK radio.
  2. Now click on “Load Config” and u get the following;

  1. I changed Net ID =73 on both TX and RX SIK radios. Clicked “Copy required to remote”. No confirmation comes back.

  1. Clicked on Connect again and the TX and RX radios are connected again;

  1. Again clicked on disconnect, and clicked on load config. You get this error message; “Failed to enter command mode”

  1. No matter how many times you try “Load Config” it will not load config.
  2. You can connect and disconnect as many times you like with remote RX.
  3. if you Physically remove TX SIK radio while Mission planner is running and connect it again, still it will not load config and will fail to enter command mode as shown above.
  4. Shut down mission mission planner and re start ot again and then connect the TX radio and click on Load config, you get;

  1. Notice the NT ID change never got saved and never got transferred to remote SIK Rx. Even if you click save settings, you get the same error message, “failed to enter command mode”

  2. Also, when you click upload firmware, you get this error message, “failed to Identify radio”

interestingly, if I click “Connect” I can very easily connect with the remote SIK RX and no issues.

ISSUES I AM SEEING ARE:

  1. Load config only works when not connected.
  2. You can not copy parameters to remote SIK radio even both TX and RX SIK radio lights are solid green.
  3. Can not upgrade firmware.

I hope this help the developers. Who is responsible for this feature?

YES RTS and CTS wires are not connected.

ive just tested

via usb direct to radio, load settings, save settnigs, upload firmware
then via usb to cube orange, with radio on telem1, all the above as well.

and i had no issues at all.

try MP beta, just so we are using the same version to test

Michael_Oborne

tried performing update and now this is what you get…This happens when you go to help and click on check updates. It tries to download a whole bunch of files and screws up the whole thing.

Install the stable copy again, MP works perfectly fine. Not sure if this will solve any SIK radio issues outlined above.

Can you post your screen shots. I can never copy the parameters to remote SIK RX off line

I have tested all of these functions w/o problem also.

  1. Right, this is not an issue. You will only populate the Remote radio settings disconnected.
  2. This is no problem, Disconnected.
  3. This is no problem. Just realize that when you do get it working it will update your local radio to V2.0 and you will lose connection with the remote radio on V1.9. You will have to update the remote radio to V2.0. Easy enough thru an FTDI adapter, easier still if your remote radio has a USB port (some do).

And from the Help screen press the “Check for BETA updates” button.

I’m very new to this and have just had an issue trying to setup radio telemetry, I’m not a pro…but I updated firmware individually on both radios via usb (had a problem where I was trying to update with a power cable and not usb data cable). When the radio is plugged in and installed, go into the device manager and check driver update and set to 57600 in windows settings. Checked the TX and RX are crossed over. removed the cts/rts (havent got a clue how they work or what they are for!) re-installed mission planner, set the coms to the correct one as both radios had different coms and set 57600 in mission planner. and connected and worked alright…propbably helpful…probably not!

The objective of the post is to duplicate the problem. Those who can get it to work doesnt solve anything. The way arounds are fine but the system should work as outlined in The docs. There are others experiencing similar issues.

See post above, beta updates screws up entire MP.

I will look into it and figure out the root cause.

this way around does work. I am trying to understand the root cause Of the issue

But there is no problem. Not with the radios and not with Mission Planner. Your Point 1 is a misunderstanding of how they operate and lead to the other issues most likely. These things have been around for years with no change in the process of setup or configuration.

I will figure it out.

The defined steps are not working in my case and I put 20 screen shots above to prove it.

Point 1 was to reiterate Thats the only way load works but copying to remote is not working. And there are number of other issues outlined in my response to Andras.

And what beta update screwing MP functionality has to do with SIK radios.

after you click copy to remote, did you click save settings? i dont think you did.

here I uploaded a video…enjoy!

p.s. the SIk radios are i think Chinese clones…

This does not lead anywhere.
Check mission planner log of the connection error and/or open up the console, there are lot more information there about what happening.
Sik radio is not a rocket science, all you have to do is to send +++ to enter command mode, if it does not respont with OK, then it does not entered to command mode…

Nota bene : 1.9 is not the latest version for Sik radios, the last one is 2.0 (dated back to 2016)…

1 Like

To change NetID:
Change the NetID on the Local radio only.
Press Copy required to Remote.
Press Save Settings.
At Set Command Error prompt select OK. Wait.Done.
Connect to remote radio to test.

To update the Firmware on the local Radio:
Cycle the power to both radios.
Load settings to test.
Select Upload Firmware (local). Wait. it will cycle thru connection options then Erase and write.
Success.

Now your local radio will not talk to the remote radio unless you update the Remote radio. As I said before use an FTDI adapter or dirct USB if the remote radio has a port.

However, if you fail to update the remote radio and want them to work again flash the Local radio back to V1.9. For people that are in this situation or simply don’t want to update a dozen air radios (as I have) attached is V1.9 to flash back. Use the Load Custom Firmware option. Wait. Select hex file.
radio.zip (64.9 KB)

Of course, and as usual, I just ran thru these same steps to confirm the sequence of events.

If you want to Custom load a version of firmware, they are here:
https://firmware.ardupilot.org/SiK/

1 Like

Andras and Dave;

Well it may not be rocket science but its not as simple as we trying to make it appear.

I just saw some more documentation on Ardupilot. Let me read it and see what I am missing.

I will try your suggestions as well. Thanks

Eosbandi

@dkemxr Dave and @Eosbandi and I am adding @smartdave as well

I never use SIK radios but when that kid posted his post, I started playing with them. I normally use RFD modems with zero issues.

Well, I got this part to work:

I was able to successfully change firmware on the RX radio using an FTTDI adaptor and no issues.

The local radio, driving me nuts.

I tried your suggested method.

To update the Firmware on the local Radio:
Cycle the power to both radios.
Load settings to test.
Select Upload Firmware (local). Wait. it will cycle thru connection options then Erase and write.
Success.

Interestingly, the radio connected to the laptop its keep failing the update. I am keep getting error message, “error opening port”. I went and tried on another laptop same thing, “failed to enter command mode”.

What’s throwing me off if the Tx radio is bad, how it can connect to the remote Rx?

I tried the AT hayes Command mode.

  1. Went to terminal.
  2. Typed +++
  3. I see this blinking | and then it stops blinking and no ok prompt.

So the TX radio is not entering command mode.

what could be the reason?

For the Local TX radio firmware update, do we have to have remote RX powered up as well?

Exactly which log file I should be looking at? I am very new to this.

You can see this error. First MP says trying X-Modem Mode then u get this.

and then just keep saying trying bootloader Mode when you click Upload Firmware.

Servers by jDrones