Servers by jDrones

Mission plannar doesn't see remote telemetry module

I’m using a 3DR 915Mhz Radio Wireless Telemetry set that I bought from here eBay, it looks liks this:

I’ve connected the ground telemetry to the computer via USB and the remote one to TELEM 1 on my pixhawk 2.4.8

I’ve opened Mission Plannar, made sure I have the Silicon Labs CP210x driver, changed the port to COM12 and Baud Rate to 57600 and went to SETUP -> Optional Hardware -> SIK Radio configuration and clicked ‘Load Settings’.

What appears in the screen is only the ground module settings which are in the following picture:

The air module just blinks and doesn’t show its settings, meaning it can’t connect to it.

What I’ve tried:

  1. going through this post Sik radios failing in Mission Planner new version - Known Issues
  2. connecting, disconnecting, restarting computer
  3. download rfdesign tools from https://files.rfdesign.com.au/tools/
  4. searching over the internet for a solution and I still don’t seem to find anything related to how to connect to remote telemetry (atleast to see the settings it has, and maybe configure them differently so it can be connected to the ground module w/ similar settings)
  5. Uploading the previous version 1.9 and still same results.

You have to connect the air module to your PC and set parameters/ update firmware on that as well. Blinking green led means they don’t see each other. Settings or firmware mismatch. Without connect it to the PC you cannot set settings on the remote if there is no connection.

I see, how can I connect it to PC? Is there like a 4pin(GND,VCC,TX,RX) to USB cable?
Also, it doesn’t make any sense because why would they sell these without the proper cable connection to PC?

Edit: I just saw a video how to solder 4 pins on the board and connect it with USB to TTL, i decided to buy 2 new radios “Holybro Transceiver Telemetry Radio Kit V3 500mW 915Mhz” from Holybro, they both have usb connection.

Since when Chinese manufacturers makes any sense ? :slight_smile:
You need an USB/Serial adapter cable. Without connecting to PC you will not be able to configure it.
Also avoid 500mW versions, they are crap, does spit out lot’s of interference, you will get more stable connection with a good 100mW pair of radios instead.
If you can spare a couple bucks, buy an RFD pair, they are expensive, but professionally made and reliable. The best is the RFD900x but you can just go fine with a cheaper rfd900u as well.

Servers by jDrones