Servers by jDrones

(SAFE) message in Mission Planner HUD

Sorry if this is really obvious but I can’t find the answer in Ardu documents or Google. What does" (SAFE)" mean on the HUD? It (seemingly) randomly pops up on the HUD but doesn’t have any negative influence on the flight in any way whatsoever? I thought it had to do with the arming button but it will show up randomly on the HUD in flight, I’m pretty sure any red message is a bad thing so really would like to figure it out. Flying a Skyhunter with TBS crossfire and PX4, Using RC through Mavlink and everything is working great except for this (no other types of failsafe out to ~5 km).

Thanks

I randomly get this as well so will also be interested in knowing what it is indicating.

It means the hardware safety switch is engaged

O.K. That’s what I thought. So I just powered the aircraft, disengaged SAFE mode by holding the button for 3 sec, and then wiggled everything around attempting to replicate the in flight issue - and I get no indications of “SAFE”, nothing until I hold the hardware switch again.

Mission Planner will announce “SAFE” in the middle of AUTO flights (so far I haven’t noticed a pattern), with no input being made, and it will stay on the screen for large portions of my flights.

Curious to hear if this is the the same issue Paul is having.

if you see “SAFE”, do you have any output of your motors or Servo?

I recently upgraded to Mission Planner 1.3.41.7 BETA so I can create a GeoFence. I am running ArduPlan 3.1.1. The previous version of MP apparently did not support GeoFencing. I noticed that I now get the (SAFE) message displayed on the HUD.
I can only fly in manual mode. When switching to any other mode, the control surfaces work, but I have no throttle. I’m not sure if this has anything to do with my upgrade to Mission Planner, or it is just a coincidence.
Has anyone run into this and have a solution.
Thanks
Update: I reverted back to the non-beta version (1.3.41) of Mission Planner and have the same results, so it appears that it has nothing to do with Mission Planner. I also have the ARMING_REQUIRED set to 0.

have you pressed the safety switch? or disabled it?

No safety switch on my APM 2.6. I have a throttle cut switch on my Taranis that overrides the throttle channel on my transmitter. It has always worked for all modes except AUTO. Now it works only for Normal Mode. I get zero throttle with any other mode.
I think this problem crept up since I tried to set up the GeoFence feature. I had to go to the MP Beta version as I received a “feature not supported” message when trying to upload the fence in MP 1.3.41, the release version.
Not sure if this is relevant, but with a USB connection to my APM, when I turn off my transmitter, the (SAFE) message goes away and I get the FailSafe message. I’ve of course set up my system to go into FailSafe when it loses signal.
UPDATE:
After several reboots of the system the problem has disappeared. I still the (SAFE) message on the HUD, but I have now full throttle control in all modes. This really puzzled as to the cause and why the problem went away.
I have since switched back to the BETA version MP 1.3.41.7 so I can use GeoFencing. Setup worked perfectly and I’m eager to test it out.

I would really like to turn off this (SAFE) indication. I mean, if something is not safe, a warning should appear, else, if there are no warnings, it means everything is safe, no? (or am I understanding this (SAFE) notice in a wrong way).

The point is: if there are other important messages, they will compete with the (SAFE) indication by switching very quickly, so I am not even able to read the other warning messaged.
E.g. My remote control was off, a warning was appearing (something like) “no RC radio”, but I was not able to read it, because the (SAFE) word seem to have priority in being displayed. Why does it even appear, if there is a warning?

How can I turn it off?

Cheers

No safety switch on my APM 2.6. I have a throttle cut switch on my Taranis that overrides the throttle channel on my transmitter. It has always worked for all modes except AUTO. Now it works only for Normal Mode. I get zero throttle with any other mode.

I think this problem crept up since I tried to set up the GeoFence feature. I had to go to the MP Beta version as I received a “feature not supported” message when trying to upload the fence in MP 1.3.41, the release version.

Not sure if this is relevant, but with a USB connection to my APM, when I turn off my transmitter, the (SAFE) message goes away and I get the FailSafe message. I’ve of course set up my system to go into FailSafe when it loses signal.

I experienced this yesterday as well on an APM 2.6. When powering up the aircraft, I have the modes set to Manual. My other two modes are FBW-A and RTL. When powering up in manual, all modes work via the transmitter. When I connect to Mission Planner, I get the (SAFE) message and I loose all controls of the aircraft immediately and it goes into stabilize mode and will not let me intervene. Is this a setting that the newest version of Mission Planner is looking for that only Pixhawk can provide and that APM 2.6 doesn’t?

I’m not sure the cause of this, but when its happening its clear that the throttle will not stay on. I’m running on some seriously odd (hacked a bit) pixhawk hardware though. I’ll let you know if I figure something out.

SAFE appears when the vehicle thinks its armed, but the sensors_enabled flag says they are not.
ie something is preventing motor output, even though the vehicle thinks its armed.

fix the underlying issue, and all will be good.

I know this is a stretch, but could an issue with the sensors_enabled flag have caused this issue where the aircraft might not have registered its landing?
I’m thinking it didn’t register the landing and then the GPS drifted while on the ground which caused it to tip over trying to correct.

Servers by jDrones