Servers by jDrones

Rover-3.2.0-rc2 release for beta testing!

ardurover
beta-testing
beta-release
rover

(rmackay9) #41

Leonardo,

You probably saw my post re the FRAME_CLASS param in the other thread but in any case, that will arrive with -rc4 in a few days.

Here’s the wiki section for the various flight modes: http://ardupilot.org/rover/docs/rover-control-modes.html
There’s no OFF-BOARD mode… perhaps you mean Guided?

So at the moment at least, HOLD mode just turns off the motors and moves the steering to the middle. We don’t have a manual-ish flight mode that will hold position. You’ll find with a boat that if you use Guided mode to make the boat drive somewhere, once it gets there it will hold position, and in Auto mode it will do something similar after it reaches a waypoint (if you add a delay to make it wait there a while)… but we don’t have a manual mode in which you drive it around, and when you release the sticks, it fights against the water flow. Someone else has asked for that so I think we will add it in a future release. In fact, I have created an issue here to capture this request: https://github.com/ArduPilot/ardupilot/issues/7312


(Leonardo) #42

Thank you very much!
I’m familiarizing with documentation, I’m following wiki step to setup my boat now.
You are right, GUIDED is what I’m looking for.
I think that, for boat, position holding should be a mode, like Altitud Hold in a Quadrotor. I would like to drive in manual mode to some place and when be there switch to HOLD and let the control to fight against wind and water flow.

Thank again!


(Leonardo) #43

I finally could setup and config everithing.
But in manual mode, if I move my sticks, servo output goes from 0 to 500 and is centered on 250
It is something like maxbirley report.
I don’t know what “cycle the pixhawk” mean.
ASV_01.param (11.1 KB)


(John Easton) #44

Hi, I just tried loading the Beta to my Pixhawk and got this error …


(rmackay9) #45

John,

What type of board are you using? Maybe attach a picture of it or a link to where you got it from.

I’ve personally never seen this error message before, it’s possible it’s an SD card issue (that’s a wild guess) or perhaps the I/O CPU’s firmware needs to be force-loaded (attach a safety switch and hold it down as the board boots).


(John Easton) #46

Randy,

It is the full size Pixhawk before the 2.1.

I have had it for about two years with no problem, it started this last week, so I was hoping that this new firmware would hopefully sort it out.

The only thing I did differently was power the board up while the outboard motor was running at the time.

Could the vibration from the motor during the startup have anything to do with it?

Yes, I tried that boot procedure, still nothing.

[Update]
It appears this board is ‘shot’, no idea why or what caused it.


(John Easton) #47

Arming Issue …

https://youtu.be/KJlVlJ-8Sck


(John Easton) #48

All sorted, had to change one of the failsafe settings from 0 to 2 and all works 100%


(rmackay9) #49

John,
Ok, glad you worked it out. I’m not quite sure why a failsafe setting would affect that… but I’ll keep an eye out for the issue…


(John Easton) #50

Restricted Throttle Output - (Ground Rover 3.2)
Here is a problem I have not run into before, probably going to slap myself on the head later, but here goes …
Problem - Restricted movement of throttle
Photo 1 shows calibration values
Photo 2 shows full left steer and min throttle
Photo 3 shows midships steer and mid throttle
Photo 4 shows full right steer and max throttle
Question -
Why is the min throttle so high?
Thanking you in advance

Facebook Discussion - https://www.facebook.com/groups/pixhawk2/permalink/1533194436763173/


(rmackay9) #51

John,

It looks like this was sorted out by setting the RC3_TRIM to 1500 (it had somehow become 1700).

I strongly suspect that this value was changed by the ground station somehow. Perhaps as part of the RC calibration.

I’ve created an issue for the MP to fix the wording on the little window that pops up near the end of the calibration procedure (link to issue)