Servers by jDrones

Rover-3.2.0-rc2 release for beta testing!

ardurover
beta-testing
beta-release
rover

(Max Birley) #21

I have a pixhawk 1 on a skid steer chassis. The pixhawk is a 2.4.8 clone. With a ublox M8N gps with compass. Not sure the actual compass model
I have tried Ardupilot Rover firmware versions 3.11 and version 3.12 and version 3.2.0 rc3 and on each occasion I get bad AHRS. I have read many posts relating to this but still drawn a blank on the fix
I have calibrated the accels and compass. When using version 3.2.0 rc3 the firmware will not even allow me to calibrate the accels and compass.
I also have a pixhawk 2 (currently without a better gps) and it has the same response. ie bad AHRS when I use the M8N gps with the pixhawk 2.
Is there a know fix or is it likely the clone is bad. What can I post to help you analysis this problem


(rmackay9) #22

Max,
The inability to do an accel calibration sounds like a hardware issue. I’ve almost never heard of a board that could not do an accel calibration. Can you download a dataflash log and post it here or in a new topic in the Rover-3.2 category? You may need to set LOG_DISARMED to 1 to be able to produce a log without arming the vehicle.
The “Bad AHRS” message doesn’t tell us much actually. I think that is displayed when the vehicle doesn’t have a GPS lock. I will look into this and try and make it go away unless there is really something wrong with the AHRS.

EDIT: I’ve created an issue to resolve the “Bad AHRS” and “Bad GPS Health” messages. https://github.com/ArduPilot/ardupilot/issues/7417


(Max Birley) #23

Thanks for the quick response it is really appreciated
I will send the log file later today
What firmware do you want me to load to do the test?

I have a pixhawk 1 and 2
As the firmware is further developed I imagine it will eventually not run properly on the pixhawk 1
Are we near this point? I guess the question is if I buy another pixhawk 1 how long will it be relavant a for
Or is the advice to change over to the pixhawk 2


(Max Birley) #24

I think I wasted so of your time…sorry
I have fixed the problem. I was testing the pixhawk inside. I was getting 8 sats so thought that was ok. I went outside and the bad AHRS went away. I think the room I use id full of EM sources and that unsettles the pixhawk. I then tried it on 3 different firmwares. 3.1.1 then 3.12 and 3.2.0-rc3
and on all three FM it works ok now

However I have one issue. In the previous FW I was using skid steer parameters with a sabertooth set on “independent” (not mixed) to control the chassis. Now I have moved to 3.2.0 rc3 the skid steer parameters have gone and the coordinations of the channels has gone as well . ie now elevator controls one side of wheels and pitch now controls the other side wheels. where as before the wheels were coordinated
I want to retain the skid steer functionality as I want aggressive 180 turns at the WP so I want to keep the sabertooth on independent. So can you help me to find the new parameter set to utilise skid steer

Also learning mode will not function as yet on this firmware


(rmackay9) #25

No problem.

I’m sure we will support the Pixhawk1 for years. There’s actually very little difference in terms of CPU power and memory between the pixhawk1 and pixhawk2.

A good number of parameters have changed with 3.2.0 but I haven’t yet updated the documentation. I hope to do that over the next week or so.

For skid-steer rovers you now need to set the SERVOx_FUNCTION (where x is the output channel being used for each wheel) to 73 or 74. 73 is for left-motor, 74 is for the right motor.

Learning mode (which just saves waypoints as you drive around) has been moved to the channel 7 auxiliary switch. There are now 8 or so things this channel can do. If you’re comfortable with it, it’s good to use the latest beta mission planner. The Basic tuning page has been updated to show the available options.

txs for testing.


(Max Birley) #26

MiniSDR2017-12-17.param (11.3 KB)

Thanks for the response

Current issue motor driver is not outputting any signal to the motors. ie nothing at all

I have enclosed my parameter file

Ardupilot Rover FW 3.2.0 rc3
Mission Planner latest beta

I am using a Sabertooth 2*12 RC motor controller with pixhawk 1
The Sabertooth Channel 1 (fwd/bk) lead is connected to the Pixhawk 1 main output pin(aileron) and Channel 2 (turning) is connected to pixhawk main pin 3 ie throttle

Parameters set as follows
SERVO1_FUNCTION to 73 and
SERVO3_FUNCTION to 74

I am using a Spektrum DX8 and it is having a normal response in radio calibration. Transmitter in Mode 1

The motor driver was working yesterday in other versions of the FW

I obviously need to set some other parameters to get the bot moving as a skid steer

Regards
Max


(Max Birley) #27

Just returned to FW 3.1.2 to check that the Sabertooth is working correctly. Had to use RCMAP to swop channels for roll and throttle. It then worked however the behaviour is still odd as when I am in full reverse the bot suddenly stops and then moves forward. I am not really interested in 3.1.2 solutions as I would rather stay with the latest beta. So this post is more for info to show that the Sabertooth is working and that this is a parameter setup issue not a hardware issue.
Regards
Max


(rmackay9) #28

Hi Max,

Thanks very much for testing.

I’ve had a look at your params and I think the issue is that you’re trying to drive around in LEARNING mode. We’ve replaced this mode with a channel 7 option to save waypoints. So maybe set MODE1 and MODE2 parameters to 0 (for MANUAL).

  • looks like no RC calibration has been done (not necessarily a problem but…)
  • safety switch is enabled (BRD_SAFETYENABLE = 1) which is also fine of course even if you don’t have one because ARMING_REQUIRED is zero.
  • looks like you’re using a skid-steering rover with left motor is connected to output1, right-motor should be connected to output 3 (again no problem, just confirming).

I’ll be updating the Rover wiki this week.


(Max Birley) #29

Hi Randy

Thanks for the help

I really do have some issues with 3.2.0-rc3 that I think are FW related not hardware related

I have now set all MODES to manual
I have recalibrated the radio
Mission planner at first would not allow accel calibration and then it did allow later on. I hver experienced it issue in other versions of the FW.
I am using a sabertooth 2 by 12 rc version. This has 2 rc leads as output. One labeled CH1 - fwd which I connect to main out 3 and CH2- Turning which I connect to main out pin 1. In MP I then set up servo1_function and servo3_function to 73 and 74
On the sabertooth I select independent not mixed mode. I will try mixed

So what is the strange behaviour
When I am in radio calibration if I move the throttle forward the pwm increases as it should to 2000 and when I get to 100% forward it flips the pwm to 899 ie full reverse, left and right are all behaving normally
what ever I do the right hand stick is not controlling the motors
if I press the safety button both motors go on full blast with no impact from the stick

The output from the servo set up screen also does not seem to make much sense.

I am going to revert to an older version of rove. Can you help to fix the current issues and recommend an earlier version.
I tried downloading older versions however I can not find 3.2.0-rc2

regards
Max


(Max Birley) #30

I just tried a pixhawk 2 with 3.2.0-rc3 and still the motors will not turn when commanded

The servo output looks healthier. I have not calibrated the esc as I have a motor controller (maybe
little of no difference)

Enclosed is the param file from the pixhawk 2

MiniSDR2017-12-19.param (11.3 KB)

Some screen shots yo show what is going on





(Max Birley) #31

Dear Randy

what version of the FW is the most stable that with give a reasonable to good skid steer response. I am looking for very tight turn at a waypoint.

also getting a parameter set would be really helpful

I know a sabertooth 2 by 12 will work on a pixhawk for a small bot however so fare the turns have been lazy. Maybe this is my fault and I have not set up the parameter properly??

Can you recommend a the best solution for this ie autopilot,FW motor controller combo

I am very happy to use tried and tested equipment rather than spending days messing around.

regards
Max


(rmackay9) #32

The best firmware to use is the latest beta which is 3.2.0-rc3.

I’ve never used the sabertooth (or hardly any other motor drivers, i’m new to Rovers) but you’ll want to select “independent”. I suppose it’s a skid-steering vehicle? So there’s some advice on these pages:

It might be good to connect the receiver directly to the motor driver and make sure the motors are moving correctly. You’ll want to be able to control each motor separately and the motors should be able to go both forward and backwards.

Beyond that I think I’ll need to see a dataflash log.

We don’t yet have a recommended list of motor drivers that we know work. I guess we can try and get a list from others in the community…

by the way, I plan to release -rc4 after I’ve completed most of the wiki updates we need for the official release. I expect/hope -rc4 will be the last release but who knows.


(Max Birley) #33

Hi Randy

I have my pixhawk2 with a Here gps working with the Sabartooth motor controller on FW 3.1.2.
I am enclosing the param file and a log file.
I used skid steer parameters
So this shows that there is nothing wrong with the hardware!
I am now going to load the beta FW and try again
I will send files if I hit a snag
I appreciate your help

regards

MiniSDR2017-12-20PIX2_3_1_2.param (8.8 KB)
84 20-12-2017 18-05-58.bin (43.1 KB)


(Max Birley) #34

Dear Randy

So I am trying 3.2.0-rc3 on my pixhawk 1. I know all the hardware works so this is a set up issue
looking at the articles you sent there is an obvious problem with the servo output. see enclosure below
This is a summary of the output I get
entered left right forward back
channel 1 272 98 450 416 84
channel3 272 450 90 416 84

so you can see that I do not get anywhere the trim values


(Max Birley) #35

I cycled the pixhawk and that fixed the servo output and then
set pilot-steer-type to 1 and the motors then started to behave. However had to go to MIXED mode on the sabertooth and swop the channels. Well at least it is behaving sort of normally. Now I can make to progress on driving it about with RTK
regards
Max


(Sebastian Schürmann) #36

You will not get a working skid steering rover with the sabertooth in mixed mode, because in this case Ardurover thinks it is controlling an ackerman steering rover. It will not use pivot turns in any mode except manual.


(rmackay9) #37

The Pilot Steer type shouldn’t really make any difference - what you should find now is that the way you use the transmitter to control steering and throttle is odd - it’s the two paddle method you will be using now.

What’s most important in terms of making it clear to ardupilot that you’re using a skid-steer vehicle is to get the function values set to “throttleLeft” and “throttleRight” as you’ve done on the “Servo Output” page. With it set like that it should certainly be outputting individual pwm values for the left and right motors.

What is being output to each motor should be visible in a few places - on this Servo Output screen but also on the Flight Data screen’s Status tab (see bottom left). Look for ch1out and ch3out.


(Leonardo) #38

May I change Flight mode Channel in this firmware version? Deafult is 8 but I need on channel 5
BTW, is there a tutorial on how to flash beta versions? I would like to use 3.2 on my ASV with skid steering.

Thank


(rmackay9) #39

@elgarbe,
Yes, you can set the flight-mode channel. It’s on the wiki here: http://ardupilot.org/rover/docs/common-rc-transmitter-flight-mode-configuration.html#setting-the-flight-mode-channel
There’s no tutorial on flashing beta versions but it’s not hard:

  • open mission planner
  • go to Config/Tuning >> Planner and ensure “Layout” (near the bottom) is set to “Advanced”
  • go to Initial Setup >> Install firmware screen and click on “Beta firmwares” link (bottom middle) and you should see the version displayed below the Rover icon change to “APM:Rover V3.2.0-rc3”

Thanks for getting involved in beta testing!


(Leonardo) #40

Sorry by the noob question, but it’s my first time with pixhawk and ardurover…
My ASV has skid steering. I would like to drive with my RC transmiter. What Flight mode should I setup?
I know Manual and RTL. But, what are other modes for? I would like to “flight” manual, waypoint’s, HOLD (is it hold position?, like fight against the river flow and hold heading?), RTL and OFF BOARD.
Thank!
EDIT: I can’t find FRAM CLASS on Full Parameter List.