RFD900X Range issues

Hi everyone,

I’m trying to get the best range I can between my GCS setup and my foam airplane (E-flite Opterra). I have 2 RFD900Xs (1 with the GCS with a 2-antenna setup -> 11db 900 MHz Yagi and the regular 3db dipole that came with the RFD900X radio bundle and 1 RFD900X in the aircraft). I have the following radio parameters set in Mission Planner:
BaudRate: 57600
AirSpeed: 64
TxPower: 30
MavLink Mode : Mavlink
MinFreq: 902 MHz
MaxFreq: 928 MHz
#ofChannels: 40
DutyCycle: 100
LBT Rssi:0
Max Window Size (ms) : 120

The antenna used on the aircraft are the 2.1db 1/4 wave monopole and 1/4 wave 90 degrees monople directly connected to the RFD900X without any separation.

Currently, with that setup I can “only” get about 2.5-3.0 km before Mission Planner’s GCS Failsafe kicks in for a full RTL.

What am I doing wrong ?

I’ve read in their user manual that they suggest to separate antenna by at least 25 cm. That would be one of my next steps. Also, probably change the 2.1db monopole antenna by dipole ones would make sense to me as well. Also, try their flex antenna (http://store.rfdesign.com.au/rfdflex1-900mhz-flexible-pcb-antenna-500mm-rpsma/)

RFDesign claims they have successfully done a 40km range test. I would like maybe between 5-7km.

Thanks for your feedback and suggestion.

René

I’ve seen far greater range than yours… With a Yagi at the GCS you should be getting phenomenal range.
In the plane, is the 5vdc good and not noisy or low?
Far enough away from ESC and battery?

Those flexible antennas mounted to the fuselage and wing would definitely help, but I wouldn’t have thought they’d be needed except for very long range.

I’ve recently done a flight to 3.5km with the TX power turned down to 25. Stock half-wave antennas on the ground radio. Stock ¼ wave antennas on the air radio. The 90degree antenna pointed straight up. I can’t remember the RSSI value at 3.5 km, but my colleague who was watching the GCS made a comment something to the effect of “don’t worry about it, it’s fine”

Other than the TX power, all other settings were stock on the latest firmware 3.20.

I would make sure your power to the air radio is good, I’ve had issues in the past where the voltage would sag and they would drop the link. That was part of the reason I turned the TX power on this install down to 25 actually. (and heat buildup) In my other install I use a dedicated 5v supply (BEC) just for the air radio.

I’m not sure how the Yagi antenna would be affected but I have noticed that antenna orientation seemed to be important when I was running at lower TX power. Even at 1km if the antennas on the ground radio weren’t in the proper orientation to match the air radio then the signal would drop significantly.

@xfacta and @Allister : I have a dedicated Castle Creations BEC (5.1V 10A). I don’t seem to have any electrical issues at all on the air unit. On the ground unit, the dipole antenna is pointed straight up and the Yagi is horizontal in the direction of flight. On the air unit, the 90degrees 1/4wave is straight up and the other one is stright forward as far as possible from any elctronics,

Wow, this is a head scratcher. Sounds like you’ve got the bases covered.

Software: The only idea I have left is use the RFD tools check you have the latest firmware on both radios. (I don’t use the mission planner tools for that). For the range you want I’d also suggest resetting everything to stock. I know others have been able to optimize performance by adjusting the settings but for the range you’re looking for, and for the sake of trouble shooting I’d try stock settings, at least to start.

Hardware: If you have spares, maybe swap out some antennas. Something might not be right or you have a poorly tuned/wrong antenna.

I’ve seen 16.5 km with two RFD900X’s , standard antennas, stubbie antennas on the aircraft. Both radios effectively at ground level inside brick buildings. 115k baud, like they were next to each other.
One radio out in the suburbs, one in an industrial area.
Here’s the elevation profile between the two points.

1 Like