Servers by jDrones

Omnibus F4 V5 & V6 Setup - Application Race Quad

gps
arducopter
chibios
copter-36

(Matt Kear) #41

Hi Ryan,
I’m not sure I was clear in what I said previously. The V6 board is set up to ‘supposedly’ have 5 UARTS. The v5.1 only has 3
UARTS. Now in theory it might might be possible to have more UARTS on the 5.1 board as the ARM STM32F405 chip can support more. However this is dependent upon which pinouts on the board are connected to which pins on the chip. In all likeliness it would mean sacrificing other functions (like pwm, buzzer, etc) by remapping the board for extra UARTS. However, to do this is currently above my knowledge level and not something I am looking to do.

The reason I say that the V6 ‘supposedly’ has 5 UARTS is because one UART is Rx only and another is Tx only. So not the most helpful. I think that the v6 board will work with the v6 nano hwdef target. However this will only give 4 pwm not 6 pwm. I will eventually get around to adding the last two pwm on the full size v6 board.

Matt


(Ryan C Smith) #42

Your right I didn’t look over my docs well enough and must have had the V6 info in my head when I was doing stuff. My bad.


(Ryan C Smith) #43

I burnt out my 4th PWM on my v5.1 so I ordered a new v6. I happened to check out ardupilot git and there is a new target for the omnibusf4v6. The firmware page has pre compiled ardupilot copter but doesn’t have a bootloader file to flash. And if you were using the omnibusf4Pro or OmnibusNanov6 target previously it won’t allow you to just flash the .apj file as it has a different target board id. I have compiled and successfully flashed the bootloader I made from the git repo with the new hardware definition files for omnibusf4v6.

1.Download the pre compiled bootloader file:
https://drive.google.com/file/d/1tHtFclLbRxUu-YNAp2l3ykb2sSnAEBBh/view?usp=sharing

2. Then flash this per instructions making sure to use the correct file name. If on windows make sure you don't have spaces in any folders:
http://ardupilot.org/copter/docs/common-omnibusf4pro.html#enter-dfu-mode 

3. After you flash make sure to disconnect and reconnect the board.

4. Then Download the firmware you want to install.
http://firmware.ardupilot.org/Copter/beta/omnibusf4v6/ 3.6.1 RC -Beta
And
http://firmware.ardupilot.org/Copter/latest/omnibusf4v6/ 3.7.0 Dev -Latest

5. Load mission planner and install via the Load Custom firmware.  

6. joy

@IAMMATT
I have not used this but the OSD might work, would love someone to test and report. I am working on getting some more parts in before i can finish my build. But will let you guys know when I do.

EDIT: The Latest version now has a new build from master and Tridge added the with-BL.hex to the auto build system. So just flash that with Betaflight then you can flash the Beta as of writing 3.6.1RC to the board. There wont be a with-BL.hex file for BETA with the new bootloader for the omnibusf4v6 board target till they make a new RC for 3.6.1.


(Dave) #44

The easiest way is to use the “with_bl.hex” file and load it with the Betaflight Configurator once. After that you can use Mission Planner as usual to flash firmware. I have a couple of these F4 Nano V6’s.

I’m not using OSD but others are and it works.


(Ryan C Smith) #45

Like I said in the post and if you checked the links (as of my writing) there are no “with_BL.hex” hence the reason i compiled my own bootloader for this 3 day old new target for the omnibusf4v6. The omnibusf4v6 is a brand new target for the v6 board. No one has posted on this thread about using it.

There is no way to install the omnibusf4v6 ardupilot software without the bootloader. I am not sure how to make those files and It could be as easy as renaming my arducopter build i made myself from master that ended in .bin to a .hex file. I just got this board in the mail today and I’ll have to ask a dev if my theory is correct. When you compile it spits out two firmware files an .apj and a .bin. But I don’t know of the .bin has a bootloader in it or not.

The file I posted above was me just compiling a bootloader
But I can confirm this method I posted above works.


(Dave) #46

Ah OK, sorry. So the old way before the BF targets were available. I had to do that with the 1st F4 Nano V6.


(Ryan C Smith) #47

I get some more crap in the mail tomorrow and can rebuild my smaller quad. I am switching my PDB to one with a current sensor even though I am going to try to use the BLheli esc telemetry as a current sensor too. I am gong to set up BLheli as sensor monitor 1 and current sensor as monitor 2… after I calibrate it that is.


(Dave) #48

Interesting. The latest hwdef file for the F4 Nano V6 is supposed to enable ESC telemetry on Rx 4 but 1st attempt didn’t work for me with an Ori32 ESC.


(Ryan C Smith) #49

Just heard back from Tridge and they added the bootloader to the auto build system so I assume soonish there will be a version of beta and latest with the "with_BL.hex so it can be flashed onto the f4 v6.

@dkemxr I havn’t gotten that far I fired my v5.1 with a soldering iron that was hotter then it needed to be. So my testing ended there.
Have you looked into the serial settings? ( SERIAL(3 or 4)_PROTOCOL ) It should be set to 16 for ESC Telemetry.
Hwddef.dat on the nanov6 was updated to inclued uart 4 rx for ESC Telemetry. There is also a test function to see if your getting info from the motors you can set. it might be new if you tried it a little while ago. You should see data in mission planner according to the video that sets the full debug. SERVO_BLH_TEST I would assume the motor test runs similar and you would see telemetry data.


(Dave) #50

Yep, have Serial 4 set for 16. I’m monitoring ESC telemetry in MP on the tuning screen but no data.


(Ryan C Smith) #51

Check out this post and the whole thread on esc telemetry. This user has the nanov6. He says he had to comment out Uart4 and re-compile AP but i don’t think that may be needed anymore. The post was a month or so ago. I haven’t check in on this theory yet about i am pretty sure i saw it setup properly on the new v6 regular target. so they may have updated the hwdef for the nano as well as they are very similar. Also @Paul_Atkin1 confirmed a few posts down that he had it hooked up correctly but didn’t think he did the whole time. Due to the messages he saw in MP. … It might work if your on the master or new 3.6.1RC for the nanov6


(Paul Atkin) #52

MP still shows no esc data correctly in the status screen. it is plain broken. you need to arm the model and then look into the dataflash log into ESCx sections. if hooked up correctly - it will have those sections and values in them.


(Dave) #53

UART4 mapped to Serial2! That did the trick, thanks Ryan! The data is now available on the tuning screen of Mission Planner. Not sure about current it looks a bit wonky but voltage and RPM are working. It could just be the update rate for the live graph.


(Ryan C Smith) #54

Awesome Dave, Make sure to set the SERVO_BLH_TRATE to 10. Also check to see what you set your Protocol for the BLHELI that may affect your results. Recommended was Dshot150. Per http://ardupilot.org/copter/docs/common-dshot.html?highlight=blheli. I am going to try out Serial 2 on my v6 Regular when I get things soldered up hopefully tonight. Hopefully it is the same. I need to look over the hdwdef for the nano and regular side by side. I am assuming I need to use the LED pad for S.Bus on the FRSKY too like the nanov6.


(atobiese) #55

“I am assuming I need to use the LED pad for S.Bus on the FRSKY too like the nanov6.”

Yes, that is correct.


(atobiese) #56

The regular V6 board also includes an additional uart (uart3), that can be used for example for a rangefinder in conjunction with gps etc. It also exposes pwm 5 and 6 (for example for servos).

I have not had time to make a description for the board yet. Note that uart4 is not a full uart, only rx (PA0 is used for rssi adc).

for example with use of 3 uarts:
esc-telemetry
SERIAL2_PROTOCOL

gps (enabling use of the 6 pin JST, gps with compass)
SERIAL3_PROTOCOL

lidar tfmini
SERIAL4_PROTOCOL (UART3)


(Ryan C Smith) #57

@dkemxr Got my blheli_32 Telmetry running aswell. My new problem, @ceitean might be able to help, is I want to use mavlink pass through on my Frsky. I would love to use inverted directly into my r9mm receiver so I don’t have to make an inverter cable. I have to read the docs on this R9mm but I am under the impression that it might have an un-inverted S.Port along with the inverted one. They made changes from the R9 mini. All that said it would be nice to know if someone had a mini or other frsky receiver.

Take this with a grain of salt as i know the OG docs don’t match up too well with the ardupilot hwdef’s.

We are using the LED for S.Bus not the labled S.Bus pin. I am assuming that the OG S.Bus (PA10) pin is now a normal UART as it is labled in the hwdef.dat file.

So I guess my question is can I get inverted RX and TX from the S.Bus(PA10) S.Port(PA9) pads UART1 (originally this is inverted according to the spec sheet) Or is there somewhere other then UART6 I can get an inverted signal.

I don’t want to use the UART6 with the JST connection as I will be messing with a GPS for a bit while tuning this thing. I know I could un-comment it in the HWDEF.DAT file and make it inverted again but I want to keep that free for the GPS like I said.


(Dave) #58

Ryan-I tried both the inverted and non-inverted Sport on an R9 slim for Frsky telemetry. No go either way for Frsky passthrough telemetry.


(Ryan C Smith) #59

When you did this, did you have the Serial port set up for 10 (mavlink to frsky telem pass through) and did you combine the TX and RX wires to a single wire going into the S.Port on the r9 Slim? Did you also try the other UARTS that you had free to check if your numbering was off…like the UART 4 to SERIAL2 we borrowed from another thread.

I have a feeling this is our golden ticket whether we need to convert in between or not SERIAL4_PROTOCOL (UART3). The pixracer has an inverted uart and can just hook up to the S.Port so those of us with the non-inverted input or have modded for that on like the XRS should be able to do the same. In my head at least.


(Matt Kear) #60

Rumor has it that the frsky passthrough will become available via soft-serial very soon. If you wait a couple of weeks it maybe easier to set up the frsky Telem.