Omnibus F4 Nano v6.1 missing basic parameters

Hello everybody,

I’m new to the forum, but quite an aged user of Ardupilot (both plane and copter, autopilots from MiniPix to the Cube). I have now a small plane flying with an Omnibus F4 Nano v6.1 inside, which flies nicely. I set it up in April, loading the bootloader and firmware with STM32 just by following the guide on the Omnibus F4 Nano page on the Ardupilot website. I’m now simply trying to set up a new plane with a second Omnibus F4 Nano v6.1, but I cannot finalize it! No way. I’m missing basic parameters in the firmware (like attitude and serial ones), and can’t understand how to fix.

Here’s some details:
I tried loading almost any fw+bl available on the Ardupilot website using STM32 (plane latest, beta, stable, stable 4.0.9, stable 4.0.0, even copter once just to try), but after successfully loading the firmware I connect with MP and I try to load the param file that I saved from my other plane: well, I keep getting a “missing parameters” error which refers to basic attitude parameters like RLL2SRV_P, RLL2SRV_I, PTC2SRV_P and some hardware parameters like SERIAL4. The missing parameters vary from 29 to 435, it depends on the firmware that I loaded obviously, but the common point is that I keep missing key parameters that prevent me from flying.

I think I tried with 20 different fw, I tried to update the fw from MP itself, I tried to use QGCS instead, I tried to load a stable fw+bl, than to upgrade the fw alone… The problem changes, the missing parameters change, but some key one is always missing.

When connecting to my WORKING plane, MP says:
09/08/2021 11:12:45 : IMU0: fast sampling enabled 8.0kHz/1.0kHz
09/08/2021 11:12:45 : RCOut: PWM:1-4
09/08/2021 11:12:45 : OmnibusNanoV6 002E004F 37565011 2039365
09/08/2021 11:12:45 : ChibiOS: c82ce90e
09/08/2021 11:12:45 : ArduPlane V4.1.0dev (ab2e429f)

I loaded several different fw on the new plane, but never got a cxxxx ChibiOS.


  1. any way to save the firmware+bl from a board and load it to a new one?
  2. any way to find a specific firmware+bl on the Ardupilot website by knowing its code (in this case ChibiOS c82ce90e + ArduPlane v4.1.0dev (ab2e429f)?
  3. anyone else ever experience such a deep missing parameters issue? How to fix that?

Attached one of the several similar errors I got, just as an example. The key missing one here is the serial4, which is instead alive on the other plane (and used).

Thank you to anyone willing to help


You’re probably aware of the limitations of that FC but I’ll post the link here just in case:

However that doesn’t solve the missing basic parameters. Make sure you’re using the latest version of Mission Planner. A new version just came out a week ago. Update MP then try using it for your firmware updates. If you want to install plane, load something else like copter or rover first, then go back to plane and just do a normal firmware install. It’s a long shot but worth a try.

Hi Max,

I try to answer your questions:

  1. I don’t know if its possible to read the fw from the board. Maybe the real smart quys can do this. But it’s not necessary, see next…

  2. Can you build your own fw? The command: “git checkout ab2e429f” should do the job. Otherwise I can build ths fw for you.
    Here you will find the apj file. This can be uploaded by MissionPlanner in case of an existing (other version) of ardupilot on the board.
    arduplane.apj (829.2 KB)

  3. Missig parameters are common in case of changing an ENABLE parameter. The disabled parameters are hidden. This is easy to fix. Just load the parameters two times. After changing the ENABLE parameters you have to disconnect and power cycle the board. The missing parameters will be visible the next time you connect the board. Now you can load the remaining params.

Hope this helps.

Hi Allister,

thank you so much for your reply, but I already tried that, and didn’t fix.
Honestly at first I didn’t want to update MP as I was using the very same version used for the first plane, than after some hours I gave it a try too (when I was trying almost everything I knew).
Anyway, I’m getting similar errors both by updating via MP and by using MP just to load custom firmware taken manually from the website, in the board specific folder (actually the board specific webpage on the Ardupilot website states to update it only this way, so the first trials were all done like this).

1 Like

Hi VRquaeler,

thank you so much for your time.
Actually I’m not able to build a fw, so later today I’ll try to load the apj you sent me. Do you think the issue is more fw related than bl related? I was thinking more to the boot loader, but I can’t really explain why (just a sensation).

I’m aware of the enable/disable parameters: I already tried to load the param file twice (by power cycling) at every try. Some board specific parameters were actually appearing just at the second cycle (enabled by my param file) but not the basic ones.
I don’t think a plane fw can have any PTCH2SRV or RLL2SRV param disabled anyway (it won’t fly). This is not something related to the board limitations or to an enable/disable - I think.

I’ll try later today with your apj - thank you.
Any chance to find the right bootloader in a similar way, in case?

Thank you again

Hi VRquaeler,

I have no words: your apj fixed it all!

I have some questions than:

  1. why only this fw works?! What’s special with it, or what’s wrong with any other fw?
  2. by loading this apj, I finally read the same ChibiOS code that I was reading on my first plane: ChibiOS c82ce90e. I was sure this was the bl, not the fw… but it changed by loading this apj. How’s that?

Thank you again so much, I’ll get back in flight in the next days and check it all, but I’m sure it works now.


1 Like

Hi @maxscali,

Thanks for the positive feedback. Glad to hear it works for you.

  1. why this fw only?
    This build AP4.10dev ab2e429f was the latest Developer firmware was from begin april.
    For the 1MByte boards it is based on EKF3. Following the EKF2 parameters are missing.
    All AP4.0.x stable builds for the 1MB boards are based on EKF2 and miss the EKF3 params.
    When you try to run a newer version of the Dev builds one month later was a major change in the PID control and in the autotune part. This leads to the missing

More info can be found here .

  1. question

This is not the bootloader.
“c82ce90e” is the hash of the underlying RTOS version beloning to the firmware.

Good luck for the first flight with the second plane!!

Hi VRquaeler,

flew today! Everything simply perfect 90% of the time.
The problem is the remaining 10%: after one reboot due to battery swap, I launched in manual (still testing), switched to FBWA while in flight and the plane was like crazy. It was clearly following my inputs, but it was also following a totally crazy horizon. I didn’t have any telemetry on at the moment, but I’m sure the horizon was going up and down, and looping and so on, and the autopilot was trying to the level the plane according to the faulty data of the IMU.
I landed in manual, rebooted, launched and flew some 40’ with NO issues.
Rebooted and re-launched several times, just perfect.
After some while I launched in auto mode, the takeoff procedure was fine but before heading to the first waypoint it pitched down 45 degs again… switched to manual, back into FBWA: perfect.

Is this linked to the EKF limitations of this board? Is it particularly sensitive to any movement of the platform while booting up?
Whichever the reason, this NEVER happened on the first plane (have been flying for months).

Smart ideas?!

Thank you again

So which version of firmware is loaded? I see the previous post but not sure. I would think you want to load the latest Plane Dev version. That’s what I have on a Omni Nano V6 (not 6.1).

I have the fw posted to me by VRquaeler, which is 4.1 dev. It appears to the be the same which is flying the first plane with no issues, so I don’t understand why I should have a different behavior here. Actually I don’t: it flies perfectly 90% of times, as said. I just can’t explain those 2 crazy flights. Should I update to latest?