Nimbus Tricopter VTOL

Ok, thanks, guys. I have several other complete analog AS sensor sets so I can try swapping out the current one. My point is that even after I swap it out, it seems the Speed gauge on the HUD may not be a foolproof way to test it…but I can look for differences between the two sensors. I’ll then fly it and look at the logs since it gets logged even if you don’t use it.

Eventually, I would like to get the SPD33 sensor kit but it still says “Pre-order” on the Drotek site.


Greg, this seems to be the same problem I am having, that the transition doesn’t seem to complete with the motors tilted partially up. I thought it was solved by going from 11m/s to 9m/s for ARSPD_FBW_MIN but I still had an intermittent issue since then, although Musa reported that it was fixed with his aircraft after that change. Wish @tridge would come past to comment.

It’s also possible that Q_ASSIST_SPEED must be lower than ARSPD_FBW_MIN otherwise one gets too much ‘assistance’ at the lower airspeeds.

BTW, [quote=“Oubie, post:480, topic:31042”]
If the Nimbus stalls at 11m/s and you have set GPS speed at 15m/s
as soon as you get a tail wind of more than 4m/s the plane will stall.

This is not quite true as whether or not one uses an airspeed sensor, Arduplane calculates the wind speed and direction and will increase the plane’s airspeed to try to always fly at, at least ARSPD_FBW_MIN. (To quote: This is referred to in the aviation business as PFM, Pure F’ing Magic.
The magicians (Tridge and Paul) use accelerometers to calculate the approximate wind velocity.)

There’s more about that here:

Hi Graham,

I agree. I just have the added confusion that the airspeed logs graph to crap while the GPS ground speed seems fine. The cure for me is to disable ARSPD_USE. The Nimbus transitions and forward flying are then superb. I’m using stable Plane v3.9.8 on a Pixhawk 2.4.8 (Pixhawk 1) pulled in from Mission Planner.

Is your setup using an analog AS sensor? Pixhawk 1? Is there any other commonality between our setups that might suggest an area to look? Doesn’t the code have a transition time-out on reaching ARSPD_FBW_MIN or revert to GPS speed if the airspeed data is garbage?

I’ll connect another AS sensor this afternoon and look for differences.


The second analog AS sensor behaved the same when blowing into the pitot tube. You can see the Airspeed gauge below behave properly. This was true on both setups. Perhaps if a bug exists, a workaround may be to install a digital AS sensor…for now.

After using a multi-meter, I figured out that the connector between the nose and body was not fully mating. There was no artwork or alignment issue…it was simply a depth problem. I fixed my nose connector problem by replacing the three stock screws in the nose board with slightly longer ones and added some spacers in the back to move the board outward. The spacers were held in place with tiny pieces of paper. Now, my AS sensor and gimbal power/control is back to being cable-free.

Greg, Thank you
Graham, These guys are magicians
My problem - hopefully you experts can get it from the log
I took off in QLOITER then change to CRUISE and after a circuit changed to AUTO
The plane pitched up, climb for a few metres , stopped and transitioned to VTOL ( hanging in the air)
I changed to QLOITER and tried to bring the plane back
All went fine but i had no rudder control.
My questions: Why did it not fly the mission and secondly why did the rudder died on me?

Can you post your mission file?

2019-07-10 09-49-23.log0wp.txt (668 Bytes)

Hope this worked

It comes out a bit odd when I open it in MP but I can see it. I think you need to take out the Take-off command from the mission as the plane will try initiate a take-off by going back to hover mode. If flying already then just put a waypoint in as your first mission item.

Not sure about the rudder, is this in 'copter mode? Because the rudder doesn’t work anyway on my Nimbus in plane mode.


Did you mean to say the rudder doesn’t work in copter mode? Or is this in plane mode in an autonomous mission?


Rudder surfaces don’t move in plane mode, yaw in copter mode works fine.

Thanks - will change my flight planning procedure and try again
The rudder movement might be that it went from CRUISE to VTOL
without a command (or a none standard command) and switching to QLOITER
over another CRUISE command ( very quickly) did not register properly.

Will check and report back in a week or so.

Hello guys, we just tested the Nimbus V1 with 12000mah 6s, flew 40mins with still nominal values on each cell. AUW was 5kg`

Hi Michael,

Which 6s 12AH pack was that? The Multistar 12C one?


Hello Greg, We use ACRA 30c.

BTW our V2 arrived. Hinges was improve on the tail, Servos were much smoother. Air speed sensor has only 1 hose. Tilt arms improve.


Very nice! It’s good to see hinges on the control surfaces.

1 Like

Guys, We wanted to set the AMP draw on the MP with our NIMBUS, if you guys already have a baseline can you help me out on this.


I’m not sure what amp draw you are setting. My setup is very close to a V2 so here is a graph from my recent flight using a light camera payload up front (no mapping camera underneath).

During the “Hover” period, the plane was ascending. For FBWA, the ground speed was 20m/s.

1 Like

Greg i was refering to the AMP use during flight. on the HUD bottom left side you will find the battery volt and the ampere consume during flight.

Ok, I see now. On my setup, which is not an official V2, I am using a calibrated Mauch Power Module and that information comes with it to be entered into the BATT_AMP_PERVLT parameter via Mission Planner. In my case, BATT_AMP_PERVLT is set to 64.73156, BATT_VOLT_MULT is 10.00387, and BATT_CAPACITY to 10000.

The only V2 model I have params for is Gordon’s and it reads BATT_AMP_PERVLT is 48…which may just be a default setting.