Integration of ArduPilot and VIO tracking camera (Part 1): Getting started with the Intel Realsense T265 on Rasberry Pi 3B

Thank you! Worked well using the USB method, however also tried with the serial pins, but there is no connection, I’m using the gnd tx and rx ports, but I’m not sure about de tty port asigned in de up board.

Using the USB, I can stablish the connection and start sending the pose estimation from the T265 camera, but in the QGControl interface in ubuntu there is no widget button to watch the Mavlink inspector and see if there ArduPilot is receiving position data by viewing the topic VISION_POSITION_ESTIMATEalso in mission planner Ctrl+F is not working, I downloaded both from the official sites, in Windows I’m able to open te Mavlink inspector but since I’m using the USB I cannot connect both, companion computer and my laptop. Any advice?

For QGroundControl you can use MAVLink Analyzer widget, see here.

@LuckyBird I believe widgets were removed on the latest versions (I’m on master)

@LuisVale Thanks for the info. Do you know of any alternative functions in the latest version for it?

I just downloaded the executable file from here and the widgets are still there, so @Eduardo92 you can still give it a try.

Thank you! It is working now! Also I was able to configure the bluetooth hc-05 module! The Estimate pose is being recieve by the ardupilot, I’m ready to fly! just one more thing, I’m starting the modules using ssh in my laptop, there is a why to get the rviz window trough ssh? similar as the python windows?

I am trying to use T265 camera with raspberry pi 3 for a similar project as described in this post, but get below error after some minutes:

19:57:13.679 [2601] [E] Device-63B0: FW crashed - got error in interrupt endpoint thread function: status = -1 (LIBUSB_ERROR_IO), actual = 0
19:57:13.932 [2592] [E] Device-63B0: State [ACTIVE_STATE] got event [ON_ERROR] ==> [ERROR_STATE]
19:57:13.932 [2592] [E] Device-63B0: Entered state [ERROR_STATE]

I tried with ubuntu mate and ubuntu server as well as updating realsense library (I used v2.23, v2.24 and 2.27), but got same error.

Did anybody face the same issue?

Hi @jcgarciaca, this might be a USB cable issue.

  • Are you using the original USB cable came with the T265?
  • Are you using a USB hub? Can you try connecting directly to the computer’s USB3.0 port and see how it goes?

Hi @LuckyBird, thank you for your answer.

  • Yes, I am using the original cable
  • I am not using any hub, but connecting directly to raspberry USB port. I tried with my PC (USB3.0 port) and it doesn’t show this error. However the raspberry only has USB2.0 ports.

@jcgarciaca are you running some applications that require images? If so, then USB2.0 is not enough since USB3.0 is mandatory to access camera streams, thus RPi will crash. For the use case that is described in this blog, we are not using image but only pose streams, hence the RPi is sufficient.

Hi @LuckyBird and @Matt_C,
I am not using images, only pose streams too. But I don’t get it working in my rpi 3.
I just upgraded to rpi4 and it seems that the error dissapeared.
Thank you!!

How are you power supplying the companion computer?

I used this power module to convert from 3S battery to 5V for RPi.

Thank you for your answer, I just ordered a couple of converters.

I have another question, wich telemetry module are you using? I´m trying to use the 3dr Radios at 915 kh, but the VISION_POSITION_ESTIMATE Drops to 2-5 hertz.

I am using this CUAV 915mhz and can get up to 20Hz, but occasionally the rate also drops to below 5Hz as well.

Those are pretty similar to the ones I have, which parameters are you using?
Only Bluetooth gives me stable hertz rate.

To access to the raspberry pi remotely are you using vnc?

Not using vnc, I am ssh-ing to the RPi through wifi and run the commands through terminal.

I understand, but I saw that you recorded the rviz output for the movement of the drone. So through ssh are you visualizing the rviz window?

ROS is distributed, so many machines can run different ROS nodes under the same system. You can read more about this topic here.

In this case, RViz is running on my desktop computer which just needs the correct ROS_MASTER_URI to connect to the master (RPi) which is running the main nodes.

hello @LuckyBird
I trying to send data position from OptiTrack system to arducopter via ROS.
do you have tutorial that explain how can i do that?
thanks for any help.

Hi @111188, unfortunately I don’t know of any specific tutorial for OptiTrack + ArduCopter + ROS, although the process should not be too difficult since all of the individual steps are already documented:

  1. Setup the system: follow OptiTrack + ArduCopter (without ROS) wiki by @chobitsfan to have all the configurations done correctly. The step about sending data to the drone (here) can be replaced by step 2, but I would recommend you try it out anyway.
  2. Send data to the FCU: follow this tutorial on interfacing OptiTrack with ROS and feeding OptiTrack data to the FCU.