EKF3 Lane Switch - almost a FRIDAY FAIL

Auto takeoff worked well, FBWA seemed ok at first, then all hell broke loose. You’d think we would have been safe at the worlds biggest flying field!

flight controller is a cheap Pixhawk 1. about 100 flights without an issue like this, but of course, only about 10-20 flights on Arduplane 4.1.x.

I would really like to know if this is a bug in EKF3 affinity switching, or a consequence of using a cheap flight controller. Would a Cube Orange have done the same?

log file here:

1 Like

@tridge any chance you can shed some light on this? thanks.

1 Like

It happens with Pixhawk 2.1 Cube Black also: EKF3 switching to DCM and back any help from @tridge or @priseborough would be highly appreciated.

Very strange at 0:37 to 0:41 roll indicator goes crazy and in consequence it rolls. IMU issues or a bug.

The lane selection logic got suckered into a switch to the second IMU EKF by a GPS glitch at 04:54:50. Unfortunately IMU2 had developed a large Y gyro offset before takeoff and was in intermittent bad health which allowed the switch.

This is another example where the user should have been warned by the GCS if the backup EKF is unhealthy.

Plotting the data for the two Y axis gyros shows the fault clearly:

I would disable IMU2 on that board.

2 Likes

Thanks for looking into this! Looks like a Gyro bias jump, but the sensor reading looks healthy for me besides this jump at 4:54:18. Are there any plans to add some preflight checks to Mission Planner maybe to find similar errors?