Servers by jDrones

Custom Maps in Mission Planner

(David Ardis) #1

Can someone give me a link to a tutorial on using custom maps in mission planner. I have a geo tiff created in pix4d that i would like to use an area with poor google maps coverage.

David Ardis

1 Like
To make google satellite map mission planner from uav imagery
(Michael Oborne) #2

do you have access to globalmapper?

please look at
http://vps.oborne.me/gcs/CustomImages.htm
and
http://diydrones.com/profiles/blogs/using-your-own-map-data-in-mission-planner

(Michael Oborne) #3

any application that can convert your geotiff to google tiles should work. OR a wms provider.

(David Ardis) #4

Michael

I have access to Global Mapper but the PIX4D Software i use does output as google map tiles.

I assume the folders have a certain naming convension and the images must be png

(Michael Oborne) #5

please try this then

open MP
control-f
"inject GE"
and specify the base folder of your tile export.

once that has completed you need to pick the maptype of “custom” in mission planner.

(David Ardis) #6

Michael

Got it working thanks

The problem was that PIX4D labels tiles and sub directories at the different zoom levels differently from Global Mapper.

David Ardis

(Michael Oborne) #7

oh ok,

what was the difference, i might be able to support it, and dont have pix4d.

(David Ardis) #8

I can help with the pix4d files

On pix4d if I choose a tile at zoom level 18 the tile is called 179093.png in a folder called 126577

On Global Mapper the exact same tile is 126577.png in a folder called 83050

I have uploaded a sample of both data sets to dropbox if you want to take a look

Global Mapper

PIX4D

(Giampiero) #9

Hallo David,
I have the same problem, using a tile created by Qgis:
A PNG tile, created by QMetatiles (a QGis plugin), zoom level 18, is named 96019 and is located in a folder named 139848, while the same tile from Google satellite Map is called 139848, in a folder called 96019.
So how did you managed to use the pix4d data?

Thank you for the answer, … or to anyone else who can help me on this.
Giampiero

(David Ardis) #10

Giampiero
I imported the files into grobal mapper and exported them back out into a format that Mission Planner will use the only issue i had was global mapper was a trial

(Michael Oborne) #11

in global mapper, what projection settings did it say where being used on the input data?

(Merrillho) #12

Hi Michael,

I’m following the instructions from your site http://vps.oborne.me/gcs/CustomImages.htm but can’t get it to work. Is there anyway to check if the tiles are successfully being imported by MP after the “Inject GE” step? I tried using the “Clear Custom Maps” button after the “Inject GE” and the message was “Removed 0 images” does that mean the “Inject GE” step have failed? I’m using MapTiler (http://www.maptiler.com) to create the tiles.

Thanks

Merrill

(Abhijeet Gheer) #13

HI Im having a similar problem where I have geotiff from pix4d that I am trying to import to mission planner. I tried the ctrl F > Inject ge > base folder. And I changed the maps to custom. Nothing seems to happen. When I select “Clear custom maps” I get a message saying “Removed 0 images”. Please help. Ive tried these steps with google tiles base folder as well.

I have also tried to do a KML overlay using map tools in mission planner, with a kml file but that doesn’t seem to work either.

Should I copy paste geotiff file in SRTM directory? if so where is the SRTM directory?

@Michael_Oborne

(cala2) #14

I did with global mapper in the past, not at home now but there is the info intructions here, try to search, if you dont find I see my instructions when return home at the end week.

(Abhijeet Gheer) #15

I will continue to search for the answers but it would be great if you could post them asap

1 Like
(Daniel Cross) #16

I have also run into this problem. I was able to use MapTiler to get some imagery into eMotion 3, but that format doesn’t seem to work with Mission Planner, nor do any of the other formats MapTiler creates. I’ve also tried using ArcGIS 10.6 to make a tile and map package which didn’t work either.

Unfortunately I don’t’ have access to Global Mapper.

Has anyone found a solution?

(Michael Oborne) #17

can you provide me wit a sample tile set? and a location on where it should be. and i will look at better supporting this

1 Like
(Daniel Cross) #18

I can and will. It is somewhat largeish, I think Google Drive might be the best way to share the data if that works for you.

Also, which data do you want? I can send you the original mosaic (geotiff), by bit-sized mosaics I made for MapTiler (png), the MapTiler tiles, the Arc tile package, and/or the Arc Map Package.

The site is DeepWater, in VA, owned by the Ward Burton Wildlife Foundation. The center is roughly 36°59’4.06"N 77°49’28.39"W.

(Olav Aamaas) #19

@Michael_Oborne: I find Mission Planner’s approach to custom maps to include a lot of labor. I made a pull request to QGC to use Styled Mapbox maps (tiles retrieved OTA by an API, then overlaid). Slow progress afterwards, so I’m currently working on Tower instead (nice app for simple missions using a mobile device) where I also got that part working. The setup in the GCS is then reduced to simply adding user name, style ID and the key - any map customization handled in Mapbox Studio (or in the GCS by simply switching between different styles).
Any thoughts on supporting such a feature in MP?

(Michael Oborne) #20

Mission planner already supports mapbox.


and

the catch being there is no ui at the moment to specify the custom layer