Craziest / weirdest crash / runaway - What went wrong?

This morning after about 8 minute flight while at about 200m above me, I have started descend and at about that time I get a warning from telemetry that it switched to RTL.
Long story short, it started switching rapidly between PosHold (original FM) and RTL. I tried to switch to stablize but than it switched RTL and Stabilize.
During this horror script, it seemed I was gaining control back for a few seconds but lost it.
Damage - one propeller - lucky me.

This is the actual behavior

I am using FrSky Taranis X9D Plus with R9M and R9 receiver 915Mhz.

I’m lost here, was my band hijacked, malfunction in my radio? where should I look?

the log file

Quad H, Using Pixhawk 4 Latest ChibiOS RC, 400kv motors with 5S 16000 lipo.


Yeah, definitely looks like your TX or RX is on the fritz. Do you have a receiver failsafe set? My first guess is that the TX was losing and regaining connection, and the receiver was failsafing to the preset values. This is happening for all RC channels. I’d say check your antennas and your RX failsafe setting.

@Anubis Hi Rick,

Thanks for response. Actually on my Taranis X9D Plus, fail safe is set to “no pulses” it might be that when there was no connection than the receiver didn’t pulse to Pixhawk so RTL, when connection regained it pulsed and Pixhawk returned to original flight mode?

I don’t know how fail safe works exactly? if RTL is enabled, what makes it return to PosHold or Stabilize? just doesn’t add up.

Thank you for your help,

Doesn’t look like that’s the case, because the RC channels are jumping to weird values. Channels 1 and 4 are going to 2000, for example. If it was set to No Pulse, then we’d see all channels go down to 0. This also means that the Arducopter RC failsafe was never engaged, as it’s configured to look for a throttle value of <925, but channel 3 was jumping down to 1039.

It might be worth experimenting to see what the behavior is when you disconnect the TX. You can use Mission Planner to see what PWM values are being received when you turn it off, just to make sure that the failsafe setting is working properly.

Besides this, I guess some possibilities might be:

  • TX is damaged and sending weird PWMs. Can happen if the Taranis gets wet, but I’ve never seen it this extreme. You can check the Channel Monitor page or Outputs page to see what values it’s sending.
  • Jamming/hijacking. Difficult to do accidentally, so I’d say it’s unlikely unless you happen to have a disgruntled neighbor with technical aptitude. Also the situation didn’t seem to improve as the drone got closer to you, so I doubt it’s an interference issue.
  • Some other hardware failure. See if you can reproduce this problem safely, such as with Mission Planner’s channel RC calibration page. If you can get it to go haywire again, you can start experimenting with replacing hardware to isolate the issue.

@Anubis I did the test on the fail safe page in MP a few minutes ago and the behavior was exactly as it should be. Also, it is un-reasonable that connection was lost since I was getting telemetry from the vehicle the whole time to my Taranis’ FlightDeck script (it drove me crazy with the messages RTL FM, PosHold FM etc.).

There is a huge communication antennas field about a 1000 yards from where I flew dozen times and never had this issue before, however yesterday, I flew at a different location and suddenly RTL was engaged without me touching the switch, I didn’t pay too much attention to it, however it adds up, I might have hardware problem :frowning: I use the R9M with R9 receiver so maybe that is where the problem is.

I really don’t know how to try to reproduce it safely, today I was actually in a huge empty parking lot where I’m not endangering others, just my quad, but its an expansive one :wink:.


It looks to me like it was switching flight modes from all the garbage on Chan 5. Graph RCIN CH5 and take a look.

Thanks for drawing my attention to it Dave. Its not just Ch 5, its on all channels and it looks like it has a pattern to it, so maybe its just a powerful broadcast from outside source? I didn’t think on that until the last few seconds before crash where I turned my radio off, but it was too late (not a trained pilot yet).

Note, that there is no radio FS activated also, all channels show the same wave. As I said earlier, there is some kind of a huge communications station nearby, and I mean antenna grids that stretches to 1km or more, so maybe that is all that happen :disappointed_relieved:, I guess I’m not going to try to fly there again.


Its not just channel 5, ALL channels have similar noise. I’ve heard some whispers about issues with the R9 stuff on RCG

From where I sit it looks like you got hit by a transmitter…

I have had the same thing happen with my R9M and an R9 Slim.Mode switching from Ch 5 “noise”. I posted a similar log on here a few months ago and one of the Dev’s pointed it out.

What doesn’t make sense to me in an afterthought on my theory is that the “noise source” is not bound to my receiver so how in the hell the FC sees commands?
Maybe, the receiver did that? It was actually a hot day, the receiver sits in the sun, the quad was at 200m just rotating on its axis and the receiver got hot or something?
Does it make sense? If you had a similar issue, maybe the r9 is prone to such problems ?

What R9M power were you using at the time? And what R9M firmware?

Here’s my post about my issue with R9. Appears to be the same issue as you, but yours is more severe. I only get the problem when miles away using 1W transmission. I have not had the issue with 500mw or less.

Hi Keith,

In my case the transmitter was at 500mw, and it was changing between RTL which is on channel 8 on my Taranis i.e. configured separately from the other flight modes (on channel 5) to the current flight mode which was Position Hold.
I have tried during that crazy behavior to switch to Stabilized so the switching behavior continued between Stab and RTL.
Just seconds before the crash, I tried to turn off the Taranis but it was too late.
To your question:
Both R9M and R9 were updates to FW up to version 180329.

As more I think about it, I am more convinced we hit a bug in the receiver. I don’t think its in the transmitter since it was playing ‘nicely’ and sending the correct commands to the receiver.

We need more input from R9 owners.


If I were doing this I’d switch to a “conventional” TX and RX combination. If the noise issues go away, then the R9 stuff is “bad”…

FWIW, I’ve had similar issues with a STorM32 gimbal controller. It is VERY noisy on the 900mHz band and it splattered my telemetry radios… Putting a capacitor on the power input fixed it…

It didn’t happen again. The receiver has a telemetry cable connected in parallel on the sbus port and tarot gimbal on sport.

That makes no sense what so ever. Post pictures and/or a video of how you have every thing connected…

Same weird behaviour (and crash) on my drone and on the drone of another user from Switzerland, see here: