Copter gone out of control and crashed, fubar


I had a crash with my fawn rescue copter yesterday. It has worked flawlessly for many flights, also for several similar flights that day. The weather was perfect, almost no wind and very dry and beautiful evening sun.

My copter went out of control during an Auto mission (I think it started with an compass error and then some tremendous GPS glitches followed. Vibration failsafe engaged and some EKF messages emerged) and I barely managed to bring it back to ground. I decided to voluntarily crash it. I crashed with very high lateral speed (no chance to controll that) and the copter was totally destroyed. Would have been a great video… .

I’m a little bit desperate and need help. Could someone have a look at the log files to see what the reason was? It might probably be interesting for people working with failsafe behavior.

Here comes the log file:


If you post the logs I’m sure someone will take a look.

Yes, thank you! I would prefer to send the logs via PM though and I hope people can understand that. If the problem has some value for the community I want to share it of course, but I don’t want to share the logs of this flight with the whole web yet (if it is not totally embarrassing I’m happy to share it later, its very impressive).

you could try
if you dont’ want to show real coordinates. This pages gives you the possibility to randomize them before sharing :wink:

Thank you, I tried but I’m to stupid to download it again.

I think the crash was caused by a compass error (got a EKF ground mag anomaly message some seconds before the crash) combined with some unfortunate gimbal and dampening problems.

to me it looks like the problem startet there
then you tried RTL which doesn’t work without valid GPS data

this message I get sporadic but without any negative effect

next time you could try “alt hold” if GPS is not working. It should prevent the copter from gaining speed

Thank you! Unfortunately the copter gained speed very fast. I have a Herelink and its missing tactile feedback for mode change. I tried RTL, then Loiter and after that Alt Hold. The copter was so fast and changed the heading that I hoped to stop with GPS first. But you are right, thereby I was loosing valuable seconds where the copter went even more crazy.

I did not have Stabilize on a button. I think with Stabilize (with my Taranis I use Stabilize as standard) I would have rescued it, at least crashed it in a way which where it hadn’t end up fubar.

It was an expensive lesson to bring back Stabilize on the buttons. Its simply not possible (for me) to use a touchscreen under such circumstances. Also to use Stabilize as first mode when something goes wrong and only go back to other modes after stabilizing the copter.

What board you had in the copter?I had similar crash on my helicopter using latest arducopter on OmnibusF4V3.I also had similar GPS glitches even thou gps itself was working okay i think.

But tridge said that i had a IMU failure.

Interesting, I think it was a barometer failure (I also went for GPS and vibrations before). I have a Pixhawk.
It suddenly jumps from 80 to 3,000m. Since them everything was a desaster.

I think I found the post.

looking into the logs is always the best idea (if possible :wink:)
there you have all the sensor data to check if it’s valid

You are right. I uploaded the file.

I think there are several strange things.

The gyro has a step in its data, probably due to temperature differences?

The baro shows a huge spike

I found another post which might be correlated (I have had anti spark plugs too, I did remove them now). Maybe that is an important finding that anti spark plugs are dangerous.

Another question would be if a temperature change inside the case with the flight controller could cause such behavior. I have a Herelink Airunit which heats up the copter quite significantly. Maybe a fast start could mean that there is a huge temperature difference between initializing and flight.

this is what my gyros look like in 2 different flight situations:

this looks strange for sure!
but I would have hoped that just a spike doesn’t confuse the EKF completely, but I’m not into that so far.

hmm, as long as your main contact in the plug is good it’s fine

you could check the IMU temperature in the log within the IMU section: “T” :wink:

1 Like

I’m thinking to put a 470 µf capacitor into the SPI-connector next to the power-connector of the Pixhawk to stabilize the 5v supply. Is that a bad idea?

I had a quick look, and there are some key things that happened:

  • IMU.AH and IMU.GH went to zero, which means the first IMU was not healthy. That meant that the first EKF lane failed over to the 2nd IMU
  • when the innovations rose on the first lane, it switched to lane2
  • there was a nasty step in the 2nd IMU gyro, and some nasty glitches in the 2nd IMU accel readings

What this all adds up to is your main sensor SPI bus started misbehaving. That bus has both of your IMUs on it, so suddenly you have two unreliable IMUs.
I’ll look a bit more closely soon, but pretty clearly you had a very unhappy SPI bus.
Cheers, Tridge

1 Like

I have noticed spikes during when the ESCs do there idle beeping. Could that be the source of the error or is this simply the motor movement?

Is it normal that the Accel Z has such a large value (965) compared to the others?

The Accel Z value comes from gravity :slight_smile:

1 Like

Ah, that is kind of obvious. Thx for the hint!

I replaced all Pixhawks with “mRo x2.1 777” flight controllers and I hope these issues are gone. We have already rescued 4 fawns on 40 ha and I hope we are now ready for a successful season with thousands of hectares and hundreds of fawns.

Thank you all for you’re help!

1 Like