Copter-3.6.8 released!

Copter-3.6.8 has been released as the stable/default version for Multicopters and Helicopters. This is a critical release to address issues with IMU failures especially those occurring on Hex Cubes (bulletin from Proficnc/Hex)

The changes vs 3.6.7 are here in the ReleaseNotes and also copied below:

  1. Safety fixes
    a) Prevent loss of active IMU from causing loss of attitude control
    b) Added startup check for Hex CubeBlack sensor failure
    c) don’t reset INS_ENABLE_MASK based on found IMUs

Thanks to those who helped during the short beta testing period!


Great, how come there is no stable /Copter/stable/CubeBlack-Solo , while I got the Beta from Copter/latest/CubeBlack-solo ?

Anyone having GPS signal problem errors? After updating I’m getting this on three units. But with 21sats and an hdop of .5, I can’t imagine the problem.

The build targets for Solo are in Master (3.7-dev). They are not backported into the 3.6 branch.

X1Aero Your description fits my problem, in my case 21 sats and hdop of .6 getting “bad gps health” error on both 2x pixhawk 1 controllers started from version 3.6.6 for me. I changed to a new power module at the same time so still tracking down where the problem is.The new power module was very close to the flight controller. So my thinking was EMI problem. Have relocated the power module just waiting for a longer cable to see if that was the case.
Did you do any hardware mods or was it when you updated firmware?

None. And I’m getting the same problem on my third unit, which is a few year in service as well. Maybe it’s a glitch in MP?

I also have sometimes the massage “bad gps signal” and it’s probably because the GPS can’t deliver 5HZ. I have set my Ublox to receive also galileo and thats the reason why the 5HZ isn’t stable. I never had problems with this warning.
Have done three flight with new 3.6.8 on cube Black (before 2019) - no problems but the bad AHRS massage still is present at first boot. After recycle power it doesn’t apear.
PreArm: Waiting for Nav Checks
PreArm: gyros still settling
Frame: QUAD
CubeBlack 002A0034 3337510F 37353832
ChibiOS: d2030d88
ArduCopter V3.6.8 (2f409678)
In MP Status bar qy2 is allways much more off than the other gyro values. After restarting the Cube gyro2 levels are more constant. I calibratet the sensors after they warmed up about 40°C.
Don’t know what to do exept repower or take off bevore the massage apears. :slight_smile:

greetings to the dev team and a big THANKYOU


Same here, “Bad GPS Health” over and over again since 3.6.6. The logs show that the Here GPS can’t maintain 5hz (<250ms) update rate all the time. Some days are better than others. The other day I had the alert constantly every 2-3 seconds. 70+ alerts for short flight.

I tested this on an older machine (Pixhawk 1) with older generation uBlox GPS , same issue (although alerts not as frequent)

I receive the alerts on Mission Planner, QGround Control and Taranis Flight Deck software. So it is arducopter code rather than specific ground station software.

Before 3.6.6 looks like the update rate wasn’t monitored and hence no alerts received. But maybe its normal for some GPS systems, or some geographical locations to have a slightly slower than expected GPS receive time?? I am in New Zealand – at the end of the earth lol.

I’m no expert but I would expect a simple filter or delay, or averaging integer on the GPS receive time would solve this…

1 Like

Have you enabled a third constellation, like enabling Galileo in addition to GPS and GLONASS? That’s what will happen. No ublox M8N can do 5hz with three constellations enabled. That’s why the HERE only has GPS and GLONASS enabled by default.

Both copters are setup as MODE 0 = Leave as currently configured. I’ve never touched this setting. But will choose a mode with 2 and see how it goes.

1 Like

Hello everyone,
Yesterday I made two flights with my 210mm., Quadrotor and I think they are perfect, even in conditions of strong winds. (No alert message.)


Althold is ok.
PosHold is ok.
Loiter is ok.
RTL is oK.
SmartRTL is ok.


Woowww !!! Very nice !!! Congrats !

Thanks! love that copter!

I seem to be missing RC9_OPTION. Does anyone else see that?

Upgraded from 3.6.5 to 3.6.8 and didn’t have any issues with some test flights.
Landings (RTL and Land) had a bit of bounce but that could be because we used 1 single battery instead of the usual 2 flight batteries. We took the opportunity to adjust a few of our landing parameters.

On 3.6.5 we had also seen the Bad GPS Health warnings and you could see the slow update frequency when the number of sats went up over about 16. We didnt see that at all on 3.6.8 but it could just be GPS conditions beyond our control. I’ll check logs for that again.

Checked logs: even though number of sats was up around 17 to 19 the whole latest series of flights on AC3.6.8 , the GPA Delta (update rate) stayed around 200ms the whole time and we didn’t get any more of the GPS Bad Health warnings. u-blox 1 HW: 00080000 SW: 2.01 (75350)
Probably dont take this as confirmation that anything is fixed or changed recently in this regard unless Randy says so, it could still be down to GPS conditions beyond our control.

I recently updated several pixhawks and cubes from AC3.5.7 to latest firmware via mission planner. I am using a teraranger one and tfmini on a few. After updating to latest I am no longer getting telem data back from the rangefinders. The tfmini is using serial2 and teraranger i2c. tried swapping serials, no luck. Checked each sensor with benewake gui and hterm and they work perfectly. Reverted autopilots back to AC3.5.7 and they all worked fine.

I scoured the forums looking for similar issue with no luck. Has anything changed/updated in setup or the code to effect the rangfinders’ in such way since AC3.5.7 before I start combing through the firmware?

just looking for a quick answer, if any, or to be pointed in the right direction.

Not sure if it will help in your case, but I found that I had to power the lidar after the autopilot boots in order to get the lidar to properly communicate with the autopilot. I am using a lightware LW20, so it might be different for you.

Thanks for the response, but that doesn’t seem to work either. Oddly, I am getting proximity reports from a VL53L0X though running AC3.6.8 on Pixhawk FMUv2, but still no teraranger one report. HMM.


I see one change related to the RNGFND_ADDR parameter for the Teraranger One. The address was previously hardcoded but now it uses the RNGFND_ADDR parameter.