Copter-3.6.8 released!

Been playing with that. Default for first batch of terarangers was 0x30. However, after boot mission planner shows it to be 0x29 in parameters. I checked the address on the module itself to verify proper address, then resent it for added measure. Still no readout for teraranger or tfmini. With the tfmini I am getting a “Bad LIDAR Health” message. The fact they work with older AC Firmware and not the latest has got me stumped. Thanks for the link.

I have updated autopilot from 3.6.0 NuttX to 3.6.8 with ChibiOS. No changes made to drone or parameters. I have two problems.

  1. This wasn’t apparent on 3.6.0, but happens now with 3.6.8:
    What could cause this huge altitude rate spike when changing flight mode from Auto to Loiter. This is visible on image 1,2 and 3. Haven’t had this problem when changing flight mode between loiter and AltHold or when changing from Loiter to Auto.

  2. Existing problem:
    Which parameter I should tune to have correct vertical velocity on auto mode. On loiter the altitude control works perfect, but on Auto the actual vertical position lags behind the desired. Visible on image 2.

Relevant images from logs.





Link to log.

i am not very familiar with programming,
is it possicle to change the param RTL_Alt= 160 to zero and then upload the firmware on the copter ?
while when its written 160 itwill not read the value for less than 160 if I want to change the parameterin param list in mission planner.
many thanks for helping. @rmackay9