Copter-3.6.6 released!

Copter-3.6.6 has just been released as the stable version for multicopters and traditional helicopters and should appear in the groundstations in an hour or two. The changes vs 3.6.5 are in the ReleaseNotes and are also copied below. This release includes one critical bug fix which is rare but still we highly recommend upgrading

Changes from 3.6.5

  1. Bug fixes
    a) EKF compass switching fix for vehicles with 3 compasses
    b) CAN fixed on Pixhawk4 and PH4-mini
    c) Mini-pix uart telem1 and telem2 reversed
    d) Divide-by-zero protection if _FILT_HZ params set to zero
    e) Guided_NoGPS skips GPS pre-arm check
    f) TradHeli roll trim ramp time fix
    g) First Spline waypoint no longer skipped
    h) RC override (from GCS Joystick) disable fix (command to disable overrides could be interpreted as real input)
  2. AP_RSSI fixes and minor enhancements
    a) RSSI pwm input driver for ChibiOS
    b) add V5 Nano to RSSI_ANA_PIN parameter description

The critical change is the EKF compass switching fix (highlighted above). The issue is that on systems with 3 compasses (which have become very common) the EKF could continue trying to use a “bad compass” even after it had determined that this compass’s heading doesn’t match the GPS and IMU. This can lead to the bad compass negatively impacting the vehicle’s position and/or attitude estimate leading to a loss of control and a crash.

Thanks very much to those beta testers that helped us over the last week testing this latest improvement.


Hey Randy,

So the ESCs are not getting calibrated using Copter-3.6.6, by default the servo outputs are all disabled. I put them as required, and yet it didn’t do anything. All the ESCs are working when i manually check using the reciever. But when they get connected to the Pixhawk v3, they don’t recieve any signal from it. Using Avionic ESCs, which were working perfectly before.

Hey Guys,

So i solved the problem of the motors not spinning at all during ESC calibration mode

The servo parameters are all disabled, so enable it for the motors, and the safety switch mask needs to be changed to 16368, to enable channels 1,2,3,4 to work without pressing of safety switch.

Hopefully it will help someone.

Good day, how i can enable the servo for the 4 motors and which parameters i need to change coz there are many.
waiting for a kind response

Awesome! When will In-flight compass calibration RC control be added? I know that it’s currently in the master.

I can’t connect external baro!!! PLEASE FIX IT!

There is NOT parameter - GND_PROBE_EXT

Px4v2 AC3.6.6


Hi Dave,
GND_EXT_BUS: External baro bus

Note: This parameter is for advanced users

This selects the bus number for looking for an I2C barometer. When set to -1 it will probe all external i2c buses based on the GND_PROBE_EXT parameter.

And at first i need find GND_PROBE_EXT


I guess this is unrelated to the 3.6.6 release? i.e. perhaps this is a new vehicle and 3.6.6 is the first version being installed on it? or is this something that was working in 3.6.5 (on this vehicle) and is no longer working?

I’ve tested ESC calibration just now and test flown a quadcopter and it seemed fine. Perhaps if you have a log.


I’m afraid in-flight compass calibration will need to wait until Copter-3.7. It’s too big a change to backport to Copter-3.6 I think and there are dozens of new features in Copter-3.7 so it’s more efficient to beta test them and then release them all together.



I guess this is a new vehicle and the problem is the ESC calibration can’t be done nor can the vehicle be armed? I suspect that either the frame-class and/or frame-type needs to be set or the radio calibration needs to be done. At the moment the pilot tries to arm the vehicle a message should be displayed on the ground station’s HUD that tries to clarify what the issue is.

Beyond this, if you have a dataflash log I can have a look but if this is unrelated to the Copter-3.6.6 release (i.e. it was working on 3.6.5 but has stopped working with 3.6.6) then could you create a new topic in the Copter-3.6 category?

Any idea on a ballpark ETA for 3.7? Thanks again for all the hard work!

I’ve try with a pixracer and i don’t have found any issue, with x2.1 I’ve set the frame, ive done all the configurations required but I can’t calibrate the air gear esc. looking in the parameters servo functions are all disabled and about the pwm min is 1100 and for pwm max is 1900.


We haven’t set a date for starting beta testing of Copter-3.7. I would guess it will start in 2 or 3 months. We need some time to finish off the development of some of the core new features which will include Lua scripting onboard the vehicle and stay-out zone support.

1 Like

@Dave84, if a .bin dataflash log could be downloaded and posted that would be good…

ok… i will download it later and I will send it to you

Hello, I have updated the firmware to version 3.6.6 and the GPS is detected by the flight controller but can not find any satellite. I have tested with two other m8N GPS without success.

I’ve tried a new Pixhawk with the same result.

After this I tried previous firmwares, reset default parameters, and only once I got GPS to detect satellites and do 3D FIX. When I repeated the procedure, it has not detected any.

Please, any advice will be welcome.

Arducopter doesn’t really affect the reception of satellites.
I can have vastly different reception on different days… One day it might take 30 minutes to find 6 satellites. The next I have 16 in just a few seconds. The next I might not get any. But if I drive several miles to a different location, all of a sudden it works. GPS can be very unpredictable.

Thanks for your answer.

The number of satellites that a GPS receives does not depend on Arducopter, it is clear. In this case it is not that I receive few satellites or are inconsistent signals, it is that I receive 0, constantly.

Maybe my 2 Pixhawk with firmware 3.6.6 have modified the configuration of my 3 GPS. Returning to firmware 3.5.7 they still do not work.

I do not know if Arducopter modifies the configuration of the GPS but it does not make much sense that downgrading to a previous version that has worked perfectly, still does not work.