Copter-3.4.2-rc2 is available for beta testing

Copter-3.4.2-rc2 is available for beta testing through the various ground station’s Beta Firmwares link. This is a relatively minor update on AC3.4.1 including just the following few changes to address issues found after AC3.4 went out.

  1. Minor Improvements:
  • ACRO_Y_EXPO applies to all flight modes (but is defaulted to zero)
  • Autotune timeout increased (helps with large copters)
  • AltHold filter applied to P (was previously only for D)
  • arming check for compass health (was previously only a pre-arm check)
  1. Bug Fixes:
  • compass calibration (onboard) fix to return completion status
  • LeddarOne driver busy-wait fix
  • SBF GPS altitude fix
  • MAV GPS uses existing configured baud rate instead of auto detecting

If any beta testers could us test this and give feedback, we’d really appreciate it! If all goes well we will release this as the official version in a week or so.

By the way, there will be an AC3.4.3 as well which we hope will include fixes to these issues:

  1. px4flow not working on pixracer
  2. shorten time for GPS driver’s to gps type being used
1 Like

this is an autotune test with rc2.
Y6 2300g.
No Problems, Results are well flyable.


Onboard compass calibration will work

What is time out in AT?
I had some long autotunes but never hit timeout…

AltHold filter applied to P (was previously only for D)
Does this means it will “hold” better?

arming check for compass health (was previously only a pre-arm check)
does this mean you can not take of even if you disabled prearm?

What is SBF GPS altitude fix?

SBF stands for Septentrio Binary Format and is the GNSS format of messages from their boards.

There is issues with the format conversion <3.4.2

7 posts were split to a new topic: LeddarOne testing in 3.4.2-rc2

Tomorrow I will fly it on a brand new Pixfalcon. And I will do autotune. I will report what happens here (=


its nice to have an update, but I would still like to know why it happens that all motors stop midflight with the logfile error “crash check”. There was no crash but this error message has produced one ( and loss of money). I would like to get away from the feeling that with ArduCopter a crash can happy any time as this is the third crash without knowing why.
I would appreciate if the developers would care a little to deal with such things and talk to the user instead of hiding.



Hiding? Really? Oh boy.


Please point where you have posted these crashes along with their logs.

So what you’re hitting is the crash check. There’s a wiki page about it here which describes when it can trigger:
In general it means the vehicle is quite out of control. It can happen with a very bad tune but it needs to be really quite bad. The crash check can be disabled but it’s probably best to get to the root of the control problems.

I agree it is best to find the problem. The copter was tuned nicely and flying quite well for some time. Also at the last flight. The only difference to other flight was to fly in POSHLD as I normaly fly in STABILIZE. I also was flying fast to left side holding the the stick at full. Everything was as expected when the motors turned off.

I dont have logs of the other to crashes as they are a few years ago. I am not mentioning crashes because of my own fault ore crashes due to a problem with MP.

Here are the links where I have writen about it:

Thank You


PS: I have red the wiki.

Thank you guys for you hard work! I tried the firmware (3.4.2-rc2) last night for my quad copter. I intended to config the setup for loiter mode with optical flow (no GPS). While the same configuration did not work with firmware 3.4.1, it work perfectly with this version.

My quad equipped with Pixhawk (clone), PX4flow (clone) and TR1 range finder. I first follow the setup described in Then followed by the configurations below:

AHRS+GPS_USE = Disabled
EK2_ALT_SOURCE = Use Range Finder
EK2_GPS_Type = No GPS use Optical Flow
GND_PRIMARY = 3rd Baro.



First of all, your crash was with a different version. So much has changed since 3.3 that it is hard to link a crash that happened with 3.3 to anything happening with 3.4.

Second, we have stopped support in DIYDrones months ago so it is to be expected that there’s no developer response there.

You posted here too, 17 days ago. It is unfortunate that you didn’t got an answer, but the title of your post doesn’t help at all. You should remember that ArduPilot is run on a voluntary basis so time in the forum is limited and we can’t check every post. Calling out developers by saying we are hiding isn’t really fair.
You should also remember that there are commercial support options available so if you want to really demand something you can always pay for it.

ArduPilot doesn’t exist without a community and we work for benefit of everyone, but there’s only so much we can do.

1 Like


thanks for your mail. It was not my intention to be unfair, I appologise for that. Fact is that I still dont know why the copter has crashed. I thought that it is also in the interest of the developers to get a report about issues. Not getting an explanation is very frustrating. It looks to me that the problem is inside the software. As I am getting no explanation the only thing I can do and recomend to my colleagues is to use 3.4 and switch off FS_CRASH_CHECK.
For me there is no point in buying a Pixhawk 2 as long as I have to fear sudden crashes. I hope you understand that. At the same time I dont want to keep you busy writing emails to frustrated customers.

So the problem is back on my table and I have to plan how I am going to continue flying drones.



3.4.2 rc2 todays short test

more details about testing and setup here;

I have tested AC3.4.2-rc2 today. I have finished the test about one hour ago.
This is the video of the test. We talk in italian, but you can see the copter flying:

I have used a brand new PixFalcon and it is all right.

I have tested:
-Autotune on Pitch, Roll a Yaw. Everything all right OK
-Compass calibration. Everything all right OK
-New parameters for silence the buzzer. Everything all right OK
-Flying in AltHold, PosHold and RTL. Everything alla right OK

I have noticed two things:
-After finishing the autotune the mission planner do NOT show any message like: autotune success.
I remeber clearly (I also have the video) that mission planner have messages for autotune success on AC 3.3.3.
Why with AC3.4.2-rc2 we do not have these messages?
I’am sure that we do not have this messages since I have tried two times.

-About the failsafe for low battery. It work. It works very well. But I’am a bit surprised about the behavior. If I set the failsafe for battery at 10.9 it start to land at 10.4. If I set the failsafe for 10.7 it starto to land at 10.2.
Is this correct?

A post was split to a new topic: Tuning values in Copter 3.4.2-rc2

I have been trying to figure out if a “PX4 software low pass filter on the SBUS input” for RSSI has been implemented in ArduCopter yet like the PX4 website claims it has in their config. ( The only information I can find in Ardupilot is that an external filter is still required. Is this the case? If so are there plans to implement this in the future?