Continued problems with TXMODv2 RFD900x frsky telemetry

I’m still having problems with the TXMODv2. This is not a problem with arducopter, so maybe I’ll get dinged for posting it here, but there’s no dedicated RFD900x forum and I can’t find a better place to get good advice.

I love the ability to run the RFD900x radios for RC coms and also have, in one package, the frsky telemetry converter for the @yaapu script, all in one module plugged straight into the back of the taranis.

The problem is, it’s super buggy! I can’t count on it. Today the voltage readout froze up on me, so I thought my batteries had much more voltage than they actually did–I got lucky and didn’t crash, but that just isn’t a good situation. I need to be able to count on the voltage that’s reported.

I only know because I checked the FC flight log, saw the crazy low voltage. Then I checked the tlog off the taranis, and it is accurate, in accordance with the FC log. The only thing that wasn’t accurate were the numbers I was seeing on the yaapu script—which were being piped to it (or not?) from the TXMODv2 module.

I also still have the same audible alert errors that others experience (here and here). Others report the situation solved, but certainly not for me. I only hear the “Telemetry lost/telemetry recovered” occasionally. Much more often I get the “motors disarmed/motors armed” audible warning, which is still unnerving even though I’m getting more used to it. Eventually I just have to mute the warnings, which is not ideal. It’s also indicative of problems with the telemetry reporting that’s happening under the hood–as evidenced by my bad voltage numbers during this morning’s flight.

so far as I can tell I’m all upgraded. Versions:
txmod 1.4.6
rfd900x 3.38
opentx 2.3.14
yaapu 1.9.5dev

Is anyone else still experiencing problems? Does anyone have solutions? What additional information/logs/settings/parameters would be useful for debugging my problems?
as always much thanks

1 Like

Yea im still getting some warnings like you but i need to go and do a lot of updating as way behind on all of them yes as you say very unnerving

What settings have you got in the RFD900X and the TXmod ?
Can you do a screenshot from the RFDtools or the TXmod web interface?

Let’s start with the data rate…
You should be able to set the data rate up high like in this screenshot.
Baud, Airspeed and Max Window are the ones to check/change.
(the unit pictured wasn’t used for RC control or connected to a TXmod at that time, but that doesn’t matter at the moment)

okay here are my local radio parameters (remote are identical):

sorry it’s not as easy to read as the Tools interface.

Looks like my baud is half of yours, but the airspeed is much smaller and the window is much larger. I will change all three to match yours and then fly again to see if it affects things positively. How exactly did you arrive at those choice of settings?

I experimented somewhat, but I had some hints these modems would do much higher speeds than defaults. I’d tried the low latency settings too, but couldnt get what I wanted.

Have you been through the full process with the TXmod setup via its own net page? Often starting over again is your best bet and running brd at 115200 and air at 64 is not an issue (unless you want crazy distances) Otherwise give us a call at RFDesign and Kent or Matthias will be the guys to talk to.
(07) 3255 6042

What settings would you recommend for 40k with a plane I have one of youy large antenna’s inbound the one you mount on a pole,many thanks and keep up the good work

Hi Marty,
Can you get a list or screenshots of all your existing settings, both TXMOD and airside please. You are using two antennas at each end right?

1 Like

Hi Shawn,I will do this in couple hrs and send to you and thank you for your help,ive built a small wing/plane and just want to send it a good few k asive seen others do but ned to build up slowly,how’s things with you and your family

@Lachlan_Eggins yes I have tried multiple times on two separate independent setups, going through the wizard multiple times in each case, without success. I’m about to go fly with @xfacta’s settings and if I see no easy improvements I’ll certainly give you guys a call, thank you very much for responding and putting out the contact info I appreciate it

1 Like

Well that was a waste of an hour—zero steps forward, one step backward sort of situation. I changed my local and remote radio settings using the web interface, saved and refreshed and took screencaptures (below), all seemed well, then I drove out to a good spot. The RC connection worked, but zero telemetry. And nothing I do through the web interface fixes it–I can’t re-run the web wizard because I get a “something is wrong” error, and even putting the settings back to what they were originally doesn’t bring back the telemetry connection. Time to connect direct with the FTDI cable I guess, and revert to factory settings so something will work again? Problem is I don’t have my FTDI cable here with me, so I have to can’t try that until day after tomorrow at the earliest.

Here were my original settings:

Here’s what I changed to (serial speed and max window are the only things I changed):

I had connection, that wasn’t the problem, and I could access the settings, but I didn’t have telemetry and couldn’t re-run the wizard. Any ideas why my telemetry dropped out? Also, any idea why my S0 “format” setting disappeared after changing the settings? Is there any troubleshooting I can do without an FTDI cable?

this is the web-interface error I get:

@xfacta 's settings are my settings, infact i have the txmod and rfd900 with me with the settings we are talking about :slight_smile:

Press the TXMOD section on the top right of the wizard and go to the right side at the bottom where it says “RFD900x Radio settings” You should be able to set it up that way correctly

Well I’m having a hell of a time with these things. I don’t know what’s going on anymore. Twice now I’ve put in the settings that you are using, via the txmodv2 web interface, saved it to the radios, and everything breaks. The result is that I partially lose coms with the radios–forget about telemetry and RC PPM, it even refuses to re-load the parameters after that, for either radio. I still have wifi coms with TXmodV2, and that’s it. Then I have to reflash the firmware to the txmodv2 just to get it working again.

Then I tried accessing the drone radio with the RFD Tools utility over USB direct to the computer, and I managed to get connected to it (after having to mess with shorting the pad to the case to force it into command mode) and also, over the air, to the TXmodV2 radio (which was then the “remote” radio listed in the utility). I changed two things–upped the serial and air speed. Saved those settings, reconnected and loaded fresh settings and… it didn’t take. So maybe I can’t/shouldn’t mess with settings from the RFD900 Tools app either.

Then after that, it wouldn’t communicate my RC PPM. So I went through the wizard again (which finally started working for me) and managed to get things back to nominal behavior again, so after two hours I’m back where I was at the end of last week, before I started messing with it at all.

So it’s definitely time for me to call support to get advice. First I’ll fly again though, maybe the telemetry problems will have magically disappeared after so much mucking about. At this point I’m reluctant to touch anything, because I was afraid for a while there that I wasn’t going to ever get it working again.

One question for this crowd: are all the settings on the TXmodV2 unit accessible through the RFD900 Tools utility? Or is the web interface required to get it functioning properly? I see the GPI1_1R/CIN and GPO1_1R/COUT checkboxes available in the utility, and also the “Set PPM Failsafe” button, which is all that’s necessary I think, as far as the radio goes. Of course the web interface would be required for changing wifi settings which aren’t available through the utility (so far as I see). But is it viable to set up the radios just using the utility, in this ‘reverse’ way? (where we connect USB from computer to the drone radio, and load up the TXmodV2 as the ‘remote’ radio as far as the utility is concerned). Of course it didn’t work for me, but I probably have other issues.

We had massive issues yesterday trying to set up 256bit encryption.
But in the end we managed it by:

  • disabling Yapu scripts on the TX
  • disabling Mavlink connunication between ArduPilot and the RFD868x airunit
  • connecting the air unit via USB (making the TXMOD the “remote”).
  • using AT commands to set the password

The web-interface really needs so more RFDesign love before it can be considered “useful”.

Hi Matt
Did you get it all working as expected?
I dont have a TXMOD with me to test anything further at this stage.

@xfacta The TXMod is back to nominal behavior, which is to say that I can fly with it, and it sometimes provides accurate telemetry, but eventually starts squawking spurious audible alerts (the favorites seem to be “motors disarmed” and spurious mode changes) and the telemetry is sometimes incorrect, particularly voltages. I don’t have enough time at the moment to troubleshoot it anymore, bigger fish to fry for now.

Check in the TXMOD web interface and ensure WiFi baud rate is the same as the radio baud rate you have set (57600 by default). This may not be a fix for you, but if you manually set the radio serial speed to 115200 like I do, you also have to set this. I think initial wizard sets them to match.
Also check S.PORT output is enabled, should be by default.

I use the same setup, but for me it usually works fine. The only issue I have is that sometimes (rarely) I have to reboot to establish a telemtry link at first. But after that the link is rock solid.

I have reflashed the TXmods ESP module with Mav2PT, which gets updated much more often and seems to work best. You also get support from the developer in the discussion thread (unlike from RFDesign): Mavlink to FrSky S.Port Passthru Converter for LRS or PX4 Pro