Servers by jDrones

Random "telemetry lost - Telemetry recovered" OpenTX-YAAPU-RFD900x-TXMOD-TX16S

I added the extra pin on my TXMOD for s-port to get telemetry via YAAPU on my Radiomaster TX16S… Everything works fine, but I’m getting random “telemetry lost” and then immediately “telemetry recovered” announcements. The tx and quad are maybe 2 feet from each other and I easily get over 2 miles with this setup. I’m thinking it’s either the script or MAVlink weirdness.

Arducopter 4.0.4
TXMOD with RFD900x
Radiomaster TX16S (openTX 2.3.10)

UPDATE: Flew a test flight and got the random announcements throughout the flight from several hundred meters to several kilometers away. My GS showed solid RSSI the whole flight, with the logs backing that up.

Anyone experience this? I know the signal is solid, but the alerts are very distracting. :neutral_face:

This is the reason. Try 3ft… Have not experienced it otherwise but don’t have the RFD900x radios.

That’s what others have said… Read the end of the end of my post. :slight_smile:

Happened all throughout a 10 minute 3 mile round trip flight.

Did you tune the Rx?

Good luck.

No, I did not. I am not using it. :grin: It is, in fact, disabled as I am using RFD900x radio modems (TXMOD).

UPDATE #2:

The two audio files for losing telemetry comes from OpenTX. RSSI is one of the sensors that were discovered in the radio settings. Now I’m thinking it may not be YAAPU related??

Also getting “Motors Disarmed” messages throughout the flight! That’s a bit too much to handle, and I think I’ll just remove the YAAPU from my TX. I’m using a real GS anyway… Can’t take the stress. :sweat_smile:

Hi Michael, I have been seeing the same issues as well.

They were discussed briefly in this thread: RFD900x-TxMod for Taranis X9D and Horus X12S with Telemetry. As a temporary work around we disabled telemetry alarms in the opentx menu to stop the “telemetry lost” and “telemetry recovered” messages. Then we went in an put blank audio files in place of the “motors armed” and “motors disarmed” messages. Then we set two edge triggers that play custom “signal lost” and “signal recovered” messages based on losing or acquiring the GPS sensor (s.port). It’s not pretty but it works for now.

Thank you. That’s a decent workaround. I’ll give it a shot and then decide if having a few bits of telemetry on my TX is even helpful. I rely on my ground station so much, plus there’s some considerable latency with the s.port telemetry.

I’ve had the telemetry lost message, but haven’t run into the disarmed message yet. That would be very unnerving. Thanks for the warning!

I’m experimenting with the same setup, (TxModv2, RFD900x, TX16s) and I’m curious what you did for a failsafe. I’ve got it set up to trigger RTL if I turn off the radio and that works, but the pixhawk doesn’t recognize it as a failsafe. It only sees it as a commanded RTL. Have you used GCS failsafe?

Thanks.

Allister,

In Arducopter, I’ve set FS_GCS_ENABLE = 1 and FS_THR_ENABLE = 1 - I also set the failsafe PWM per the RFD900x instructions. I think this “capture” of PWM values is what triggers the FC into failsafe for loss of RC signal. Naturally, GCS or loss of throttle PWM is going to happen simultaneously since both are sent over the same path, RFD900x radio modem link. Here’s the PWM failsafe instructions from RFD900/868x and ux Peer-to-peer V3.X Firmware User Manual

To record a failsafe PPM stream first connect the PPM generator to the ground station modem. Then
power up the receiving modem. Connect the ground station modem using the FTDI cable. After the
modems have established a link set the desired PPM failsafe stream using the generator and connect
to the ground station modem. Then send the following command to set the failsafe on the receiver
modem.

RT&R
RT&W
RTZ

This could alternatively be done by powering up the ground station and sending the PPM while
connected to the receive modem via the FTDI cable in which case the command would be.

AT&R
AT&W
ATZ

Please note that it is the modem that receiver modem that must record the failsafe mode.

Hope this helps!

I’ve found the telemetry lost/recovered audio files, but cannot find the motors disarmed/armed files. Where did you find them?

Thanks!

That’s how I had my failsafe setup. I haven’t tried with GCS failsafe yet, but what I’ve noticed is that the throttle PWM value only drops to the calibrated min value, not below like it would with a Frsky or spektrum receiver. Therefore it does not trigger the throttle fail safe. In stead it it goes to the failsafe condition that I set on my TX16S (controls neutral, RTL mode, armed). It would work to bring the plane back but the pixhawk never actually knows it’s in fail safe.

I didn’t mean to take over this thread. I’m going to do some tinkering and I’ll start a new thread later. Thanks for the help!

No worries! Looking forward to exchanging data in the future!

Servers by jDrones