Constant Yaw & GPS Issue

Hi All,

I’m having issues with my Pixhawk. This is my very first build and have used it as a training ground in reality. The Pixhawk I bought is a 2.4.8 and before anyone points out the obvious, I know what this is however as stated this was my first build and wasn’t going to spend big money until I knew I could get it in the air. Now that I have I’m moving onto my next build which I’m going to take my time with, I have already ordered an orange cube and a hex here3 GPS with RTK.

For now though I need to focus on what’s wrong with my current build and understand what’s wrong through the logs. I’m new to reviewing this data and not fully sure what to look out for, the issues are as follows:

  • Today I tried a planned mission (this has worked perfect up to this week). I switched the Pixhawk to Auto mode and it flew to waypoint 1, no problem, then to waypoint 2 (delay set at a height of 20m) then the drone started to go into an uncontrollable climb, I switched mode to land then RTL but I got no response. Eventually I got control through stabilise then the drone dropped quickly after I cut throttle but again got control. Then switched to RTL and eventually the drone came back to land but it again climbed to a lofty height where I have RTL set to about 20 metres. I think my GPS may be fit for the bin as my from the log the BAR - ALT and my GPS - ALT has a delta of about 80m, again not sure if this is right. This last week I am also getting a lot of EKF errors with an error message of altitude errors and GPS glitch. These come and go though.

  • The drone is in a constant CW yaw motion. Whether it is is in loiter or waypoint follow it constantly yaws. I have tried most things suggested here, props, motor direction, ESC calibration etc. but it hasn’t resolved. WP_YAY_behaviour has been set to 2 and 3. I presume where this works correctly the drone should yaw while my camera faces directly along the flight path? My drone is in a constant spiral. You can see this clearly in the log attached. If I fly manual I have to constantly correct the drone.

Any help is greatly appreciated and thanks for helping a newbie.

Vibration EKF error, Vibration Compensation activated into the uncontrollable climb. Deal with the Vibes in the usual way. Balance props (no matter what they are), better isolation of the FC, make sure no cables are keeping the FC fromr being free on the mount. What frame is it?

I wouldn’t be flying any mission until the Yaw problem is solved. Perform a simple hover flight in Alt Hold for 1 minute or so and post that log.

It’s a Tarot Sport 650 frame. I had a hefty enough crash last week and I think my GPS came out the wrong end. So I have ordered a new one. I want to really use this as training before I mount a cube orange and here3 to a frame. I want to try my best not to crash that…

Again, since our last contact it’s been going pretty well and haven’t had many issues bar the CW rotation issue. Since I had a crash it’s been going not so well so I’m presuming that may be a lot of my problem. Even without isolation on the FC up to now all has been pretty fine but will look into that also.

Question for you - how did you export the data to that format as the Ardupilot format I have as the norm doesn’t allow me to show data like you have shown. The way you have graphed is far easier to understand.

As regards balancing props, what is the best method? Anything specific I should do other than what’s on Youtube.

Will attempt an ALT hold and post the files.

Again thank you very much for your help, I really appreciate it.

The graph was created in APM Planner 2. It has the most useful options for multiple channel graph scaling. You can try UAV Log Viewer also.

For prop balancing I use a cheap magnetic balancer.

Hi Dave,

Happy New Year to you and your family. I’m only now getting back to the issue above. I’ve done a bit since we were last in contact. I changed the flight controller (new 2.4.8, not installing the Cube orange until I can get this issue resolved as it will crash and that’s a given). Also installed a new radiolink GPS. As above, I had a pretty heavy crash a few weeks ago where my battery calc. was incorrect and flying about 10m in the air the drone stalled and fell to the ground. The battery calc. I cannot get correct but I will worry about that separate.

I have tested the latest incarnation on the bench and briefly outside but the drone is reacting exactly the same as the previous drone I grounded after it being uncontrollable. The issue I have is the following - When I change throttle on my radiomaster I initially get a “potential thrust loss 2 or 3” error. That message clears and I seem to be at full throttle when at 50% on the transmitter (all have been calibrated on numerous occasions). 50-100% seems to be dead. Same when decreasing. When I switch to loiter which used to work perfectly the drone just stalls and falls out of the sky now.

The only parts I haven’t changed are the motors and the ESCs (Motors are Tarot 4110 and the ESCs are 40A Hobbywing X-rotor ( not pro)). I don’t believe it’s a motor issue as these should in theory either work or not. Could it be the ESCs not ramping up/down rapid enough but this seems to be across all motors and not just 1 or 2. I can’t see how this would be the case. The original drone flew perfectly until I crashed as above. I was flying automated missions and the controller worked perfectly also.

I have to date tried the following:

Installed new:
Pixhawk 2.4.8 - previous one worked fine until I crashed.
Radiolink GPS
X8r receiver
FC mounted on dampers

Following performed:
Radiomaster firmware reflashed and fully calibrated
Pixhawk firmware reflashed and fully calibrated twice
ESCs calibrated

I can’t fly in it’s currenmt state as I’m not spending endless money on an issue I know is there, I have seen posts on this forum to just fly and see but this is dangerous and I’m afraid I will lose control conmpletely. I’d like to auto-tune but as I say even in stabilise mode I can’t control properly as the throttle is not using the full range. The transmitter is showing it’s full range on the screen.

Any help again is greatly appreciated at this point. Should I change ESCs and motors as these are the last of the original parts. My endpoints on the radio for mission planner are 982 and 2005, should the lower endpoint be higher?

I’m genuinely stuck on this issue and don’t want to do any more until I have this resolved. Thank you again for any help.

A Tlog is of minimal value for troubleshooting this. Post link to the .bin Flight log from the flight controller.

The flight log is a waste of time. I found an old post on here that had the exact same issue as the above but it’s 2 years old, hoping someone can lend a hand. I think you also commented on some of the posts.

Link here:

It might be a waste of time for you… Good luck.

Apologies, I meant it was a waste of time purely because it never flew only 1 foot off the ground. I looked yesterday and I’m pretty sure that I’m getting 50% throttle output for 100% input on transmitter. I will post later if you think it may be of any use. As I said above I found an old post that is the exact same issue I’m having here. The fix there was to downgrade firmware to 3.3.3 but the board won’t let me do that? Mission planner only allows me 3.2.1 or any of the 4.x versions which don’t fix my problem. I’ve been trying everything I can think of for days but to no avail. As above, will post the .bib from yesterday later on.

OK, got it. The Parameter file can be extracted from a Flight Log even if there is not much in it and that can often be helpful. If it’s a typical Pixhawk 2.4.8 you should be able to flash the latest Stable (4.0.5) no problem. You for sure don’t want anything else. Update Mission Planner to latest Beta (button on the Help Screen) before attempting to flash it again. If this doesn’t work try QGroundControl and select Arducopter like this:

Got ya, will try that. Yes I can flash 4.0.5 on no issue but that gives me the 50% throttle issue. Will download the log shortly and post to see if you can take anything from it. Sorry for the misunderstanding above.

Post shortly and thanks again, I really appreciate your help.

As promised .bin file here. Hope you can give me some insight.

Have updated MP this eve toi the latest Beta. Uploaded 4.0.5 again. Will recalibrate tomorrow and try again. Will update you on the findings tomorrow. Thanks.

RC2_TRIM (elevator) is at 2005. Is the Tx trim sliders centered and have you done a radio calibration? Fix this and then post a log of it actually flying. Even if it’s just a short hover.

Ok will do tomorrow. I’ve calibrated radio, pixhawk, ESCs, etc numerous times. But can do it again and eliminate.

Well, when the command to the Front Motors compared to the Back Motors look like this some things become obvious. The value of a Flight Log even if it hasn’t left the ground :grinning:

:joy:. Ok so going by that is it not telling me that for 100% throttle input signal from my transmitter I’m not even getting 50% output? The pitch and roll channels are giving me 100% signal?I didn’t touch yaw so channel 1 is showing me 1000/1100 us?

Those are commanded motor outputs (RCOUx).
It’s being commanded to Pitch forward (full output to rear motors) because the elevator Trim is at full input
From your parameter file

Have you fixed this?

I’ll check but I’m pretty sure I have. That file may have been taken after I reset and reflashed my radio. It reverted to mode 1 which reversed pitch and throttle. Sorry I may have uploaded the wrong .bin file. I’ll be back at bench shortly so I’ll run again and send you that file instead as that’s the way I’m setup after changing radios to mode 2.

Here is link to latest log. Again this is no props on and tested on the bench. Any help again, greatly appreciated.

I uploaded 4.0.5 firmware to the Pixhawk and prior to that I updated the MP firmware also to the latest. Same issue again. 0-(approx)50% seems to have full throttle range on the drone, 50-100% change on my transmitter has no change on motor speed, and brings in a potential thrust loss 3 alarm each time. Same issue remains.

It shows Loiter mode not engaging due to the GPS not registering but this is because I didn’t leave long enough after the firmware upgrade to pick up satellites but when I do switch into this mode the motors slow and indicate a crash.

Thanks again.

Put props on it and fly it. You can tell very little from it sitting on the bench with no props. Motors are turning and in which direction is about it.

You can use Motor Test function in Mission Planner to test unpropped motors.