Constant Yaw & GPS Issue

Latest .bin file attached. I don’t think it’ll be of much use. Same again, got about 1 metre off ground in stabilise, with drone uncontrollable. With the full throttle range between 0 and 50% its impossible. Switch to loiter and the quad just lands, t]it won’t loiter. This all worked fine 2 months ago and honestly don’t know whats gone wrong. I used to be able to take off easily in stabilise then switch to loiter and worked a dream. I don’t think I can get any better flight log as this is as long as I can stay in the air which is all of about 5 seconds. It may be time to find a new hobby…

There’s a few issues.
Firstly you take off before there’s a 3D Fix and that messes up altitude.
Set these to wait for a proper 3D fix before being able to arm:
People get impatient and want to launch immediately, but best to wait.

Set up proper battery monitoring, the voltage and current readings tell so much - then you’ll also need to configure these:
Some of this gets configured if you enable and calibrate (or at least check) the battery voltage and current monitoring, then connect the quad to MissionPlanner and press ALT A , plug in your cells and prop size and accept all suggested values except INS_GYRO_FILTER - leave this one at 20.

Motors 1 and 2 (CCW) are working much harder than 3 and 4 (CW) indicating motor mount twist or frame twist. Motors 3 and 4 are physically causing yaw and motors 1 and 2 are trying to fight it.

Fix all those things then try another test flight and share the .bin log

Thanks for the pointers, will work on the above and post the flight log when I get to it. I also need to start a new thread related to the throttle issue as when this occurred at the beginning it was a yaw issue but as time has progressed it’s become an issue where my throttle is only operating on a small range. The first post in the thread doesn’t relate to this but a few posts in it does.

The above points are absolutely valid though as battery monitoring is on my list of things to do so will work on that and repost here. Thank you again for the help.

You can also set these too:
but dont rush into thinking they’ll fix everything, follow the rest of the issues through and you’ll get a better flying aircraft in the end.

Here’s the tuning guide that everything we discuss is based upon:
That MissionPlanner plugin (Alt A) will do a bunch of it for you and then we have to see how it flies to know what to do next.

Also, I’d probably do the RC calibration again, check that when you pull back the Pitch stick that the green bar rises, push forward the pitch stick makes the green bar go down. The other axis are more “logical”, the green bars will move the same way as the sticks.
After that redo the all-at-once ESC calibration:
…then everything I said before!

Will do all the above and see. I’ve gone from a fully functioning drone to something that I can’t control and originally all on default settings. Will do above and get back with flight log. Thanks again.