Pixhawk 2.4.8 (clone) and problems with copter firmware above 3.2.1

(yes I know there is no such a thing like pixhawk 2.4.8)
I have two pixhawk clones both marked as 2.4.8 versions, everything working perfect as long as the firmware for the copter is 3.2.1 or lower - if I flash it with 3.3.3 or 3.4.3 or 3.4.4 rc1 there is a serious problems - first of all throttle stick increasing the speed of motor only up to half way of the stick, the upper half has no impact for speed of the motor (dead zone) when I try to move the right stick (mode2) it controlling the speed of the motors but sooner or later I will get CRASH and disarming (all this at ground testing without any propellers of course)
I have 6x afro 30a simonk with 6x quannum motors 475kv all of it working perfectly with v3.2.1 on both pixhawk units I have, I believe it could be some firmware bug but I don’t know where to go with it so starting here, it could also be some hardware problem as my two pixhawks are identical units.All this is completely new subject for me so really appreciate any help. thanks

Ps. another thing worth to mention is during esc calibration throttle stick working all way bottom to top and changing the motor speed as it should with no problem at all.

1 Like

From the sound of your issues what you have are APM2.4.8 units running 8 bit processors, and not Pixhawks, which have a 32 bit processor.

For all APM’s the last version of FW is 3.2.1

Anything above that is going to give problems.
What are you using to load the FW?
Mission Planner usually sees the board version and provides the correct FW.

1 Like

I am using mission planner, my device looks like pixhawk and mission planner also think this is pixhawk :slight_smile:

how to check the board version in the m.planner ?

I am trying now with 3.4.4 rc1 again after few different versions, this is the screenshot from mp

1 Like

It definitely looks like a PH and the messages indicate it is a PH so my assumption is wrong.

I have seen a similar throttle problem in another thread, but I can’t find it at present.
If you turn on “pre-arm logging” in parameters you can get a log file to post which might help in finding out whats going on.

Sorry I can’t be more definitive.

Wasn’t there an issue some time back about memory space on some clone Pixhawks? Perhaps that is an issue in this case. This is just a WAG. I haven’t heard of this since but I thought I would throw it out there.


this is the latest log file from my sdcard but I have no idea how to read it
7.BIN (247.6 KB)

and this is the picture of the board inside

After few more tests I see that in firmware v3.3.3 throttle working all way no problem but still getting crashes if trying right stick in some positions so not able to use it at all

I have also noticed that every firmware above 3.2.1 giving me a motor/esc beeping before arming in sync like every second or so on all motors but with the time 20-30 seconds is not in sync any more, when armed beeps gone!
with firmware 3.2.1 there is no strange motors beeping!

I have a couple of those Pixhawk 2.4.8’s and they work no problem with all versions of firmware including the latest 3.4.4.

I do recall a memory issue with some boards as @rustutzman mentioned.
But @dkemxr says he has these and they work.
So you either have
a) 2 boards that are incompatible/faulty
b) an issue with loading firmware.

Option b) can be checked out by doing a couple of things
1 - make sure you have a good USB cable as some are a bit light on wire diameter and cause voltage drops amongst other issues. So use the best quality USB cable you have and connect it directly to your computer and not through a hub.
2 - do a clean install after an erase. Install plane or rover and then re-install copter which will erase your board and give the leanest install.

For my own information can elaborate on the “CRASH” you say you experienced.

1 Like

The 2.4.8’s that I have use the Rev 3 processor with 2MB of flash like the last 2.4.6’s shipped from 3DR. But there are definitely different version of these 2.4.8 clones because some have gotten them with a 5607 baro device instead of the proper 5611. So maybe there are other inferior components. I have to say for what these units cost (~$60) they are a real bargain. I have 2 of them and one Pixhawk 2.4.6 and I don’t see a difference.

I have tried already fresh install with different, cable, different usb ports 2.0 and 3.0 also different computer all the same !

“crash” I am getting when in the middle of tests mission planner say “CRASH: DISARMING” and disarming all the motors, it happens only with firmware above 3.2.1 especially when I start to do some strange movements with the right stick.

also checked! when I do radio calibration the end points in all the firmware versions are exactly the same so the top throttle going up to 2006

need some advice - do you think it could be some strange incompatibility issue with my esc or motors ? even 3.2.1 was ok ? have nothing else to test right now :frowning:

The only thing I can think of suggesting now is to check with your supplier on what hardware is on the boards to see what might be causing this incompatibility.

Not much help I know.

Or maybe go over the board and compare it with the standard Pixhawk circuit diagrams and see if you spot any difference.

just little update
I have measured the voltage pwm output from pixhawk with standard multimeter
during esc calibration the top level is over 330.0 mV but under normal arming the max is 250.0 mV what is reached at the half way of the throttle stick and won’t move any bit more even if you go with the throttle full up, so I think I can exclude esc/motor incompatibility issues and concentrate on pixhawk

Is the esc calibration method changed a bit from 3.3.3 up ?
I have feeling like the upper range of my throttle is not registered correctly as there is only one beep at the top, there is few beeps at the low position so it looks normal, but the top beeping much more with 3.2.1
actually should I calibrate the esc from firmware to firmware or just once ?


I am not alone, I have found this today at yt

no, this is not my videos

Hi Obecny, I’m glad to see that it’s not just happening to me! I’m no closer to finding a solution either, unfortunately. I’ve posted on DIYDrones (http://diydrones.com/forum/topics/apm-3-4-3-full-throttle-at-50-stick-continuous-beeping-from) but I’ve had no replies and a post on the APM 2.x & Pixhawk group on Facebook (https://www.facebook.com/groups/ArduFlyer/permalink/1811855569065313/) has lots of replies but so far no solution.

I’ve not yet tried any FW below 3.3.3. One thread I found (can’t find the link) had a problem with auto calibration that was fixed by changing the PDB. I can’t see how that would work, but that’s my next step. The Pix is buried within the frame so I can’t easily see if it says 2.4.8 on it, but when I swap over the PDB I’ll see what it says.


I have just tested single esc/motor connected directly to battery and at the same time pixhawk powered through usb port only so no pdb used at all, sadly no difference :frowning:

I’m sceptical it will work too, but I’m running out of options. There seems to be no good reason why it doesn’t work and I can’t believe we’re the only people to have this problem, yet there seems to be no solution.

I have two identical pixhawk units (2.4.8) same ebay seller, today I thinking to order another one from different seller but really afraid to finish with third unusable module! do you have any other pixhawk around you to check if you can flash it with 3.4.3 or 3.4.4 and check it with rest of your stuff ? I have it in the air with 3.2.1 no problems but wish to upgrade to make it work with flightdeck and few other things.

1 Like

Only an APM 2.6 which is only supported up to 3.2.1, so not much use.

Any progress there ?

I couldn’t resist to order another pixhawk, different seller on ebay, v2.4.6 (theoretically as no version number on case, going to open it later)
just arrived!

  • esc/motor beeping every second still with me until safety switch on so nothing new here

  • throttle - even stranger than the last time, at the start throttle stick working all the way up/down no problems but when I let it go around the middle for a short while (lets say 10 sec) I can hear the motors slowly increasing speed to the max so when they are at max and I move the stick any higher there is no impact on the motors at all but when I lower the stick down to about minimum motors speed decreasing and I am getting the full scale of control again even with the upper half of the stick
    ( I am starting to think it could be some kind of new feature detecting pixhawk is still on the ground and not flying anywhere but can’t really understand how this is suppose to work)

  • esc calibration exactly same as with my other two so seems to be ok i believe
    full throttle up/ power on/ rgb led/ power off/ power on/ safety switch/ yellow led? beep/ throttle down/ few more beeps/ throttle up-down full scale of control of motor speed

  • If the motors are on and when I try to move the right stick to left down corner or right top corner motors switching off instantly and I am getting info from mission planner as (CRASH DISARMING) same as with my two v2.4.8 but it never happened to me with v3.2.1 firmware so I don’t really know if this is normal with new firmware when on the ground testing

The new one looks completely different - there is a battery on board ?
also two microswitches on both sides, I can’t find what they are for when I press any of them the small red led light come on at the same side as switch, firmware persisting on the board

After reading a few pages of manual in pdf I know what the buttons for :slight_smile:
battery is also obvious but why there is no battery on the 2.4.8 board