Servers by jDrones

Can't get FrSky Passthrough working (4.0.5)

Hi everyone,

I’m using a Pixhawk with 4.0.5 and a Frsky R-XSR, OpenTX 2.3.10. I’m trying now for several hours, no luck. I’m using an inverter between S.Port and TX/RX. Tried Telemtry 1 and 2 ports, both are working with standard Mavlink modem. Disabled RTS/CTS, protocol set to FrSky Passthrough, SERIALx_OPTIONS is 4 (Half-Duplex).

What is working:
I can see the telemtry from the receiver
IMG_20201122_182404

The inverter is also working, first channel is receiver output, second channel RX input on PixHawk, the receiver sends data to the PixHawk:
IMG_20201122_182310

However the Pixhawk TX does nothing, it is high (second channel):
IMG_20201122_182331

Any idea how to debug this? Why is the Pixhawk not sending any data?

Regards,
Sebastian

Hi
I was fixed this problem on my QX7 with this configuration

SERIALx_OPTIONS = 0 (if using convertor like rs232)
SERIALx_Protocol = 10
Wiring like this post

If telemetry is not working till this step try to add 2 1n4007 diode before Vcc from fc to converter

1 Like

Thank you very much, SERIALx_OPTIONS set to 0 did it :slight_smile:

Never tried without 4 (half-Duplex) because it sounded logical and in https://ardupilot.org/copter/docs/common-frsky-telemetry.html#common-frsky-telemetry
It says:
" In general, F4 based autopilots using an external bi-directional inverter can use any UART with the following configuration:

  • SERIALx_PROTOCOL =10
  • SERIALx_OPTIONS =160 (enable pull-up/pull-downs on TX and RX pins for those external inverter circuits that may require it)
    "

It good to hear that you got it working

Yes a little bit confusing but its for other flight controllers like omnibus f4 not pixhawk

Your right, I think that came from me trying it first with a Mamba F405 and then moving on to the Pixhawk. If I’ve finished the second inverter I try it on the F405 again.

Hi, I also have a similar configuration and the same problem, even putting 0 on serial option unfortunately I have not solved. Omnibus nano F4 v6.0 and radiomaster
Here are the tests I did, can I try anything else? Thanks

The MAX323 boards have two circuits, one on each side of the board. Make sure all your wires are using the same side.

did you tried this ?

Not yet. This is my inverter:

Why 2 diode 1n4007? Thanks.

Some rs232 converters are not working with 5.2v
2 1n4007 will drop voltage to 3.2 to 4 volt and its will work

Hi, thanks :slight_smile: but if i have a 3.3V pad on FC (omnibus nano), can i try with this? Without diodes? My quad is micro only 3"

If you have 3.3v ignore this step

Now my inverter it’s connect to 5Vcc on FC pad. Can i try to connect to 3.3 pad?

Yes try it
It might work

1 Like

Hi, don’t worked at 3.3V. I tryed protocol 4,10,23. Serial option 0,160. Baud rate 115,57. No new sensors on radiomaster.

:frowning:

i dint used radiomaster, is it OpenTx ?

Yes, open TX.

I connect only pad TX1 on TX pad inverter, could that be a problem?

If your FC is based on a F4, you need both TX and RX connected.
Also, you need a diode between the inverted Tx-out and RX-out, where your S-Port wire goes to the receiver.

1 Like

Have a look here, maybe it help you.

1 Like
Servers by jDrones