Cannot calibrate radio (no green bars)

Hi Guys:
ArduPilot Newbie here.

I’m rebuilding my Diatone Tyrant Quadcopter with a Spektrum SPM4650 Serial SRXL2 Telemetry Receiver, and Matek H743-Slim FC. Both are brand new, and properly wired together (good continuity on 4V5, G, Tx6). They are not yet installed in the quad. My PC’s USB connection is providing power for both. I’m running ArduCopter v4.0.6 ‘Matek H743’ firmware, and Mission Planner v1.3.74.1. I have been unable to begin Mandatory Hardware Radio Calibration because the green bars do not show up on the screen.

I can easily bind my Spektrum DX6 transmitter to the SPM4650 receiver, so no problem there. Either the SPM4650 is not talking to the H743-slim, or Mission Planner is having trouble communicating with the Rx & FC.

It’s my understanding that the Matek H743-slim should auto-sense a serial SRXL2 receiver on any UART. The Matek diagram shows the receivers adjacent to Rx6/Tx6 so I used Tx6 (Tx required for two-way/telemetry communication). I also tried Tx7 in case Tx6 wasn’t working. No luck on either, so I don’t believe this is my problem.

It’s also my understanding that Mission Planner should auto-sense a receiver on any UART, but it doesn’t look to me like that’s happening. Is there something else I should be doing in Mission Planner, like defining the Rx6 UART as being a receiver? I really don’t know where to turn at this point, so any suggestions would be greatly appreciated! I couldn’t find anything relevant in the forum posts (most are old and PixHawk issues).

Thanks and Best Regards,

Doco says “RC input is configured on the R6 (UART6_RX) pin. It supports all RC protocols” but I cant test it myself :frowning:

I doesn’t do this. As @xfacta says standard RC input is on R6. If you want to use another UART it has to be configured for RC Input. I use Fport with this board which is a different case but the standard config as per the Wiki should work for you. But granted I have no Spectrum stuff…

Is SRLX2 supported yet? The website says “coming in a future release”

I believe so per Dr Piper. Looks like the answer is at the bottom…

1 Like

Hi Shawn, Dave and Allister. Thankyou all for the quick response!

Yup, I read that doc and a bunch of others regarding the proper connection between my Spektrum (SRXL2) receiver and Matek flight controller. I agree with you all that UART 6 is the correct connection (although I seem to recall somewhere that any UART would work). The reason I used TX6 instead of Rx6 was because the Spektrum SPM4650 is a telemetry receiver. From what I’ve read, and seen on YouTube, this receiver must be connected to a Tx UART which provides two-way communication. An Rx UART cannot send telemetry data back to the transmitter… but perhaps that isn’t true for the Matek H743-Slim.

Going on that assumption, I soldered the SPM4650 signal pin to the H-743 Rx6 pin, rebound the transmitter to the receiver a few times to be sure, then fired up Mission Planer. I had high hopes, but still no green bars. Piece-a-crap! Any other suggestions?

Thanks and Best Regards,

Also, I changed the BRD_ALT_CONFIG parm to ‘1’ per the ArduPilot H743 doc to activate the Rx6 pin. It didn’t help. :confounded:

I’m guessing you tried this:

Thanks, Allister. Actually, there are a few other parms I should try per the Spektrum SRXL2 wiki. I’ll try tomorrow…

SRXL2 receivers must be connected to a UART. SRXL2 receivers support a wide range of voltages, including the 5v available on a UART so connect GND to GND, VCC to VCC and the signal wire to the TX pin of the UART.

In the configuration of the serial port select the RCIN protocol and set the serial options to half-duplex operation. So for example for serial port 4:

Set :ref:RSSI_TYPE <RSSI_TYPE> = 3
Many single board flight controllers support RC input on serial port 6 only exposing the RX connection. For F7 flight controllers, such as the Kakute F7, it is necessary to swap the RX and TX pins in order to support SRXL2. It is also necessary to support serial access on the UART by using the board’s alternate configuration:

Set :ref:RSSI_TYPE <RSSI_TYPE> = 3

With the receiver connected and configured correctly proceed with RC calibration as normal.

Hi guys. So I reconfigured EXACTLY as suggested above…


I have the data wire on FC UART Tx6. I rebooted MP, my DX6 radio, and my H743/SPM4650 receiver combo. No luck. I also tried ‘BRD_ALT_CONFIG = 0’ (in case I didn’t need that), and I also tried ‘SERIAL6_PROTOCAL’ = 4’ (as suggested in the upper section above). Still no green bars. However, I noticed that when I go into ‘Setup>Radio Calibration’, I can ever-so-briefly see the green bars, but they quickly disappear. What next???

Hi guys. I decided to download the latest ArduPilot Copter-Matek743 firmware, 4.0.7. I used BetaFlight so I could be sure to erase all previous data on the FC (I thought it may help to start from scratch). As such, I also reconfigured the parms once again…


No Luck. I still do not have any green bars on the Radio calibration screen. At this point, I’m dead in the water unless someone has any suggestions. Thanks for all the help thus far.

Best Regards,

TX/RX6 is Serial 7. You don’t need to move any wires, just change the settings over to SERIAL7_xxx.

Just a hint. I use Multiplex RC with srxl to a pixhawk 2.4.8 Clone. To get it running, i connected the signal wire to the DSM port and i powered the rx via the ppm port to get 5v.



Thanks Maarten and Allister, I appreciate you taking the time to help me.

I’m not using a Pixhawk, Maarten, but I believe I’m using the suggested “DSM” port on my Matek H743 (Uart6, Rx6/Tx6), so I think I’m OK there.

As for the serial port, Allister, good call!!! I forgot that the ArduCopter doc said that Uart6 = Serial7, and I had hoped that you hit on the solution, but still no luck after changing the parms to SERIAL7 (still no green bars)! I also systematically tried a number of alternate combinations (8 connected to the Tx6 pin, 8 to the Rx6 pin) just in case, but no success…

SERIAL7_OPTIONS = 12 (half duplex, swap Rx and Tx), also tried 4 (half duplex)
RSSI_TYPE = 3 (Rc protocol), also tried 5 (telemetry radio)
BRD_ALT_CONFIG = 1 (alt board config), also tried 0 (default config)

I’ll continue to read everything I can to resolve this, but as I said, I’m an ArduPilot newbie, so thankful for any suggestions.

Best Regards,

Long shot: Make sure you’ve set SERIAL6_PROTOCOL = -1. And any other port you may have tried but aren’t using. Sometimes if there’s multiples things get confusing.

Hi Allister. Good thought, and thanks, but I did remember to change the SERIAL6 parms back to defaults before I started testing the SERIAL7 mods. I’ll continue reading and looking for a solution. If I find something, I’ll be sure to update this thread.

Best Regards,

Hi Guys.
This is still unresolved. I’ve tried everything I could think of, and tried all of the suggestions above, but still no luck. I cannot calibrate my radio in Mission Planner because I do not see the green bars on the screen. I’ll start a new thread with a different approach, requesting help with my SPECIFIC hardware. Perhaps someone has been down this road before. Thanks to all who have contributed. I appreciate the help!!!

Best Regards,

@blakvette, exact same issue with Matek F765. Have you solved it yet?
I have tried Serial7 as well, nothing

Hi @RizHass:
Nope, I’m grounded. I removed a perfectly good RaceFlight FC and non-telemetry Spektrum RX from my quad (which flew great!), and installed the Matek H743-Slim, Matek GPS/Compass, and telemetry Spektrum SPM4650 in the hope that I could take advantage of the various ArduCopter flight modes and especially ‘Simple’ and ‘Super Simple’. I’m 73 and nearly blind now, so I need a better way to fly or I’m done. I was hoping that one of the devs would read my posts and get my combination working, but nothing so far. I haven’t tried lately… WAY too many other priorities, but if I ever get this thing to work, I’ll be sure to post the EXACT solution. Also, I had hoped the upcoming INAV release would support the H743, but I don’t think it will, so no help there either.

I’m trying the same thing on a Matek f405-std. no luck so far. Is there something special about Rx6? I’ve been trying on rx2 which will run the Rx as a regulAr non telemetry Rx, but not as srxl.