Can not solve the Compass Interference issue

HI there everyone !

I’m trying to solve the compass interference issue on my F450 quadcopter (PIXHAWK Arducopter 4.1).

I’ve done:

  • Moving external compass to a height.
  • Shielding the wires with aluminium tape.
  • Disable internal compass & use external only.

Still there is large magnetic interfernce with the compass.

I believe the internal compass is still being used by the pixhawk despite being disbaled in the MP. Becuase :::"Whenever i try move the external compass, the YAW does’nt change. But it changes imeediately for PIxhawk movement. (when only external compass is selected):::"

compass interference

00000051.BIN (705.4 KB)

1st, you should be using the latest stable version of firmware and Pixhawk1 not fmuv3 for that Flight Controller. 2nd, the Auto Analysis tool is mostly useless incl that Test Compass=Fail message. 3rd, when you move the Flight Controller it will show a Yaw change from the Z-axis gyro whether you have a compass connected or not. So at this stage it’s not clear that you have any problem.

I would add that those motors and collet prop adapters are ill suited to a multirotor but I suppose you got them and some cheap old school ESC’s in a kit.

1 Like

Hi !
Thanks for the valuable response.

The issue is, the quadcopter struggles to maintain a heading during its flight.
As i raise the throttle, it turns slowly in a CCW direction and is hard to yaw from the RC.

OK, post a link to another log where is flying for a bit after updating the firmware. The way you have that GPS module mounted is fine.

The easiest way to get the right firmware flashed is to download the .apj file from here and use the “load custom firmware” feature in Mission Planner. Pixhawk1

1 Like

Dave thanks again !

I’m resisting to update the firmware because the pixhawk i bought was a chinese CLONE.

And this came with it (use only fmuv3 else you will brick the module) :sweat:

Just stuck with it…

This the link, i got packed with the pixhawk

I wouldn’t believe that, they don’t know what they are talking about but up to you. 2.4.8’s can’t be clones because there was never an original. Some of the images shown in that guide are old.

In any case update to latest Stable (4.1.5 today) whether you stay with fmuv3 or not.

Hmm !
Actually I’ve tried 4.1.5 Stable.
I’m just trying out older versions now to check if some works.

Only issue i face with each is: unstable yaw and heading. :pensive:

Don’t bother with that. Move forward with latest Stable and fix the issues as they arise.

I would remove the prop guards.

Actually the issue is nothing different since i used APM2.8 board on this setup. This toilet bowling and unstable heading issue was also there.
I’ve changed the FC, Battery, external compass, shielded cables etc.
But no changes.

Just can not catch where the problem’s coming from.

Fly around and post a link to the .bin flight log. That other on is too short to see anything.

Here is a troublsome flight test (hard to control the heading and the orientation):

A bit stable flight test log (don’t know how the issues went neglible in this test)

1 Like

These are at default parameters, nothing to see here.

I’ve noticed lots of EKF yaw reset, yaw realignment, yaw reset errors in the log file, at the time when quadcopter caused problems during flight.

What caused these ? Any idea ?

As @dkemxr recommended you should complete the tune. Some of what you may be seeing may be a result from the poor tune performance.

There also seems to be an issue with motor #4. This image is only a sample, but on log 25 it was repeatedly reaching maximum. Have a close look for a loose prop. Those prop mounts are intended for fixedwing installations, and have been problematic in the past for quads.

1 Like

Thanks allister…
will look in to this

Hi Allister, i think i found your answer very helpful.

The motor 4 is causng the trouble.
But i’ve tried a different orientation previously where current motor 4 was motor 2 & viceversa.

I just opened up my previous logs & found that: the previously set motor 4 was also having this similar behavior (touching maximum limits) in that configuration. (When motor 4 was not this one. But it was motor 2 on this setup).

  • The board i used on previous configuration was APM 2.8. Now in this configuration is Pixhawk So i guess no issue with the boards.

Can i please get in detail touch about this…
I’m trying fly it stable for ~ 5 months now. Still nothing…

I have’nt moved the motor or the ESC.
Only shifted the wires of ESCs for changing he front face orientation of the Quad.

As a very simple test, you can take Pixhawk and GPS out, attach the GPS to the Pixhawk with double sided tape with same orientation and connect it to it, supply them through USB, connect from MP on USB port, check that both compasses are detected, check orientation parameters (learn), and try compass calibration.

1 Like

Hi !

I changed the motors with DJI 920KVs.
But the issue with motor #4 still seems stuck there.

The Quad tilt towards the #4 Motor as it takes off & makes it hard to continue the flight.