Servers by jDrones

BLHeli32 Dshot not finding ECS with passthrough

Hi.
I have followed the documentation and vid about getting BLHeli32 setup talking to the ESCs by pixhawk passthrough. The BLHeli connects to the cube (I think) but then cant see any ESCs. Been over and over the settings. Even tried the bitmask option instead of auto. Cube with 3.6.8 and ESC is Tmotor F55A PRO 6S 4IN1 32bit. Trying to get Dshot150 working.
Message is - ‘Found no valid ESC configuration’

Any ideas please?

are you using the AUX outputs?, maybe you can post your params

Yep using AUX. Tried others also, just in case.
will post params

ESC problem.param (14.2 KB)

try setting SERVO_BLH_MASK to 3840 (i think this should be outputs 9, 10, 11 and 12, or you can just tick those in MP) and SERVO_BLH_OTYPE to 4

Tried the mask already with that number. Will try the other thing later. I see there was an issue earlier with blheli _s not connecting in much the same way

Nope. Still the same.

Are you supplying power to the ESCs?

Yes but didnt have any motors connected.

Thought perhaps I had a dead ESC (4 in 1) but now connected one motor and it plays the tunes and spins the motor so its ok.

Had some weird issue yesterday when new version on BLHeli32 suite did not recognize ESCs but previous version worked ok. Try downloading 32.6.1.0 and use it.

1 Like

Not a bad idea but cant find an older version to download. Have 32.6.1.2 now.

https://drive.google.com/open?id=1ovSP4_qnsYjXkuc11JOD2UyW7IPUeiO8
Try this

1 Like

Anton. That works. Thanks.
Must be a problem with 32.6.1.2

1 Like

I’ve seen this issue recently with a 4-IN-1 ESC. The flight controller is not a Pixhawk, but the behavior was identical. I tried the stand alone Windows and Android versions of BLHeli Suite and neither one would read from the ESCs.

As a last resort I tried the Google Chrome EXTENSION version and it worked.

Yea I had the same issue with the latest version of suite. The older versions work as they should.

From what I gather, the latest Suite is written for BLHeli_32 ESCs. BlHeli_S is basically a dead end. BlHeli_32 is no longer Open Source and apparently manufacturers must pay a license fee.

Thanks, this worked, 32.6.1.2 has problem.

I am having the same problem. I have tried dozens of configurations for connecting pass-through. I believe I have complied with all of the suggested parameter adjustments. Finally through Mission Planner I was able to connect to the ESC and update its firmware, but it seems to have only worked for ESC#1. I needed to turn off Low RPM protect to get the low KV motors to run. It worked, but only for the one motor. I cannot get the BLheli Suite32 32.6.1.3 to show all 4 ESCs of the 4in1. I have all of the ESCs on the AUX outputs and the servo functions transferred to them. This has tied up the effort for days. I first wired in a Typhoon32 4in1 ESC, then replaced it with the Bardwell 4in1 which seems to have the same problem, so I am sure it is some configuration issue. The Cube is running Arducopter 3.6.8.255 I have lost count of all of the videos, tutorials and documents I have consumed. Is this a lost cause? Why is there so much confusion and conflicting documentation?
HELP!
Phil
The aircraft:
Tarot Ironman 650 Quad X airframe with extended motor mounts (actual wheelbase = 775mm)
Pixhawk 2.1 Cube with Here2 GPS
Frsky 8XR RC and Frsky QX7 TX
915MHz Telemetry to either Mission Planner or Q Ground Control
Bardwell 4in1 BLheli32 ESC
MultiStar Elite3508 268KV motors
17" props
6s4p Li-ion Battery

Did you try the older version of BL Heli that Anton linked to above? That’s what fixed my issues 6.1.2 didn’t work. Didn’t know there was a new version 6.1.3. Anyway I know 6.1.0 works for me.

Servers by jDrones