Servers by jDrones

BLHeli32 Dshot not finding ECS with passthrough

the latest suite rev i could reliably connect with using ardupilot is 32.6.1.1 . there‘s a recent commit for higher revs support in master, i personally didn‘t get it working though:

Thanks to you all. I will try the older version tomorrow. Is this thread the best place to monitor for the new released solution? I will report my results here.
Phil

The older version worked for me too.

@Vince_Hogg

Could you please add label for ArduPlane aswell. It is also affected.
Thank you

There is some more info about this issue
Here: https://www.rcgroups.com/forums/showpost.php?p=42086409&postcount=3475

and here: https://www.rcgroups.com/forums/showpost.php?p=42087137&postcount=3480

as it seems compatibility issues have been resolved in recent blhelisuite32 revision 6.1.5, connect working reliably again.
thanks @pompecukor !

@vierfuffzig
Hello Doctor Basti. All I did was ask the gurus over there for help. I did not fix the issue personally. I wish I had the skill :slight_smile:
How are you doing man? Come visit us in Hungary. I would be so happy to see you. Fly and factory tour. What say you?

@pompecukor
hey alex, i‘m doing fine personally, job turbulences don’t leave much room for hobby stuff this year though, even had to cancel this year‘s trip to france :sob: hoping for more flexibility in 2020, would be great to see arace live! hope you‘re doing fine too and business is going well!

thanks to steffen and achim for fixing blhelisuite issues!

Is there much change form 1.0 to 1.5?
I mostly believe - if it aint broke don’t fix it.

Blheli _32 Suite 32.6.1.6a is the current version. It will not connect to my Pixhawk running arducopter 3.6.10, Been working on this for two weeks without any success.
Anyone have an older version of Blheli_32Suite? As a closed source the older versions are not available.
I have tried 32.6.4, but again, no connection. Accoding to the BLH log file the connection fails on the line “MSP_API_Version”

Hey Hquarter, try this

Dear All
Trying dozens times and cant do my BlHeli_s work with my PIXHAWK. The motors do not spins, and passtrough does not work too.
Please anybody to send a quad parameter file to help me?

Frame: QUAD
RCOut: PWM:1-12
fmuv2 00390040 31385112 38353731
ArduCopter V4.0.3 (ffd08628)
ChibiOS: d4fce84e
BhHelisuit32 vers :32.7.1.2
ESC RacerStar Dshot RS40A
Motors: Racerstar 4208

You shouldn’t have any problem getting them to spin but you can’t use BLHeliSuite 32 for BLHeli_S ESC’s. Need the 16bit version of the suite.

Better if you post your parameter file.

Dear , tkyou for the response.
I’m shure I have some config problem, due the motors does not work and cant do the passtrough. I tested with 16bit version, and it does not work too.
I goona post parameter file late afternoon .
Tks again

Frame: QUAD
RCOut: PWM:1-12
fmuv2 00390040 31385112 38353731
ArduCopter V4.0.3 (ffd08628)
ChibiOS: d4fce84e
BhHelisuit32 vers :32.7.1.2
ESC RacerStar Dshot RS40A
Motors: Racerstar 4208

You posted this question is 3 different threads? That practice will discourage help. And if you are using Copter V4.0.3 it doesn’t belong here.

Dear Dave, I’m sorry !
Any thing can I do?
I’m really desperate to find a solution.

I`m grounded for long time.

I`m sorry again

Passthrough with BLHeli_S ESC’d likely will not work. I have a couple craft with those ESC’s and I use an old Naze32 board running Betaflight for setup/configuration. BLHeli32 is no problem.

Servers by jDrones