Servers by jDrones

Benewake TFmini LIDAR works on Ardupilot


(David ) #41

Hi ppoirier, im David new member of this community, i just need of help just in case my tf mini is not working on i2c of pixhawk 1 how i can wire it on arduino mini pro and how i must configure it on arduino and after this on mission planner.
Hope in a your positive help


(ppoirier) #42

Have you read my blog above?


(David ) #43

hi… ppoirier, yes but i cannot understand very well coz i dont have enough experience on this… im beginner


(ppoirier) #44

There are excellent tutorials on the web for Arduino, gain some experience and get back to this project whe you feel ready :slight_smile:


(David ) #45

i know… only i need of a drone for my work, that’s whwi need to set a lidar


(ppoirier) #46

You can use the serial interface then ?


(David ) #47

me for now I’ve connected the lidar on the i2c of the pixhawk… after I have done the connection the parameter of the sensor is 4.21 variable and the voltage is 1.32 variable… this is what mission planner show me


(Siya Liu) #48

Hi, David. I have invited engineer to pay attention to this topic. Would you pls check some tutorials for Arduino and also ppoirier’s blog first and tell your specific questions, or send email to Benewake support :blush:


(David ) #49

hi Siya, ive already sent an email to benewake but didn’t help, ive also placed an order of the arduino mini pro so i can wire the sonar, but i need help or the steps for configure the board like ppoirier’s blog and maybe ive solved the problem


(Mincy Zhao) #50

Hi,David.


This is a simple diagram.
If you have any question you could send email to me.


(David ) #51

hi mincy, thanks… for what kind of lidar is this scheme, after i have soldered all the wiring how i can set up the arduino boar and the parameters.
My email is dchaim84@gmail. com… yours?


(David ) #52

Good pm, after few time of trials maybe my lidar is working but i don’t know if the parameters are corrects


(Justin R Bates) #53

I have tested the tfmini on the TF software, changed the Device command to 47 57 02 00 00 00 04 06 and confirmed the serial output was getting readings through Tera Term. However, after changing my mission planner parameters to be configured with the serial 4/5 port I still see no reading through mission planner. Do i need an update on the lidar firmware? Any other suggestions? Also I tried modifying the ‘LightWare’ serial driver but that was locally through my computer. Would I have to flash settings onto the pixhawk with an SD card to change the Lightware serial driver?
Thank you


(Siya Liu) #54

Hi, Justin. As you hope to use TFmini with your Pixhawk, I’d like to suggest below:

After you connected TFmini with PC and entered the display software, please select “Pixmode”, then the TFmini will be changed to pixmode. Then connect TFmini with TELEM 2port, please make sure you connect the cables correctly and configure rightly as the TFmini operation manual I sent by email and configure the data. (Pls refer to Attachment 3: Application of TFmini in Pixhawk)


(chris rey) #55

Hi @ppoirier, just get my Tfmini that I want to use first with Serial (telem2). Working great on the PC interface via my FTDI232, seems very accurate. Just to be sure of my config before installing it to my Pixhawk:

  1. Activate Pix mode in PC interface (no need to save?)
  2. Apply the parameters described in the Benewake doc:
    SERIAL2_PROTOCOL = 9 (Lidar)
    SERIAL2_BAUD = 115
    RNGFND_TYPE = 8 (LightWareSerial)
    RNGFND_SCALING = 1
    RNGFND_MIN_CM = 5
    RNGFND_MAX_CM = 600
    RNGFND_GNDCLEAR = 5

I put 600 for RNGFND_MAX_CM in order to not have bad surprises…
Seems working like this, but if you have any other recommendation, you’re welcome!


(ppoirier) #56

@chris661 Yes that looks good for serial. I would change minimum to 30 cm because of the TFMINI issue on short distance error.
Please note that the TFMINI goes to “0” when out of range you can have it ‘‘push’’ 12 Meter instead ==Send command 42 57 02 00 00 00 00 20,
TFmini will output 12m range data for distance greater than max range (6 Meter outdoor)


(chris rey) #57

For me setting this RNGFND_MAX_CM = 600 means that if lidar distance measured is 601 the baro is on and lidar off, Am I wrong?
So If it distance from lidar is 0 it’s still under MIN_CM so, I’m confused…


(ppoirier) #58

Yes thats a range so ts not using sensor below 5 CM and above 600 CM


(chris rey) #59

this point I do not understand, why is it useful to push it 12 meters instead of 0? because both values are out of the defined range


(ppoirier) #60

With altitude it does not seem to have a negative impact but when you change orientation as for avoidance it makes the vekicle stop . Look here TF-Mini-Obstacle Avoidance Issue 3.5.5