Servers by jDrones

Benewake TFmini LIDAR works on Ardupilot


(Siya Liu) #1

Hi, friend.

I forwarded Mr. Patrick Poirier’s test and report for Benewake Inexpensive LiDAR for drones/UAV/UAS, which works with Ardupilot. Pls check below details.

" Hello,
Benewake, TFMINI LIDAR works Ardupilot, you need to:
A) Change mode to text output : The command of pix format output is 42 57 02 00 00 00 04 06
B) Modify this line on the LightWare serial driver https://github.com/ArduPilot/ardupilot/blob/master/libraries/AP_Ran
You have to replace ‘\r’ with ‘\n’

You could check more details of the TFmini micro LiDAR module on OzRobotics

: )


Benewake TF mini Setup
Pixhawk 2.1 with maxbotic I2CXL-maxsonar-EZ issues
(ppoirier) #2

Hello
Thanks for posting this simple experiment .
Unfortunately the TFMINI is missing resolution within this mode, because its pushing decimetric values instead of cm or mm.
There was an experimental driver written for ardupilot but the short distance error pattern - reporting erroneous values up to 60 cm when reading under 30 cm- makes it unfit for landing.


(Siya Liu) #3

Hi,Patrick. I hope you think it’s ok that I list your test here. Thank you for your attention and reply.

TFmini outputs the ASCLL code value in pix mode in meter units not in decimeters. And this is caused by different TFmini version you got.

TFmini is divided into cm value output and mm value output, the two output modes can be converted to each other, but the resolution is cm level. When pix mode, the unit is m, and resolution is cm. So it’s better to input the command in cm level unit.
For short distance error issue, new version TFmini has better performance.


(ppoirier) #4

@Siya
Can you detail the command lines to change resolution ? Its not published anywhere and I dont want to experiment sending random command making the unit interlock

How can we upgrade firmware, I have 2 units making the same error pattern and they come from RobotShop

Best regards


(Siya Liu) #5

Hi,Patrick. I could send you the command lines by email or you are welcome to add Skype lymulanqf for support. The command lines can not be published yet. You’ll get support and well use the TFmini.


(ppoirier) #6

Thanks to Siya Liu and Benewake engineering team, my TFMINI goes centimetric with the new firmware release :slight_smile:

You can use LightWare serial driver

https://discuss.ardupilot.org/uploads/default/original/2X/1/1a0a58469a33dc12dca8d06a0e35772b8f62b5a7.png


(Sergey) #7

Why values doesn’t change on your screen? Is this an centimetric resolution or centimetric precise?


(ppoirier) #8

Well… thats a screen capture at 115 kbaud of the sensor on the table looking at ceiling.
The unit is millimetric and the ‘‘pix’’ format showned above is centimetric


(Sergey) #9

Great, so the TFMini is actually able to sence centimetric changes for you?


(ppoirier) #10

Yes , quite accurately and fast

There is still the short range error that need to be adressed, once that is done I will write a blog and reference the TFMINI in the RangeFinder WIKI http://ardupilot.org/copter/docs/common-rangefinder-landingpage.html


(rickyg32) #11

Anyone got the manual for setting this up on Pixhawk


(ppoirier) #12

@rickyg32 you can download spec and info from benewake
http://benewake.com/en/down.html

If you need any help, just ask :slight_smile:


(rickyg32) #13

I got the manual and the app. set the mission planner config up but no go. going to go over everything in the morning. curious if it should be running newer firmware and if so how to upgrade it


(ppoirier) #14

I guess you have a USB-Serial converter ?

When yo read sensor with a terminal @115200 baud, do you see numbers x.xx corresponding to distance in meters ?


(rickyg32) #15

yes I have one and will try it in the morning. going to rule out the possible problems. just wish I knew how to check the firmware


(冯作磊) #16

When and where did you buy the TFmini?May I known the number of TFmini?If your TFmini is the LAST version,you don’t need to upgrade it.Just please marked the check in the “pix mode” box with the APP,if it doesn’t work,please tell me.


(rickyg32) #17

Ok so still no luck.

I connected the app and it appears the unit is working.

However if I select Pixmode the display stops. Not sure if thats right
or not.

I just bought the unit a week ago and the numbers are as follows

N030049

7020687

I have changed the wiring harness, changed the port its on and still no
luck.


(rickyg32) #18

I still get Bad Lidar Health and sonar range and Sonar voltage are both 0


(ppoirier) #19

Open a terminal (TeraTerm or any) and connect @ 115200
Do you read distance?


(rickyg32) #20

Ok I again connected it to the app.

Seems to work fine. I notice that when ever I start the app the pix mode
is not checked and when I connect to the com port it remains unchecked.
If I put it into Pixmode the graph stops working.

If Pixmode is a setting that it should retain I have no clue how to get
it to save, there is no write function and the send command has no
effect that I can see.

I am not sure what else to check