Assault Reaper 500 with Pixracer autopilot Roll wobble

Hello guys, I am quite new to px4 flight controllers with arducopter firmware, so don`t be rough on me :upside_down_face:

I am trying to use pixracer controller on assault reaper 500 heliquad. Firmware is beta 3.6.0-rc7, I used .param file from wltoys v383 heliquad, did all calibrations, tested it in stabilized flight mode and it`s flying ok, but in loiter mode I have significant wobbling on roll axis, copter is not stable and I am afraid to use auto-tuning mode. Is there any way to make it more stable in loiter ? Also I encountered strange thing - I am using rsc mode 2 for motor interlock, but if I disarm controller before switching motor interlock off after flying I cant stop my motor at all, it keeps spinning, even safety switch cannot make it stop only battery disconnecting helps, is there any solution for that too ? If I switch motor interlock to off prior to disarming - motor stops as it should.

Alex, what you might be seeing is a collective oscillation so try setting this to 0.3 instead of 0.5

@bnsgeyer I can’t verify that the engine fails to shut down on disarm in heli. I have all my radios set up with switch arming with an interlock in the radio that prevents me from disarming if the throttle hold is released. Could this be related to the servo changes? Are you able to verify it?

I disabled my RC arming<->throttle hold interlock and tested this. The engine in my helicopter shut down properly on disarm. So I don’t think there’s a problem I can verify in the servo library or heli RSC code.

Thank you for your reply, Chris.
I will try lowering PSC_ACCZ_P before my next flight and will post results. Right now I am trying to balance my copter more precisely and flat-level props a bit.

On motor problem - my current preflight arming is like this:

  1. Turn RC transmitter on. Plug in copter battery.
  2. Press external safety switch on copter. (switch light become solid and servos are starting to react to my rc controls)
  3. Arming copter with throttle stick down and right. (arming beep)
  4. Flip motor interlock switch on my RC and motor starts full speed. Ready to fly.

After landing:

  1. Flip motor interlock switch. (motor stops)
  2. Disarm copter by throttle stick down and right.
  3. Press external safety switch on copter. Unplug battery.
    But if I forget to flip motor interlock switch (motor spinning) and disarmed copter by throttle stick down and right (i.e. after landing in loiter mode when there is no direct input on swash servos) - motor keeps spinning and there is no way to turn it off, except for unplugging battery.

I have not set throttle hold in my radio because I thought that RSC_MODE 2 prevents any input for ESC motor speed control channel from RC transmitter, and motor is always running on constant speed after flipping motor interlock switch.

@Alex_Pilot Did you mean " throttle stick down and right" to disarm?
It should be " throttle stick down and left"

Well, yes. It’s “throttle interlock” in Copter for some reason. It has been throttle hold in RC helicopters since cave man days. So I call it throttle hold.

Are you sure you are disarming correctly? I think for stick arming down and the left disarms. Down and to the right arms it.

Yes, it`s right to arm and left to disarm, I confused it :blush:

I assume you have the speed controller hooked to SERVO6 on the speed controller? And your switch on the RC is on channel 8?

Yes it is. Motor ESC on CH6 and interlock is on RC8.

Would you be able to post a log from that flight where the quad went into this oscillation in Loiter? And another one showing the throttle issue (maybe the same log?)

I have already posted it in logs thread with my .param file.
I guess I have to double check disarming procedure, maybe I was really disarming it wrong way.

Sorry, I forgot that was in that other thread. Your throttle SERVO output is set to 5, not 6. And the MIN/MAX for the throttle channel should be set to 1000/2000 to make your ESC happy.

In the log it looks like SERVO5 out went to 1100, but that must not be low enough to shut down your ESC. Get that to 1000 and see if it works.

You definitely have a collective hop from the ACCZ_P being too high. I don’t know if that’s causing your bad roll oscillation or not. Try setting that to 0.3 first and see if it fixes it.

Thank you, Chris. For your time and your help. I highly appreciate it.
I will try these settings tomorrow and I will report the results.

I checked disarming procedure and both down+right and down+left stick commands are disarming copter. But if the motor interlock is on and engine is spinning only down+left works, strange …
With servo min/max set to 1000/2000 motor stops after disarming, thank you Chris.

You can assign a switch and channel for arming/disarming if you want. That’s what I use for helicopters. The stick arming thing don’t work for heli’s very good because just because you shut the engine down doesn’t mean a helicopter is done flying. Trying to disarm one on the ground, rotors turning, with the stick deal will flop it right over and spin it in a piro in the dirt. Even with the engine shut down.

Yes, that`s a great idea, I will assign free switch for arming/disarming. I was unable to fly today because of strong wind in my area, maybe tomorrow will be a day.

I tried PSC_ACCZ_P 0,3 parameter in loiter flight mode, it made huge impact on throttle response, like delaying throttle input on several seconds, it is very hard to keep stable altitude in loiter mode with it. Sadly, there was no effect at all on wobbling problem, wobbling continues. I will post flight log in my flight logs thread. I`m still thinking that I need to level my props more precisely, but I have no small digital level right now that will fit on ar500 small props.

Ok, if that didn’t have an effect then set it back to 0.5. This appears to be a position controller problem as well. I found this problem with a turbine helicopter a few days ago. I’m still working on it, trying to figure out why it’s a problem for some helicopters, but not for others.

Hi. I’m just wondering if you solved the problem? I’ve been using a pixhawk 2 (cube) to control the assault reaper 500 and it works quite well. To solve the wobbling problems I simply tuned the PIDs for Pitch/Roll. If the oscillations are slow, the PIDs are too low, if the oscillation are very fast it’s usually too large P or possibly D. I’ve been flying it in loiter, althold, auto etc.

Hello. I have not tested it yet after propellers leveling, I will try it once more someday, but I think that pixracer is not best choice for that type of drone, maybe I will replace it with pixhawk later.