Arduplane 3.6 Quadplane - PIxhawk PX4 experiencing erratic motor using BLHeli/SimonK ESC (with solution)

Hi there fellow Quadplane pilots!
This is my first post in the new forum, and I’ll en-devour to respond daily.

I’ve been flying quadplanes/derivatives since the beginning of 2015 mostly with success. But over the last few months I’ve been running into issues trying to use ESC’s running the latest BLHeli and SimonK firmwares, on DYS, ZTW and Littlebee ESC hardware in particular.


  1. Motors run erratically, sometimes follows throttle or individual random motors cut out completely for a short period. (unflyable in hover)
  2. Motors and ESC’s get warm even when running without props (Same with brake/regen on or off)
  3. Resulting in pre-mature motor and ESC failure from overheating (mostly motor - won’t start - stutters)


  1. CHK Wiring/Dimensions/Plugs/Battery - all ok
  2. CHK ESC/Motor with PWM Servo tester - Runs ok :sweat:
  3. CHK PXH PWM output with non-SimonK/BLHeli ESC on same motor and assembly > runs ok :cry:
  4. CHK with various prop combos as well as without, along with different mounting positions etc - (I suspected that maybe eddies were somehow interfering as quad is mounted on aluminium spars!) - No change
  5. Changed all potentially affected ESC settings and combinations with no effect - issue remained
  6. Pulled out hair trying to diagnose intermittent erratic faults… now bald! :sob:

Result of testing > likely issue:
For some reason the PXH to ESC PWM connection is dropping frames if the RC_SPEED is not a multiple of the ESC max Hz, which in turn causes them to cycle between max/min rapidly and makes them heat up within 30-60sec, as well as run erratic at low speeds and loosing sync.

Solution that is working so far:
Make PXH RC_SPEED 500 or 250 for 500Hz ESC’s and 300 for 600Hz ESC’s running BLHeli/SimonK. :grin:

To be safe to get it flying:

  1. Make sure ESC PWM mode is enabled to turn off Oneshot as this is not supported (This is disabled by default!)
  2. Set timing to medium and test before increasing
  3. Turn motor brake off and test motor/ESC temperature prior to flying when on. (This loads up the ESC/motor considerably, but typically doesn’t burn out the motor/ESC. Be careful that ESC has enough current headroom over motor max. draw)

Funnily enough, in 3.5.2 we never had any issues because Tridge set the default RC_SPEED to 300 and that worked fine with our first quadplanes running 600Hz DYS 40A ESC. But since 3.6 the PXH is running at 490Hz… Yikes some coincidence!

Anyways I hope this saves someone 6 weeks of stuffing around trying to figure out why some ESC’s don’t work properly with Pixhawk!



Thanks for your post.
Can you post the problem log? I think we have the same problem as you said here “QuadPlane cut the throttle automaticly in Qloiter mode and crash(3.6)”.
My esc is Hobbywing.As shown below.Especially for copter.Does this type of esc will cause the same peoblem?

I have two quadplane .one is the problem quadplane which is bigger,the other one is working normal which is smaller.Today I tried to chang Q_RC_SPEED of the smaller quadplane to 700 /600 and 150 ,nothing erratically happen. I can’t feel there is any obvious difference.

So it seems that the Q_RC_SPEED doesn’t have any influence.

And another problem , I found the loiter_to_alt and guide mode doesn’t work if I set Q_guided_mode to 1.

Hi Farstein
I thought that Q_RC_SPEED is limited to 500? I experienced problems with it set at 490 (which is default atm) using 500Hz BLHeli ESC’s. I’m not certain what the issue is with the PXH or what settings exactly might cause the behavior for every type of ESC, other than that after changing it I no longer have that problem with the Little Bee/DYS BLHeli ESCs.

I haven’t tried the q_guided mode either yet so I’m not sure how it’s meant to behave. I have another few “improvements” for QP, in particular for takeoff and landings in wind.

And also I found In the final stage of landing,QP seems in Q_HOVER mode,which can’t hold the positionand and always drift meters away. So I set the Q_LAND_ALT be -10,which cancel the final landing stage.
It’s not a good method. Have you had these problem?AND what’s your solution?

I thought it’s ok if the HZ of ESC is greater than the HZ of Q_RC_SPEED. There is no need that the RC_SPEED is a multiple of the ESC max Hz.Do you think so?

Q_HOVER does not position hold. Try Q_LOITER instead. From what I can tell, and as I tried to explained in the first post, for example: the RC_SPEED did not work properly if the default RC_SPEED of 490 is used with 500Hz BLHeli ESC’s. Only an RC_SPEED of 250 or 500 would work with 500Hz ESCs and 300 with 600Hz ESCs. I haven’t got any xrotor ESCs like yours to test, but It could have the same issues.

I mean that in the final stage of landing of the auto mission,using “Return to launch”, QP seems in Q-hover mode,which can’t hold the position and fly meters away from the home-position and land.That’s strange.
In my test,RC_SPEED seems having no impact with the ESC working,as I have tried the RC_SPEED to be 150/600/700,the ESC all seems working well.

That’s good to hear that you don’t have any issues with the ESC. (Which is also the subject of this thread btw)

If you are doing an auto mission the autopilot should not switch to q-hover mode at all. In my experience it should also position hold at the landing WP, after it’s transition from forward flight. If the WP before your landing WP is too close together, then the aircraft can’t transition to hover and will overshoot the landing WP. Try setting the second last WP and the Landing WP further apart. If it still does not land on the landing WP, then maybe outside influences, like wind is blowing it off course and causing it to land somewhere else. See here for more:

To overcome wind effects carefully try weathervaning and forward assist in a slight wind first.