QuadPlane ESC PWM handling problem

Hi everyone,

I have a huge problem with my hovering ESCs on a Quadplane. I am using FVT LittleBee 30A ESCs with Quanum MT4108 700kv Motors on 4S. After arming and activating the ESCs by switching to QSTABILIZE they spin up to idle throttle as they should. If I raise the throttle a bit some of the ESCs shut down depending on the aircraft’s attitude.

The problem is, that when applying some throttle, some of the PWM values go to Q_THR_MIN_PWM and do not stay above Q_THR_MIN_PWM+Q_THR_MIN. While idling all motors spin constanty at Q_THR_MIN_PWM+Q_THR_MIN.

Does anyone have a solution to this? I have tried to set ARMING_REQUIRE to 2 and Q_THR_MIN_PWM a bit higher, but the ESCs still get Q_THR_MIN_PWM while disarmed. After some thinking this approach wouldn’t work anyway, because the aircraft will be armed in fast forward flight. :slight_smile:

In BLHeli I have the PWM values set to 1000-2000. Q_THR_MIN_PWM is set to 990, because the ESCs wouldn’t spin up if they get initialized at 1000. I have Q_THR_MIN set to 50, which works fine for idling.

Problems seems to be fixed in Plane 3.6 :smile:

I had issues with the Little Bee ESCs and this could be a potential reason because in your case changing PXH firmwares also changed the default RC_SPEED setting as well:

even i i am planning to buy littlebee 30a opto esc and i am using pixhwak so should i buy it or not

I recommend you buy something else. I had littlebees fail on me at multiple occasions.

so which esc are u using in ur pixhwak

I have had good experience with DYS ESCs.

so were u using oneshot 125 in ur littlebee or just pwm and also did ur esc support Blheli_s firmware and bootloader i am asking this bcz in other forum some guy told me that he had no problem with Blheli_s firmware however he didn’t mention esc brand

Can’t remember. Littlebee doesn’t support Blheli_s