QuadPlane issues

I just completed my first transition to forward flight, but I have a couple things going on with the MT that i just can’t get sorted out on my own.

First is the quad ESCs. I have a set of 45a Spedix ESCs running BLheli S along with Cobra 2210 2200kv motors. I cannot get a smooth hover(however, the motors do not come down hot). I have tied my best tuning out the oscillations but nothing i have tried has worked… it is also very sloppy in the Yaw. I tried swapping in BLHeli escs with PWM enabled but I never was able to get them to calibrate correctly. I would be at 100% throttle at mid stick, and i tried to calibrate them everyway i could think of. I also tried some SimonK escs as well and that was not any better.

Secondly, when I transitioned to FBWA, I did not feel like a had very good command of the aircraft. even after adjusting the lim_roll and lim_pitch parameters. on the ground, when i check the control surfaces, they all appear to have more than enough travel. On my second transition, at the end of the test, I was in a very shallow dive and could not pull out. i was barely able to get her flat by the time I got to the ground, luckily i was flt enough so that the only damage was a 3d printed part.

I did have Quad Assist enabled and set to 17m/s. I don’t know if the quad assist would affect forward flight that much.

any help would be greatly appreciated.

Hi Slager!
I’ve finally caught up with some ardupilot.org posts again over the holidays.

I think you are suffering from different issues at the same time so a couple of things to check would be:

  1. Have you changed the RC_SPEED parameter of the PXH to be a multiple of ESC? I see you have already found my post here: Arduplane 3.6 Quadplane - PIxhawk PX4 experiencing erratic motor using BLHeli/SimonK ESC (with solution)
  2. Have you (carefully) tested the ESC and motor combination with a Servo tester, or straight from a RC Receiver without the PXH in a loop, under load with a prop? Does it still get warm/hot? Also apart from when temperature measuring, after landing I like to run the quad motors for 20-30 seconds to cool them down with the prop wash.
  3. How hot do the motors/ESCs get after running them? Can you touch them more for 2-3 seconds without burning yourself? (as in don’t burn yourself!) Do you have a way to measure the temperature otherwise?
  4. What size/pitch props are you using on those motors?
  5. Can you post your BLHeli config file here? You can set the throttle calibration values permanently and disable ESC calibration using the BLHeli app instead of running the ESC calibration setup. Maybe compare the config to these: https://raw.githubusercontent.com/sarsky/Mozzie/master/3d/BLHeli_OBC%20Mozzie%20FWD%20-%20ZTWSpPro20AHV%20-%20Rev.%2014.3%20-%20Multi_170701.ini
  6. Do you have the QP setup as a H-Frame? Yaw control is not brilliant with small props and a high weight on the MT, and typically the quad arm movement helps somewhat to improve yaw control in a H-frame setup. Note that the RC channel numbers are set in the PXH parameters and are not the same as the motor numbers in the ardupilot docs. More on channel mappings can be found here: http://ardupilot.org/plane/docs/quadplane-frame-setup.html
  7. From the videos I can tell that the quad motors are not switching off after transition. This normally means that the transition speed hasn’t been reached. Quad assist should be fine at 17 m/s, depending on you all up weight the stall speed will be around 13-15/m/s, but it does need to know what it’s airspeed is to determine that. Are you using a pitot tube for airspeed sensing and where is it located? (maybe a picture from above?)
  8. Also what is your all up weight and have you checked the Center of Gravity flight ready, with everything onboard? That might be affecting your forward flight control.
  9. Is STALL_PREVENTION enabled? It’s critical that you have a good airspeed estimate otherwise you will loose control authority with that enabled. (Ie you can’t pull up because the PXH is trying to maintain a high airspeed and will counteract you RC inputs)
  10. What is your ARSPD_FBW_MIN set to? It should be around 13-15m/s for the MT depending on weight. This affects your stall prevention behaviour as well.

Let us know how you go. :slight_smile:

Regards
Sam

[quote=“JeffBloggs, post:2, topic:24410”]
Hi Slager!
I’ve finally caught up with some ardupilot.org posts again over the holidays.

I think you are suffering from different issues at the same time so a couple of things to check would be:

  1. Have you changed the RC_SPEED parameter of the PXH to be a multiple of ESC? I see you have already found my post here: Arduplane 3.6 Quadplane - PIxhawk PX4 experiencing erratic motor using BLHeli/SimonK ESC (with solution) [/quote]

I did change the rc_speed over to 500 after reading your post.

[quote=“JeffBloggs, post:2, topic:24410”]
2) Have you (carefully) tested the ESC and motor combination with a Servo tester, or straight from a RC Receiver without the PXH in a loop, under load with a prop? Does it still get warm/hot? Also apart from when temperature measuring, after landing I like to run the quad motors for 20-30 seconds to cool them down with the prop wash.
3) How hot do the motors/ESCs get after running them? Can you touch them more for 2-3 seconds without burning yourself? (as in don’t burn yourself!) Do you have a way to measure the temperature otherwise? [/quote]

The motors are NOT getting hot, which is odd. they sound like they should be. I have a feeling most of my quad related issues are because I’m using BL Heli S ESCs, and cannot enable to PWM output(more on that below)

[quote=“JeffBloggs, post:2, topic:24410”]
4) What size/pitch props are you using on those motors? [/quote]

6x4 (prototype 6 inch props from Luminier. they were a big performance upgrade over APC 6x4)

[quote=“JeffBloggs, post:2, topic:24410”]
5) Can you post your BLHeli config file here? You can set the throttle calibration values permanently and disable ESC calibration using the BLHeli app instead of running the ESC calibration setup. Maybe compare the config to these: https://raw.githubusercontent.com/sarsky/Mozzie/master/3d/BLHeli_OBC%20Mozzie%20FWD%20-%20ZTWSpPro20AHV%20-%20Rev.%2014.3%20-%20Multi_170701.ini [/quote]

I did try swapping in BLH escs so I could enable the pwm output but I never was able to get them calibrated correctly. I tried leaving them at 1000/2000 in BLHELI Suite but I wasn’t aware that I needed to actually diable calibration. can i do that in BLHeli Suite or do i need the app?

[quote=“JeffBloggs, post:2, topic:24410”]
6) Do you have the QP setup as a H-Frame? Yaw control is not brilliant with small props and a high weight on the MT, and typically the quad arm movement helps somewhat to improve yaw control in a H-frame setup. Note that the RC channel numbers are set in the PXH parameters and are not the same as the motor numbers in the ardupilot docs. More on channel mappings can be found here: http://ardupilot.org/plane/docs/quadplane-frame-setup.html [/quote]

I am set to H frame and I have verified the motor order. I had it wrong the first time i tries and it didn’t get off the ground.

[quote=“JeffBloggs, post:2, topic:24410”]
7) From the videos I can tell that the quad motors are not switching off after transition. This normally means that the transition speed hasn’t been reached. Quad assist should be fine at 17 m/s, depending on you all up weight the stall speed will be around 13-15/m/s, but it does need to know what it’s airspeed is to determine that. Are you using a pitot tube for airspeed sensing and where is it located? (maybe a picture from above?) [/quote]

I have not installed the pitot yet, I’m running the pixhawk 2.1 and need to figure out the wiring for most of the peripherals… It sounds like that may be alot of my issue. I left the ARSPD_FBW_MIN/MAX stock 9/22.

[quote=“JeffBloggs, post:2, topic:24410”]
8) Also what is your all up weight and have you checked the Center of Gravity flight ready, with everything onboard? That might be affecting your forward flight control.[/quote]

UAW is 2650g and I do verify CG before every flight.

[quote=“JeffBloggs, post:2, topic:24410”]
9) Is STALL_PREVENTION enabled? It’s critical that you have a good airspeed estimate otherwise you will loose control authority with that enabled. (Ie you can’t pull up because the PXH is trying to maintain a high airspeed and will counteract you RC inputs)[/quote]

It was enabled, and with no Pitot installed yet, that seems a likely culprit.

[quote=“JeffBloggs, post:2, topic:24410”]
10) What is your ARSPD_FBW_MIN set to? It should be around 13-15m/s for the MT depending on weight. This affects your stall prevention behaviour as well.[/quote]

9/22 for min/max

In Summary:

Huge thanks Sam.

Until I have the pitot installed i probably shouldn’t be messing with stall prevention or quad assist?

I need to put in the BlHeli escs again and figure out how to get them working right… 1000-2000 and disable calibration?

I reinstalled the BLH ESCs and set them all this way. I did NOT do the pixhawk calibration.

When i arm the quad i do not get any response from the motor/esc

Ok, I had to adjust the min throttle to get the motors to spin up. However, I’m still getting the same issues. The motors sound like they are at full speed at half throttle stick. If I continue from half throttle stick to full throttle stick there is no real change in motor speed. This is in Qstabalize, where I would expect a linear throttle response.

NP Slager glad to help.

You’re running a pretty heavy Mini Talon ship, with a bot of camera gear drag on the nose, so you will need to keep you airspeeds well up to stay airbourne. The heavier you make it the faster you cruise will be as well, so expect to fly fairly fast say around 20m/s most of the time. It’s a good job you have QP for landing! :slight_smile:

QP and stall assist all tend to work better with a pitot airspeed, in general QP do. Without it it depends on how good the GPS estimate is and that in turn can be out if there is a lot of wind. The estimate typically improves the longer it flies.

I’d try upping your ARSPD_FBW_ MIN up to 15 and the MAX to 27 or so. That should actually help get you to transition properly and for it to turn off the quad motors. MIN should always be over your stall speed. We set Quad Assist slightly over so that it “transitions” rather than stalls and then transitions. Makes for a smoother flying experience.

Your BLHeli settings look fine like that. To get the ESCs to arm you need to get the PXH output, when your throttle stick is down, to go under the ESC PWM MIN range. You can do that either by increasing each ESC PPM Min Throttle in Blheli Suite or by reducing the PXH as described here: http://ardupilot.org/plane/docs/arming-throttle.html?highlight=throttle%20pwm#important-rc-transmitter-calibration . Which is easier.

You have already unchecked the “Programming by TX” in BLHeli so you should be good to go then. You shouldn’t have to change the calibration again, however if there are any issues, you might need to adjust your min/max PPM values.

Regarding the prop selection we found that running a less steep prop, so in our case a 6x3.5 actually improved hover current and performance. Note that the quad part on the Talon, unlike a normal quad without wings and another forward motor, is not at all required to produce forward airspeed, so you can use props that give the best hover performance, and are small enough to stay out of the way of forward flight performance. :slight_smile:

Regards
Sam

excellent, thank you again.

I’m still concerned about not having a very linear throttle on the bench but I’ll take it out and see how it hovers tomorrow.

I’ll try those settings for the min/max. The pitot will be my first priority once I get this thing hovering decently.

Thank´s Sam for your always detailed explanations. Time to time my quadplane engage motors (plane or quad in different times during short periods) without stick movement, it´s possible to solve with rc min value that you mention?

Hi Cala
It’s likely that you Quad Assist speed is too close to your ARSPD_FBW_ MIN. Try increasing your Quad assist speed if you are safely above wing stall speed or alternatively just increase your cruise speed using TRIM_ARSPD_CM to stay above either. (aka fly faster!) :slight_smile:

Thank’s. Im going to try with that params, but that occurs on the floor, I didn’ t fly as plane yet, only simulate transition without plane prop, It loose altitude when I try to transition and now I separate power module and looks better so near to fly :smile:

Took some messing around but i finally figured it out. I put in a different set of BLHeli escs and they sound better… will hover tomorrow if work allows

I’ll try this out this weekend when I attempt more transitions and try and work out some more kinks.