Servers by jDrones

An Open Source Frsky Telemetry Script for the Horus X10,X12 and Taranis X9D,X9E and QX7 radios

I’m using an X10, with several models configured. Is it possible to enable the yaapu script on a per-model basis? I have a model with no telemetry, and for that model I would like to blank the screen rather than having the flashing and red warning that is displayed. Thank you.

Hi Anthony, sure, simply don’t define any widget pages if they are not needed. You probably cloned all models from one with the yaapu widget enabled

I will test ardupilot passthrough too. With Frsky Mavlink, we tried different setups of Frsky long range Receivers and transmitters, but no luck.

Could it be the settings?

I tried today the ardupilot passthrough, it does freeze too, but only after around 20min. Which ist longer than before.

Could you let me know, what version of firmware and settings you use? I would try to set it up the same as you.

Christian you’ll receive a much better support if you ask on the MavToPT thread, Eric will help you debug it for sure!

Thank you, I posted my problem there too.

But we have the problem also with ardupilot passthrough, but it goes longer than a couple of minutes. I tried it again an hour ago, it ran than for 35min.

I have a small plane with a PixRacer running Plane 4.0, Transmitter - x12s running 1.8.1beta2. I’m getting intermittent No_RC_Receiver messages in the message box on the x12s but Mission Planner doesn’t show any No_RC_Receiver messages. This happens in the air and on the ground. I don’t know if I actually have a problem, or it’s a config problem or a bug with just a PixRacer. I have 6 other planes with Cubes in them and they work fine. Any suggestions on what may be going on would be appreciated. Thanks

Hi,
you don’t see the message in mission planner because it’s not sent as a regular “text message” but as a sensor status message which is a bitmask.

When the FC looses the RC link ardupilot sets the equivalent of the MAV_SYS_STATUS_SENSOR_RC_RECEIVER status bit.

The frsky telemetry library periodically checks the RC status (among others) and generates the “No RC receiver” message on the fly (repeated if necessary every 5 seconds), but the message is sent ONLY on the frsky link and not injected into the mavlink stream as a text message.

in the end you probably have a problem on your RC link,

cheers.

Alex

Edit: maybe enabling RSSI logging can give you a clue of what’s going on

Hi Alex,

I will take a look at the RSSI.
Is it possible to get the No_RC_Receiver message from the Autopilot and not get a lost telemetry message from the X12s?

Hi, I gave a quick glance at the code and rc receiver input is checked at 100Hz in copter and 50Hz in plane, so I guess that the FC can very well detect an RC link loss that gets undetected by the radio.
Another possibility is that the receiver is working fine (so never looses the link with the tx) but for some reason the rcin link (rx to FC) is loosing packets (sbus crc error or interference?), this has never occurred to me so just wild guesses :slight_smile:

I’ve done quite a bit more logging and analysis and I’m inclined to agree with you concerning the rx to FC link. I’ve tried powering the RX directly from the RixRacer and also directly from a BEC, same issue. I know this isn’t directly related to your Scripts, and I don’t want to hijack your thread but your pretty knowledgeable on this and I want to ask one more question. Do you know of a way I can zoom in on the RX to FC data to see what may be going on?
Thanks Alex

I’m afraid I don’t have a solution, you might have over estimated my knowledge :slight_smile:
I’d try the usual fixes first like switching receivers and wiring but I’m sure you already did all this.
You could check the link with a scope to see the quality of the signal or if you can reproduce the issue on the bench you can capture the rcin with a logic probe but captures are short, few seconds t the most, so you really need to trace it while it happens. Sorry, out of ideas!

1 Like

We got it to work now, if other have the same problem, we used this setup:

  1. Ardupilot passthrough
  2. R9 and R9M Slim, but other R9 versions worked too
  3. Update on the latest flex Firmware and 100mw
  4. Latest Open TX Firmware 2.31 on a Horus X12

great, that’s my exact setup :slight_smile:

I work with this too all the time and never had an issue (even when this application was a separate script). I use 25mW though, which provides telemetry in EU out of the box (need to see this latest update you mention if it allows me to run at 100mW w telemetry).

Hi Alex,

I no this has nothing to do with your telemetry script, but I wanted to do a quick followup in case someone else runs across this issue.
After digging around a lot I’ve found a lot of discussion that the Frsky systems are occasionally dropping frames. Frame drops would cause the symptoms were seeing. Whats interesting is that were only seeing this issue when using a PixRacer.

Thanks

Hi can you provide some references/links?

Does the latest version on GitHub have the Graphical User Interface you posted? Or the one attached below?
image
or
image

Hi,
the current default release and beta layout is this one

x10

From the menu you can however change it to the legacy one

1 Like

Alright thanks! Have downloaded it from GitHub.

Does this only work with ardupilot flight controllers or also inav?

Servers by jDrones