Servers by jDrones

An Open Source Frsky Telemetry Script for the Horus X10,X12 and Taranis X9D,X9E and QX7 radios

Nope, Ardupilot only.

@yaapu I’m using v1.8.1 Beta2 and just upgraded my Jumper T16 to OpenTX Nightly 2.3.3N56 and seem to have lost the map. The only thing that shows up is the attitude indicator. Any thoughts? Thanks.

Hi Rolly, looks like you need to rediscover the GPS sensor perhaps?

That was it! Had to delete them then ran Discover Sensors again. And with OpenTX, Zoom Level channel is working as well!

Thank you very much.

1 Like

Ooops, after updating to v4.0.1 (from 3.9.x) I am also getting the No_RC_Receiver messages from time to time although everything works just fine (i.e. no actual RC loss at all, and no RTL nor glitches). My stuff:

  • Horus X12
  • Pixhawk (two 2.4.8 -one from HK and a random one affected by the 1MB flash bug)
  • ArduPlane
  • R9Slim+ and X4RSB

This was not happening with previous v3.9.6.

Hmm, finally got around to trying the Gas Suite, but the Horus will not see the FC telemtry when it’s passing through the gas suite. Tried deleting all sensors,etc, on 2 different receivers (Both X8R Pro).
I guess this is more a frsky issue, but figured that someone else here might have had similar issue?

Hi, can you describe the cabling and how many sensors you have on the sport bus? What ardupilot version are you using?

Currently using a custom heli build from Chris Olson.
Cuav Pixhack v3. Craft & Theory cable to the RX works as intended.
I then plug that into the Gas suite in ‘Channel in’ and plug the S.port cable into the RX and I only get the gas suite sensors.

Gas suite should work just fine, both Chris Olson and yak-54 use it on a regular basis.
@yak-54 reported an issue when having many frsky sensors chained on the sport, but that issue has been resolved in latest master.

Your gas suite setup is probably using the same sensor id used by ardupilot, you could try to change it by something else by using the provided gas suite lua script.

[1]= {

The sensor id is the number in the square brackets?

No, you should use the GasSuit-config.lua downloaded from the frsky site to change the physical ID.
By default it should be 26 which is fine so this is just a blind guess, try to change it to 14 as a test

Yeah no joy. Tried a couple of different ID, rebooting inbetween,wonder if I got a dodgy gas suite module.

The only way an external frsky sensor can interfere with ardupilot is by responding to the same sensor ID, anoher reason could be the module for some reason is not forwarding ardupilot packets on the sport bus.
To check it you could try to splice the sport cable by making an Y connector and connect rx,gas suite and FC with the same cable all in parallel.
In the end the only way to really know what’s going on is with a logic analyzer trace

Aha!, Ok, didnt realize you could do that. Will do that before I buy a new one. Thanks!

1 Like

Sorta worked. I get ‘sensor lost’ and it’s struggling to see the FC telemetry, although the screen appears to update correctly.

Do you have by any chance a spare FLVSS cell voltage sensor to add to the chain, if you can discover it in OpenTX it would give us some insight if your gas suite is misbehaving.
If you do a sensor discovery do you discover GPS?
Looks like your gas suite is responding to all sensor polls, but again you need a logic analyzer trace to properly debug your issue

Alex do you know if someone is working on injecting S-port to Ardupilot or mavlink ?

@yak-54 yes, that would be me :slight_smile:

I do not have any other frsky sensors. I do see the GPS.

@Implicit Jakob I created a PR to update the frsky scheduler in current HeliPilot master, you might give it a try. I don’t think it will solve your issue tough.

Servers by jDrones