Servers by jDrones

Which mount type for a Tarot T-3D III?

Hi there,

I have a Pixhawk running ArduCopter V3.6.11 on a Tarot 650 frame with a Tarot T-3D III gopro 3-4 mount with Turingy gopro clone. The FC is well tuned and flying stably.

Tilt and Pan are working using RC7(tilt) & RC8(pan) when controlled from the transmitter, from Aux 1 and 2 on the Pixhawk. I have the mount type set as Servo with the Tilt on SERVO9 and Pan on SERVO10.

However, when I attempt to use “Point Camera Here” in Mission Planner, or POI in an auto mission the gimbal doesn’t point in the correct direction or elevation?

Rob

Mount type servo is correct. What you might have to play with is the mount mode. I haven’t done this in a long time, so take it with a grain of salt, but I think you have to switch the mount modes between RC targeting and MAVLink.

The parameter MNT_DFLT_MODE will set default mode, which is probably set to RC. You can use Mission Planner to set it to other modes so you can tell it to look at points on the map:
image

Note that you’ll need the min and max angles and corresponding PWM values configured in the gimbal setup page for the map targeting to work.

2 Likes

Thanks.

I can set the mount targeting mode to MavLink or back to RC. When you “point camera here” it switches to MavLink targeting, but the servo outputs are incorrect. I can switch back to RC Targeting mode and the mount performs properly (that is, the mount / camera align with the RC controls.) So I think the PWM values, angles and limits are correctly configured.

Do you know if it is possible to see the calculated servo outputs when it is in MavLink targeting mode? This might give some clue as to what is happening.

Rob

Oh I see, I misunderstood your question.

If Mavlink is not pointing the gimbal in the correct direction, the angle-to-PWM mapping must be wrong. You can easily test this on the ground by using “point camera here” and entering a negative altitude to see if the gimbal turns the right way. I often had to invert my angle limits or something.

RC targeting will work either way, because it doesn’t care about what angle the gimbal is at.

1 Like

Thanks, these are the mount settings:
image

I don’t remember if Tarot uses 1000-2000 PWM range (it might be 1100-1940), but I do remember that the PWM range does not scale with the angle limits set in the Tarot software.

Use your TX to send tilt and pan PWMs and make sure that they are mapped to the angles correctly.

1 Like

Thanks - yes it does scale properly to the TX variable knobs (ie full left is 90 left on the gimbal, full down is vertically down tilt etc).

So, the FC seems to send the correctly scaled servo output when in RC targeting, but when in MavLink targeting it doesn’t seem to be calculating the PWM outputs correctly.

I’ve worked out how to display the SERVO9 and SERVO10 PWM output on MP Flight Data screen, which confirm that the PWM outputs aren’t appropriate for the selected ROI when it is MavLink targeting.

I’m not sure if that’s an error in the relative azimuth and elevation trigonometry calculation from the drone’s posn (from the GPS) to the ROI, or if having calculated the angles correctly it’s not scaling to a PWM output correctly.

I’m not sure what to try next.

Okay just to be clear: did you change the angle limits in the Tarot gimbal software? And did you make sure that the gimbal moves when you change the PWM near the min/max limits (eg, does it move when you go from 1000 PWM to 1030)?

On my Tarot T3D III, I set tilt to go from 0 to 90 degrees in the Tarot software, but in Mission Planner, I had to set the PWM range to be something like 1500 to 1900 to achieve those angles.

Hi sorry for the long delay in responding.

Yes I’ve set the angle limits in both the Tarot Gimbal software and in Mission planner.

It all works fine in RC Targeting mode, but not when the FC is calculating the angles. I think there must be a problem in the FC code for these calcs, but haven’t looked in the source yet.

These are my settings with the Tarot T-3D.

MNT_ANGMAX_PAN   4500.000000
MNT_ANGMAX_ROL   4500.000000
MNT_ANGMAX_TIL   0.000000
MNT_ANGMIN_PAN   -4500.000000
MNT_ANGMIN_ROL   -4500.000000
MNT_ANGMIN_TIL   -9000.000000
MNT_DEFLT_MODE   1.000000
MNT_JSTICK_SPD   0.000000
MNT_LEAD_PTCH    0.000000
MNT_LEAD_RLL     0.000000
MNT_NEUTRAL_X    0.000000
MNT_NEUTRAL_Y    -90.000000
MNT_NEUTRAL_Z    0.000000
MNT_RC_IN_PAN    0.000000
MNT_RC_IN_ROLL   0.000000
MNT_RC_IN_TILT   0.000000
MNT_RETRACT_X    0.000000
MNT_RETRACT_Y    0.000000
MNT_RETRACT_Z    0.000000
MNT_STAB_PAN     0.000000
MNT_STAB_ROLL    0.000000
MNT_STAB_TILT    0.000000
MNT_TYPE         1.000000
SERVO10_FUNCTION 7.000000
SERVO10_MAX      1890.000000
SERVO10_MIN      1520.000000
SERVO10_REVERSED 1.000000
SERVO10_TRIM     1520.000000
SERVO9_FUNCTION  0.000000
SERVO9_MAX       1900.000000
SERVO9_MIN       1100.000000
SERVO9_REVERSED  0.000000
SERVO9_TRIM      1500.000000

I don’t have RC targeting enabled, but Mavlink targeting and ROI work perfectly. I have it set to tilt from 0 (straight forward) to -90 (straight down). Note the SERVO10 PWM limits - this is what was needed to get the gimbal to go from 0 to -90, even though I changed the angle limits in the Tarot software. The Tarot software does not rescale the PWM limits to match the angle limits you set.

I don’t use the pan, but if I did, I’d set SERVO9_FUNCTION = 6 and change the PWM limits to match the ±45 degrees that I have set in the MNT_ params. It would probably be something like 1400 to 1600 PWM, since the gimbal is capable of ±125 degrees.

Servers by jDrones