VTOL -- freeman2100 vertical take-off and landing fixed wing +pixhawk

I’m lost myself. Here’s a link to a post which links to the MFE Github. I think @GregCovey is using custom firmware so I don’t know if the parameter file he shared will be useful without the same custom firmware.

I’ve always thought the hardware part of making robots was the easier than writing the software to control the robots. That said, I always wrote my own software to control my ground based robots. Using ArduPilot will hopefully make the software side of a flying robot easier than building the hardware.

Where did you purchase the Freeman 2300? I ordered from UUURC Store four days ago and the order hasn’t shipped yet. I’m wondering if there’s a better store to use.

Thanks. Have to see what differences there are between the solutions in this thread. Dont want to invent the wheel again. :slight_smile: Just tweak it a little.

We got our Freeman 2300 oct 24 2019. :slight_smile: Dont remember from where it was, maybe Taobao. !?

Hey Greg. Sorry another ESC question. Is there such a thing as a 100amp ESC running blheli32 and telemetry. Thinking of the forward flight motor and the esc for them. Just curious as I am dreaming about doing one of these vtols.


1 Like

iFlight makes an 80A BLHeli_32’s to 8S. I think Gal had the 55A version of these on his X8. 100A ? Perhaps not with BLHeli_32. There are others with proprietary protocols. Check out X-Class multirotor stuff.

1 Like

Thanks Dave.
Actually I just checked the motor and 80amp is what it’s asking for,
I will have a look, that said not sure if quadplanes even use esc telemetry.

cheers and thanks

what size and kv are you using for puller motor ?

Hello everyone!

I am looking for somw advice on how to mount a mapping camera in the fuselage of the believer.

Currently I have the opening covered with a plastic cover. But this causes the pictures to be blurry. Considering that I am taking the airspeed static measurement from inside the fuselage, I think if I remove the cover, I will have to recalibrate the airspeed.

Any comments on how I can improve this setup? Pictures are attached.

Hi Ali,

Removing the plastic cover will not affect your air speed sensor. No recalibration is needed.



Thanks Greg! Your insight is much appreciated.

Hi Greg, I’m setting up the front tilt rotor servos of a Freeman 2300 VTOL following the arduplane documentation on quadplane support.

The documentation says that this is done with transmitter off and the Manual and QStabilize modes used in this process is accessed through the Set Mode button in the Action tab of the Data menu of Mission Planner. However, there is no Manual or QStabilize modes when I press the Set Mode button.
I would appreciate any advise you can give. Thanks.

Hi Jose,

It’s one of those situations where you need to have Mission Planner connected to a quadplane. Once connected, the pull-down menu to the left of the “Set Mode” button will display all the appropriate flight modes. You can then select the mode you want before pressing the button. See the image below.


Hi Greg,

Thanks for your response. But connecting the Freeman 2300VTOL to Mission Planner, this is what I got.
Mission Planner Set Mode
Please note that the items in the pull-down menu are entirely different from what you got. In fact I don’t see any Q_ or quadplane parameters and the fixed-wing parameters don’t include Manual. Note also that my Mission Planner version has been updated to 1.3.75 while yours is 1.3.74. My firmware version is V3.10.0-dev [effeebfe], which was given to me by MFE, while yours is V3.9.8.


I was using an older Wing Z84 Quadplane for my example photo, not the Freeman. However, regardless of Ardupilot Plane firmware version or of the GCS version, the result should be the same.

I cannot see your image because it is so small. There seems no way to click on it for enlargement.

If I have to guess, I would say that Q_ENABLE is set to 0 on your parameters. This would make Mission Planner think that it is not connected to a Quadplane.

Have you loaded the .param file from MFE to go with your firmware? If not, you need to load it, reboot the flight controller, and load it a second time with Q_ENABLE set to 1.


Hi Greg,

I did have Q_ENABLE set to 1.

I have also loaded this param file from MFE. Loaded once, rebooted, loaded again and rebooted. Only thing is I have already set Q_ENABLE to 1 even before the first time I loaded the param file.
MFE Freeman 2300 .param (19.5 KB)
I still got the same drop-down menu as shown below.

Do you think it would help if I revert to Mission Planner 1.3.74? Thanks.


Hi Jose I 'm using 1.3.75 and have Q modes available. Just in case… when you load the parameter file you need to write the file as well, otherwise it doesn’t save to the flight controller.

1 Like


I’m not sure what else Mission Planner needs to think it is connected to a Quadplane.

Perhaps, as a workaround, you can go into the Flight Modes section under the Setup button and select the Manual and QStabilize modes so that your radio can enable then for your setup of the tilt servos.

Hi Steve,
I did write the param file after loading it but didn’t make a difference

Hi Greg,
Thanks for this suggestion, did it and it works.

Finally got the Q modes. I reverted Mission Planner to version 1.3.74.
MP Set Mode

It’s good to know. In the Mission Planner forum, there does appear to be an issue with v1.3.75. Andras has a workaround that may help below. The thread is here.